forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/oniguruma: Version bump (6.6.1).
- Loading branch information
Showing
3 changed files
with
68 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST onig-5.9.5.tar.gz 587874 SHA256 9f49ae7819a5f47e25449d0e4b010d479f7868a24a7b9884b47041b49a76438a SHA512 3ba3c94c5e52c80c680ebf1d19be53fa5a94a11d622e0282184c7a9c8cc6676f1926b97d12aafc66514071e65cd7de2bd4632afb053c69b01ddb8b581e878252 WHIRLPOOL 4f8a52fc682c15a96660049159e98ddd9f68170e2cba3948f73f3105a266bce8b4c42329b4dc0d6f94472fd9139bbd9a8ebbf3f7351a95c868e78999ce276ece | ||
DIST onig-5.9.6_p1.tar.gz 605920 SHA256 ac34ae0624296b59ff9ad9a2e93f2b1cdd775ca87057a42d27e551b7a76ff7b4 SHA512 5c874a92acab19e7b228e855cee2d8c55648d3c0c25213127e67bba7f510ec68cb5d64999cf629ffa509745e1b0bd13dd80afbdcef3ba1d4bb8f3d0ee3616f48 WHIRLPOOL be0f030469cbaef0f196190a18725eb4f516b3b78c1a3484fe602462df1ada48fa848fc59f619f0089a352293825f809034c18e5964802fc964032d94e10f03b | ||
DIST onig-6.4.0.tar.gz 900425 SHA256 cf43ddc5167aea260c4297c76b0dd5e1e6d67aa39319db667347d4d0706ff695 SHA512 476f2110f09eae9b27e0da4b995fa9db46fe6f98f5ef8700b9f1966f9b4bf6db680c6e9e67e1d8d81e759fd8d1787af39c4b38d6681ee4b6405a970c18d583fa WHIRLPOOL bc89b0217a89c70234d2b167fbe68e7588104c812d4df18e64964511cf764786d53a50e87561438d317f435ab30f179990202fc8892b8ab4e85d1cbf8b21c6b9 | ||
DIST onig-6.6.1.tar.gz 943490 SHA256 8f9731f9e48666236a1678e2b4ead69be682eefba3983a714b6b57cf5ee14372 SHA512 ce9ac1336e2782fcfdac8cb4a257162f57dd8c2be20f74771a1ab9671b5926ea9c9fc07e2f4b04d80a2138a6e4c0e3295ac3f257e4424acf888e343870a377cc WHIRLPOOL c6ed29ca7b4f2ce83d4d17daf7292689b420dd5a5a82e0c1c6b2707dae5b5af4227ebcf4b495096a084c45c23b96df5c924e5cd0ea238ba5246d56d99c460cbf |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
https://github.com/kkos/oniguruma/issues/68 | ||
https://github.com/kkos/oniguruma/commit/1337755c2758a62057ef95f1cff1b9466f533301 | ||
|
||
--- /sample/Makefile.am | ||
+++ /sample/Makefile.am | ||
@@ -4,7 +4,7 @@ | ||
LDADD = $(lib_onig) | ||
|
||
AM_LDFLAGS = -L$(prefix)/lib | ||
-AM_CPPFLAGS = -I../src -I$(includedir) | ||
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(includedir) | ||
|
||
TESTS = encode listcap names posix simple sql syntax user_property bug_fix | ||
|
||
--- /test/Makefile.am | ||
+++ /test/Makefile.am | ||
@@ -3,7 +3,7 @@ | ||
|
||
AM_LDFLAGS = -L$(prefix)/lib | ||
AM_CFLAGS = | ||
-AM_CPPFLAGS = -I../src -I$(includedir) | ||
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(includedir) | ||
|
||
TESTS = test_utf8 testc testp testcu | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
inherit autotools multilib-minimal | ||
|
||
MY_P="onig-${PV}" | ||
|
||
DESCRIPTION="Regular expression library for different character encodings" | ||
HOMEPAGE="https://github.com/kkos/oniguruma" | ||
SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0/4" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris" | ||
IUSE="combination-explosion-check crnl-as-line-terminator static-libs" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-build.patch" | ||
) | ||
|
||
DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,FAQ,RE}{,.ja} doc/UNICODE_PROPERTIES) | ||
|
||
src_prepare() { | ||
default | ||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" econf \ | ||
$(use_enable combination-explosion-check) \ | ||
$(use_enable crnl-as-line-terminator) \ | ||
$(use_enable static-libs static) | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
find "${D}" -name "*.la" -delete || die | ||
} |