Skip to content

Commit

Permalink
app-misc/yq-2.9.2-r1: revbump, add py38 and pypy{,3}, kill extra deps
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
patrick-mclean authored and chutz committed Dec 3, 2019
1 parent 15f0c6f commit 4c8f90f
Showing 1 changed file with 42 additions and 0 deletions.
42 changes: 42 additions & 0 deletions app-misc/yq/yq-2.9.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )

inherit distutils-r1

DESCRIPTION="Command-line YAML processor - jq wrapper for YAML documents"
HOMEPAGE="https://yq.readthedocs.io/ https://github.com/kislyuk/yq/ https://pypi.org/project/yq/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="app-misc/jq
>=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/xmltodict[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/toml[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
)"

distutils_enable_tests unittest

python_prepare_all() {
sed -e 's:unittest.main():unittest.main(verbosity=2):' \
-i test/test.py || die

sed -r -i 's:[[:space:]]*"coverage",:: ; s:[[:space:]]*"flake8",::' \
setup.py || die

distutils-r1_python_prepare_all
}

python_test() {
"${EPYTHON}" test/test.py || die "tests failed under ${EPYTHON}"
}

0 comments on commit 4c8f90f

Please sign in to comment.