Skip to content

Commit

Permalink
dev-db/kdb: 3.2.0 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.63, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Apr 18, 2019
1 parent c1a578a commit 4c99c36
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/kdb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kdb-3.1.0.tar.xz 543780 BLAKE2B d874765758e245fc939bf88312b064d2dcff3460b2c9e968277e0ce7b8821314273cb3086e821645f9d7605de1a4268e25d11c40f8bf847a8dc98c410bd4d9eb SHA512 f94f1ff87cb5133570f7e9b0ab48202a516eabe1c3f2ed750cd1794800d9b9936bbd62e1479ca6877c293f6473b7f4e2d4a144b928b5bc0f228af327131b43c2
DIST kdb-3.2.0.tar.xz 650180 BLAKE2B 306152b37c2ecc670d26a2df2ae8acb950505ecb37c4994f4debd1b80c8b2ee94252658fe28b59255d9ad0d350375171f3b43dc9e94949417c3aa9ed167134fe SHA512 7df22f2c5b6e20ae3de71cb6c76b234d2f1f33b2abcdffa85be313c63d067a40a85ed102b6256207315db08ced5d69f8bc40afdf84a188463713a6b2ffdb2df7
52 changes: 52 additions & 0 deletions dev-db/kdb/kdb-3.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_QTHELP="true"
KDE_TEST="true"
PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit kde5 python-any-r1

DESCRIPTION="Database connectivity and creation framework for various vendors"
[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"

LICENSE="LGPL-2+"
SLOT="5/4"
KEYWORDS="~amd64 ~x86"
IUSE="debug mysql postgres sqlite"

BDEPEND="${PYTHON_DEPS}
dev-qt/linguist-tools:5
"
DEPEND="
$(add_frameworks_dep kcoreaddons)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
dev-libs/icu:=
mysql? ( dev-db/mysql-connector-c:= )
postgres? (
$(add_qt_dep qtnetwork)
dev-db/postgresql:*
)
sqlite? ( dev-db/sqlite:3 )
"
RDEPEND="${DEPEND}"

pkg_setup() {
python-any-r1_pkg_setup
kde5_pkg_setup
}

src_configure() {
local mycmakeargs=(
-DKDB_DEBUG_GUI=$(usex debug)
$(cmake-utils_use_find_package mysql MySQL)
$(cmake-utils_use_find_package postgres PostgreSQL)
$(cmake-utils_use_find_package sqlite Sqlite)
)

kde5_src_configure
}

0 comments on commit 4c99c36

Please sign in to comment.