Skip to content

Commit

Permalink
media-video/parole: Bump to 1.0.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Mar 1, 2018
1 parent 9637815 commit 4d1ca30
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/parole/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST parole-0.8.1.tar.bz2 814827 BLAKE2B 54c6753da5f9e6e6eef70bfbe13dd6496687fb35905ac8222a8ab96d3a46bc2f718a5d87dc44abec2c15cfde503f839960b0bcb51c8a58b5c978df830eec5207 SHA512 73c27022331828adb7b5805245ce97f03f4848c569125529436e82651da61e28f4d4a834468d6e4c165754f2fd9664eded9a7e15fc86f067d9b2c7c54afff3ee
DIST parole-0.9.2.tar.bz2 922024 BLAKE2B 95075aae3a1ba5595dc28c5610539a7c330802a03e4b53cee221ce131cb02df72b582000e98349d624fd1834cb97118ce75ce54e8acf820b1380ea2c24ce3fd5 SHA512 c3eee9501648bbb058a22398f2b8ae3727036718052b9e93ebb6f7dc3eb88ce1cfe8d443a5abf7d0cebc2853e14f42fed520ce17d8c7e03dacdcafb57247fb4d
DIST parole-1.0.0.tar.bz2 900499 BLAKE2B d6a1eb21846426781a712f33b7cf8f412b17b9a3e02b1ef15b6ff742687efc70a3e3f0ae8124ed2226a1cf00022c7ef0650c8e1c1b6e3279b111891e8c3e651e SHA512 0581fed93d2a09a3d9ec9cf1bb68a298ccd47676b22d0824495136ee9d785290b8465af8c12b5ecd34a46936f7433bf96dd559e6252a8f1af46c0e2f9256c864
67 changes: 67 additions & 0 deletions media-video/parole/parole-1.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit gnome2-utils xdg-utils

DESCRIPTION="A simple Xfce4 media player using GStreamer"
HOMEPAGE="https://docs.xfce.org/apps/parole/start"
SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86"
IUSE="clutter libnotify taglib"

COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.32:2=
media-libs/gstreamer:1.0=
media-libs/gst-plugins-base:1.0=
sys-apps/dbus:0=
>=x11-libs/gtk+-3.20:3=
x11-libs/libX11:0=
>=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
>=xfce-base/libxfce4util-4.11:0=
>=xfce-base/xfconf-4.10:0=
clutter? (
>=media-libs/clutter-1.16.4:1.0=
>=media-libs/clutter-gtk-1.4.4:1.0=
<x11-libs/gtk+-3.22:3
)
libnotify? ( >=x11-libs/libnotify-0.7:0= )
taglib? ( >=media-libs/taglib-1.6:0= )"
RDEPEND="${COMMON_DEPEND}
media-plugins/gst-plugins-meta:1.0"
DEPEND="${COMMON_DEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
x11-proto/xproto"

DOCS=( AUTHORS ChangeLog README THANKS TODO )

src_configure() {
local myconf=(
$(use_enable clutter)
$(use_enable taglib)
$(use_enable libnotify notify-plugin)
)

econf "${myconf[@]}"
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}

pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_desktop_database_update
gnome2_icon_cache_update
}

0 comments on commit 4d1ca30

Please sign in to comment.