forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/teamspeak-client-bin: 3.0.19.4 version bump, quazip[-qt4]
Force dev-libs/quazip[-qt4] so that it installs necessary compat symlink. Gentoo-bug: 598136 Package-Manager: portage-2.3.0
- Loading branch information
Showing
3 changed files
with
83 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,4 @@ | ||
DIST TeamSpeak3-Client-linux_amd64-3.0.19.1.run 37071678 SHA256 b0d8e208b95b3b3f13e53a7930482599d205e2b769876763ad40c5c9f266759c SHA512 6db1f21c104935bfbaf3936f22ad6c8da79d1c69816576651de49d0354fbbf0d744157983ee486a522b89d98e6436550ca3be6153c5dcda1209ad9a00e70d24d WHIRLPOOL acadd3686648fe4176944ca1d2e937ac4e8843d0334b28717dc1e96349157315d1fb5f6ff483f16b072cdc750a6733952673cde4140e0135111fd5e4b7f2d5f9 | ||
DIST TeamSpeak3-Client-linux_amd64-3.0.19.4.run 37054436 SHA256 f74617d2a2f5cb78e0ead345e6ee66c93e4a251355779018fd060828e212294a SHA512 fca7303a9c75bbab4945c9336c78115b28b3f14b278ffccb8453d7b29eabf1cd7147697bf0042bc625a9108db653468e8f0ebc4b29cf00d48f5438c919efa8c7 WHIRLPOOL e979cbe22a4109aabffc9b77a9b6e625e1e9e819c248d18795967a007bc1b92fe726a1fb33063a1551e9853d5bd15473ed1fd311f413e33e451f8a4b5eeb001a | ||
DIST TeamSpeak3-Client-linux_x86-3.0.19.1.run 36646880 SHA256 ddfe07713e09e009d4268eb14c5802a0afffc1a1aed34c2da09153b5a8d456c5 SHA512 c8b9a3426ab0516ab0c63d72f63d03016e5abe4f03eae112d93fdb813d49c0170de6e8951acaec20a4f64c25cafc6a64f0c3122cba88553daa4aedcb49b4aaac WHIRLPOOL 7f14e0bcd9bc596b0a52eccc8ac839327dcd3e15a36d647b1554fedc801167a7a9baa17eb96dfe349a027b3f6b02eda3319927a483016bd87bba52ca9b38e722 | ||
DIST TeamSpeak3-Client-linux_x86-3.0.19.4.run 36627204 SHA256 e11467dc1732ddc21ec0d86c2853c322af7a6b8307e3e8dfebc6b4b4d7404841 SHA512 ec52a78e5753716ba81602ecd60a2440a08ec4fc777d7d560dd714ae4b80fe7befceb5271c11d2eae46dbc3cbf71f0eca4976a44510bc66a51f5ebe39745d2db WHIRLPOOL f54b4a0ce97a2e24b4bd6873db89cbca15b47f992f390d66458e4ff00b5a0febb54a5d6402936019fb854c183739fab453a9909c8c1977593e712daf59bdb522 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
79 changes: 79 additions & 0 deletions
79
media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,79 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit eutils unpacker | ||
|
||
DESCRIPTION="TeamSpeak Client - Voice Communication Software" | ||
HOMEPAGE="http://www.teamspeak.com/" | ||
SRC_URI=" | ||
amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run ) | ||
x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )" | ||
|
||
LICENSE="teamspeak3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="alsa pulseaudio" | ||
|
||
REQUIRED_USE="|| ( alsa pulseaudio )" | ||
|
||
RDEPEND=" | ||
dev-libs/quazip[-qt4,qt5] | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5[accessibility] | ||
dev-qt/qtnetwork:5 | ||
dev-qt/qtsql:5[sqlite] | ||
dev-qt/qtwidgets:5 | ||
sys-libs/glibc | ||
sys-libs/zlib | ||
alsa? ( media-libs/alsa-lib ) | ||
pulseaudio? ( media-sound/pulseaudio )" | ||
|
||
RESTRICT="mirror strip" | ||
|
||
S="${WORKDIR}" | ||
|
||
pkg_nofetch() { | ||
elog "Please download ${A}" | ||
elog "from ${HOMEPAGE}?page=downloads and place this" | ||
elog "file in ${DISTDIR}" | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# Remove the qt-libraries as they just cause trouble with the system's Qt, see bug #328807. | ||
rm libQt* || die "Couldn't remove bundled Qt libraries." | ||
|
||
rm -r platforms sqldrivers qt.conf || die "Couldn't remove bundle Qt files." | ||
|
||
# Remove unwanted soundbackends. | ||
if ! use alsa ; then | ||
rm soundbackends/libalsa* || die | ||
fi | ||
|
||
if ! use pulseaudio ; then | ||
rm soundbackends/libpulseaudio* || die | ||
fi | ||
|
||
# Remove quazip | ||
rm libquazip.so || die | ||
|
||
# Rename the tsclient to its shorter version, required by the teamspeak3 script we install. | ||
mv ts3client_linux_* ts3client || die "Couldn't rename ts3client to its shorter version." | ||
} | ||
|
||
src_install() { | ||
insinto /opt/teamspeak3-client | ||
doins -r * | ||
|
||
fperms +x /opt/teamspeak3-client/ts3client | ||
|
||
dobin "${FILESDIR}/teamspeak3" | ||
|
||
make_desktop_entry teamspeak3 TeamSpeak3 \ | ||
"/opt/teamspeak3-client/pluginsdk/docs/client_html/images/logo.png" \ | ||
Network | ||
} |