Skip to content

Commit

Permalink
app-shells/fish: Bump to version 2.7_beta1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
Lars Wendler committed Nov 7, 2017
1 parent e81cf71 commit 4e027d1
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/fish/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST fish-2.4.0.tar.gz 3455874 SHA256 06bbb2323360439c4044da762d114ec1aa1aba265cec71c0543e6a0095c9efc5 SHA512 b27a2291c284fda7a12b3cd5dcba8dfcbf2738f50de40d9aac1500afa3bd98be04b4f67d7e6d3bb2f808c11a8c2dd6b1b5cc2dfe3e8e0e7d1bc88f8d8994d57b WHIRLPOOL abb9c31237a33553b25920fe3284f4ca90941aed2b8f1ec4b69fdb4231f7b2585f0292bc647ffe3acf88f6b01ac61931f615fa9a56ede35a8182e3a69aa11861
DIST fish-2.5.0.tar.gz 3496831 SHA256 f8c0edadca2de379ccf305aeace660a9255fa2180c72e85e97705a24c256b2a5 SHA512 6d94bb70a5f1cefaada4d10ac845992f87c9bfc8c253f38bdfcc3a573a35503d825c9487d2ce8ef3819713594ab7b54ebf6c89fe3362c7010c63dbefc99b424d WHIRLPOOL a16d5f75e95573f2b766527fb124d99083a7ab84522a4826cd5b3aaf3a73ae6728f30defbd0598698b496f279f686eddcb4e81779767e89888037abe0b908849
DIST fish-2.6.0.tar.gz 3575346 SHA256 7ee5bbd671c73e5323778982109241685d58a836e52013e18ee5d9f2e638fdfb SHA512 d4ded5ce24600e85673a7bb016e9dc36bce999b27f40e6b1ce0b9ca49a421be2d444d9d2b6f178f6eee963e59daa4a65df4c3de2a8086a610486f758fcfb0ed1 WHIRLPOOL 3316c1bd8778a1eba5b7b65edf28495ec89ec01ba3d0bc26cbc64ce69bfcd73a538c9a5463c9385f55689e3e680241d37e36bfec309f87c6ee98934f74fd7aa4
DIST fish-2.7b1.tar.gz 5760393 SHA256 326dbea5d0f20eba54fa0b0c5525e58b4a39ebd8c52c14cfffc5f4d6cdf55385 SHA512 75e9351eb8179d9a21915d6cbc8d042f595e9fd3120f2ab7ad503fde5d59c9d965cc01ec599c89d7e6c9b3ef3e175b91e6c750427e146a0649434ee121a7c17c WHIRLPOOL 3ec2707d4bd2d8726c969e7aadd665d29adc89d1e6e78918a509c275ec289c1cfbdab4e6271b15ad2bd47a292dff00c312ed0735e1ef34ae66dcbf5c8c6bcae1
84 changes: 84 additions & 0 deletions app-shells/fish/fish-2.7_beta1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_PV="${PV/_beta/b}"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="fish is the Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"
SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
[[ "${PV}" = *_* ]] || \
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="nls"

RDEPEND="
>=dev-libs/libpcre2-10.21[pcre32]
sys-libs/ncurses:0=
"
DEPEND="
${RDEPEND}
sys-devel/bc
nls? ( sys-devel/gettext )
"

S="${WORKDIR}/${MY_P}"

src_configure() {
# Set things up for fish to be a default shell.
# It has to be in /bin in case /usr is unavailable.
# Also, all of its utilities have to be in /bin.
econf \
docdir="${EPREFIX}"/usr/share/doc/${PF} \
--bindir="${EPREFIX}"/bin \
--without-included-pcre2 \
$(use_with nls gettext)
}

src_compile() {
emake V=1
}

src_install() {
emake DESTDIR="${D}" V=1 install
}

src_test() {
if has_version ~${CATEGORY}/${P} ; then
emake test
else
ewarn "The test suite only works when the package is already installed"
fi
}

pkg_postinst() {
elog "fish is now installed on your system."
elog "To run fish, type 'fish' in your terminal."
elog
elog "It is advised not to set fish as a default login shell."
elog "see bug #545830 for more details."
elog "Executing fish using ~/.bashrc is an alternative"
elog "see https://wiki.gentoo.org/wiki/Fish#Caveats for details"
elog
elog "To set your colors, run 'fish_config'"
elog "To scan your man pages for completions, run 'fish_update_completions'"
elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
elog
elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
elog "browser of your choice to get acces to ${PN}'s help system:"
elog " BROWSER=\"/usr/bin/firefox\""
elog
elog "In order to get lzma and xz support for man-page completion please"
elog "emerge one of the following packages:"
elog " dev-python/backports-lzma"
elog " >=dev-lang/python-3.3"
elog
elog "If you have issues with cut'n'paste in X-terminals, install the"
elog "x11-misc/xsel package."
elog
elog "Have fun!"
}

0 comments on commit 4e027d1

Please sign in to comment.