Skip to content

Commit

Permalink
sys-fs/udev: 235 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
williamh committed Oct 6, 2017
1 parent 291a0bf commit 4e259b7
Show file tree
Hide file tree
Showing 2 changed files with 330 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/udev/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST systemd-216.tar.xz 3612960 SHA256 945d3db7d840d6ffe98aa68394428e13317161ae7
DIST systemd-225.tar.gz 3878442 SHA256 b2f576bb3688e9315f2f49b98e141ac6f964567370e98ebd8fd7332a0a6f9701 SHA512 35b3946509c7b01660da4370d3c51ff0e6a537dadd9dbb0a039c4f7ed552fd4e02ebac6eb8a788f61f1e3ba99444238d959051dd004c174b027729a80368ac19 WHIRLPOOL 47cd3b5690dafdf3c0ef6a9767e947666b1853541f8aefd17eb5c07eee1477daf32f3b249b04327b1c56d8ec430745725383750b97755bb6cf594d354a7ffdf8
DIST systemd-233.tar.gz 4660737 SHA256 8b3e99da3d4164b66581830a7f2436c0c8fe697b5fbdc3927bdb960646be0083 SHA512 5ad5329ea116d973cf67096f7e7ad28e9ea0905696e9451291f1d25e5064f4a9bfcfae87e912996c6a38397e9f4a148d4ccecfa9b70f7ecdf04deadb61784c8e WHIRLPOOL ce19f6a546b8f899cfa952e49d47f063fd29186be4a53391bc30ea2c487eb2c140a74ad843a1dc499bb61bba3e9ca055613852291e38b85af5d79c59409dc176
DIST systemd-234.tar.gz 4800186 SHA256 da3e69d10aa1c983d33833372ad4929037b411ac421fb085c8cee79ae1d80b6a SHA512 762336a7d96c6583cf71cad62efce95a0ed93cd0a0d7251f128d10dba8200c0c8df0e5a7d168179ababa5b221295a231e73b7e7ea2697cb3fb5c1b33538efa68 WHIRLPOOL 9ff9f25ce82514db969a427eee51c0483b2bcaaa611f93c1fc17c356ea25eee712217708c54101ecaafd835cd8ac988b16e8ad411b48541a32442b9a0d148f07
DIST systemd-235.tar.gz 6586406 SHA256 25811f96f5a027bf2a4c9383495cf5b623e385d84da31e473cf375932b3e9c52 SHA512 243f2eb5340fa37dd1286eaa63e83387bda9e03953af266cd6196a37535a13491482caf14c6ab10608bba4ed23b6c41923608e52017e0c26988ed72ddd2b9993 WHIRLPOOL 05e50b31f7b3b1cd756abd1580dddae0e114953857564133784fc43b9ecd0e203ee534aaf76531ca7af5c43b03b9b73c6cbbbb1caf5afb17502555cc52fe06cd
DIST udev-216-patches-2.tar.xz 1264 SHA256 18b7b8f852f11c2ac2a58458462ce686ebec48859562df99c5b9c29c95ddfa3c SHA512 1f5912f3bbc3e40a4efad9de8b1fab2b3a750f3f23c9f2e33a581658959d22cf23f9ff1b8f51597874e7bca1d0f757f37fd5550b4112160261559524eda261f4 WHIRLPOOL 8f93f982de2d1fa10f7e3c6541c559f2c881730276498b14d4d27b8577bdb340d49b2dc7a50a40e8a13fcabbbabb3dfa5f1605aa842e325d12c17e82d2dc787b
329 changes: 329 additions & 0 deletions sys-fs/udev/udev-235.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,329 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit bash-completion-r1 linux-info meson ninja-utils multilib-minimal toolchain-funcs udev user versionator

if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/systemd/systemd.git"
inherit git-r3
else
SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
fi

DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd"

LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
IUSE="acl +kmod selinux"

RESTRICT="test"

COMMON_DEPEND=">=sys-apps/util-linux-2.27.1[${MULTILIB_USEDEP}]
sys-libs/libcap[${MULTILIB_USEDEP}]
acl? ( sys-apps/acl )
kmod? ( >=sys-apps/kmod-16 )
selinux? ( >=sys-libs/libselinux-2.1.9 )
!<sys-libs/glibc-2.11
!sys-apps/gentoo-systemd-integration
!sys-apps/systemd
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20130224-r7
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
DEPEND="${COMMON_DEPEND}
dev-util/gperf
>=dev-util/intltool-0.50
>=dev-util/meson-0.40.0
dev-util/ninja
>=sys-apps/coreutils-8.16
virtual/os-headers
virtual/pkgconfig
>=sys-kernel/linux-headers-3.9
app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
dev-libs/libxslt"
RDEPEND="${COMMON_DEPEND}
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10"
PDEPEND=">=sys-apps/hwids-20140304[udev]
>=sys-fs/udev-init-scripts-26"

S=${WORKDIR}/systemd-${PV}
EGIT_CHECKOUT_DIR=${S}

pkg_setup() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
CONFIG_CHECK="~BLK_DEV_BSG ~DEVTMPFS ~!IDE ~INOTIFY_USER ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2 ~SIGNALFD ~EPOLL ~FHANDLE ~NET ~!FW_LOADER_USER_HELPER ~UNIX"
linux-info_pkg_setup

# CONFIG_FHANDLE was introduced by 2.6.39
local MINKV=2.6.39

if kernel_is -lt ${MINKV//./ }; then
eerror "Your running kernel is too old to run this version of ${P}"
eerror "You need to upgrade kernel at least to ${MINKV}"
fi

if kernel_is -lt 3 7; then
ewarn "Your running kernel is too old to have firmware loader and"
ewarn "this version of ${P} doesn't have userspace firmware loader"
ewarn "If you need firmware support, you need to upgrade kernel at least to 3.7"
fi
fi
}

src_prepare() {
if ! [[ ${PV} = 9999* ]]; then
# secure_getenv() disable for non-glibc systems wrt bug #443030
if ! [[ $(grep -r secure_getenv * | wc -l) -eq 27 ]]; then
eerror "The line count for secure_getenv() failed, see bug #443030"
die
fi
fi

cat <<-EOF > "${T}"/40-gentoo.rules
# Gentoo specific floppy and usb groups
ACTION=="add", SUBSYSTEM=="block", KERNEL=="fd[0-9]", GROUP="floppy"
ACTION=="add", SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="usb"
EOF

local PATCHES=(
"${FILESDIR}/234-uucp-group.patch"
)

default

if ! use elibc_glibc; then #443030
echo '#define secure_getenv(x) NULL' >> config.h.in
sed -i -e '/error.*secure_getenv/s:.*:#define secure_getenv(x) NULL:' src/shared/missing.h || die
fi
}

meson_multilib_native_use() {
if multilib_is_native_abi && use "$1"; then
echo true
else
echo false
fi
}

multilib_src_configure() {
local emesonargs=(
-Dacl=$(meson_multilib_native_use acl)
-Defi=false
-Dkmod=$(meson_multilib_native_use kmod)
-Dselinux=$(meson_multilib_native_use selinux)
-Dlink-udev-shared=false
-Dsplit-usr=true
)
meson_src_configure
}

src_configure() {
# Prevent conflicts with i686 cross toolchain, bug 559726
tc-export AR CC NM OBJCOPY RANLIB
multilib-minimal_src_configure
}

multilib_src_compile() {
# meson creates this link
local libudev=$(readlink src/libudev/libudev.so.1)

local targets=(
src/libudev/${libudev}
)
if multilib_is_native_abi; then
targets+=(
systemd-udevd
udevadm
src/udev/ata_id
src/udev/cdrom_id
src/udev/collect
src/udev/mtd_probe
src/udev/scsi_id
src/udev/v4l_id
man/udev.conf.5
man/systemd.link.5
man/hwdb.7
man/udev.7
man/systemd-udevd.service.8
man/udevadm.8
)
fi
eninja "${targets[@]}"
}

multilib_src_install() {
local libudev=$(readlink src/libudev/libudev.so.1)

into /
dolib.so src/libudev/{${libudev},libudev.so.1,libudev.so}

insinto "/usr/$(get_libdir)/pkgconfig"
doins src/libudev/libudev.pc

if multilib_is_native_abi; then
into /
dobin udevadm

exeinto /lib/systemd
doexe systemd-udevd

exeinto /lib/udev
doexe src/udev/{ata_id,cdrom_id,collect,mtd_probe,scsi_id,v4l_id}

rm rules/99-systemd.rules || die
insinto /lib/udev/rules.d
doins rules/*.rules

insinto /usr/share/pkgconfig
doins src/udev/udev.pc

mv man/systemd-udevd.service.8 man/systemd-udevd.8 || die
rm man/systemd-udevd-{control,kernel}.socket.8 || die
doman man/*.[0-9]
fi
}

multilib_src_install_all() {
doheader src/libudev/libudev.h

insinto /etc/udev
doins src/udev/udev.conf

insinto /lib/systemd/network
doins network/99-default.link

# see src_prepare() for content of 40-gentoo.rules
insinto /lib/udev/rules.d
doins "${T}"/40-gentoo.rules
doins "${S}"/rules/*.rules

dobashcomp shell-completion/bash/udevadm

insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/_udevadm

einstalldocs
}

pkg_postinst() {
mkdir -p "${ROOT%/}"/run

# "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766
# So try to remove it here (will only work if empty).
rmdir "${ROOT%/}"/dev/loop 2>/dev/null
if [[ -d ${ROOT%/}/dev/loop ]]; then
ewarn "Please make sure your remove /dev/loop,"
ewarn "else losetup may be confused when looking for unused devices."
fi

local fstab="${ROOT%/}"/etc/fstab dev path fstype rest
while read -r dev path fstype rest; do
if [[ ${path} == /dev && ${fstype} != devtmpfs ]]; then
ewarn "You need to edit your /dev line in ${fstab} to have devtmpfs"
ewarn "filesystem. Otherwise udev won't be able to boot."
ewarn "See, https://bugs.gentoo.org/453186"
fi
done < "${fstab}"

if [[ -d ${ROOT%/}/usr/lib/udev ]]; then
ewarn
ewarn "Please re-emerge all packages on your system which install"
ewarn "rules and helpers in /usr/lib/udev. They should now be in"
ewarn "/lib/udev."
ewarn
ewarn "One way to do this is to run the following command:"
ewarn "emerge -av1 \$(qfile -q -S -C /usr/lib/udev)"
ewarn "Note that qfile can be found in app-portage/portage-utils"
fi

local old_cd_rules="${ROOT%/}"/etc/udev/rules.d/70-persistent-cd.rules
local old_net_rules="${ROOT%/}"/etc/udev/rules.d/70-persistent-net.rules
for old_rules in "${old_cd_rules}" "${old_net_rules}"; do
if [[ -f ${old_rules} ]]; then
ewarn
ewarn "File ${old_rules} is from old udev installation but if you still use it,"
ewarn "rename it to something else starting with 70- to silence this deprecation"
ewarn "warning."
fi
done

elog
elog "Starting from version >= 197 the new predictable network interface names are"
elog "used by default, see:"
elog "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
elog "https://cgit.freedesktop.org/systemd/systemd/tree/src/udev/udev-builtin-net_id.c"
elog
elog "Example command to get the information for the new interface name before booting"
elog "(replace <ifname> with, for example, eth0):"
elog "# udevadm test-builtin net_id /sys/class/net/<ifname> 2> /dev/null"
elog
elog "You can use either kernel parameter \"net.ifnames=0\", create empty"
elog "file /etc/systemd/network/99-default.link, or symlink it to /dev/null"
elog "to disable the feature."

if has_version 'sys-apps/biosdevname'; then
ewarn
ewarn "You can replace the functionality of sys-apps/biosdevname which has been"
ewarn "detected to be installed with the new predictable network interface names."
fi

ewarn
ewarn "You need to restart udev as soon as possible to make the upgrade go"
ewarn "into effect."
ewarn "The method you use to do this depends on your init system."
if has_version 'sys-apps/openrc'; then
ewarn "For sys-apps/openrc users it is:"
ewarn "# /etc/init.d/udev --nodeps restart"
fi

elog
elog "For more information on udev on Gentoo, upgrading, writing udev rules, and"
elog "fixing known issues visit:"
elog "https://wiki.gentoo.org/wiki/Udev"
elog "https://wiki.gentoo.org/wiki/Udev/upgrade"

# If user has disabled 80-net-name-slot.rules using a empty file or a symlink to /dev/null,
# do the same for 80-net-setup-link.rules to keep the old behavior
local net_move=no
local net_name_slot_sym=no
local net_rules_path="${ROOT%/}"/etc/udev/rules.d
local net_name_slot="${net_rules_path}"/80-net-name-slot.rules
local net_setup_link="${net_rules_path}"/80-net-setup-link.rules
if [[ ! -e ${net_setup_link} ]]; then
[[ -f ${net_name_slot} && $(sed -e "/^#/d" -e "/^\W*$/d" ${net_name_slot} | wc -l) == 0 ]] && net_move=yes
if [[ -L ${net_name_slot} && $(readlink ${net_name_slot}) == /dev/null ]]; then
net_move=yes
net_name_slot_sym=yes
fi
fi
if [[ ${net_move} == yes ]]; then
ebegin "Copying ${net_name_slot} to ${net_setup_link}"

if [[ ${net_name_slot_sym} == yes ]]; then
ln -nfs /dev/null "${net_setup_link}"
else
cp "${net_name_slot}" "${net_setup_link}"
fi
eend $?
fi

# https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
# https://bugs.gentoo.org/246847
# https://bugs.gentoo.org/514174
enewgroup input

# Update hwdb database in case the format is changed by udev version.
if has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"
# Only reload when we are not upgrading to avoid potential race w/ incompatible hwdb.bin and the running udevd
# https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
[[ -z ${REPLACING_VERSIONS} ]] && udev_reload
fi
}

0 comments on commit 4e259b7

Please sign in to comment.