Skip to content

Commit

Permalink
dev-util/gcovr: add 5.1
Browse files Browse the repository at this point in the history
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
chutz committed Jun 16, 2022
1 parent b8ef5ef commit 4e4ae37
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/gcovr/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gcovr-4.2.tar.gz 222847 BLAKE2B 44864c89b58b526c5afc293168c8af2c9082a99e92f2315485f10430fa5ff959046d189c018e0fa121ff4e9fc3685c13b737c112856c841966052d5fd6c9169a SHA512 bf9e22a58b8390eca391dc8f6ba58c4ca0765e66f18ac6f8d8f80609411df2bab74a846eb179a1aded81b7774fa8a8121bb2d586556aeaf43fd729205b0d0c72
DIST gcovr-5.1.tar.gz 1676960 BLAKE2B 106c30c7e349f8ffa7a9c52d70e59c32799a8def11986027e3b794ada07fc11ab27b322c377b553f4bb96ca8662bf152eeb7de2d1913381e6068123d2430aa6c SHA512 ae2f0d9ad04f2dc851db9bc99a30a5dc1b1f43dbc6336422ecf5228d37f6994406a83e50f1ee6b5c8d6ec6d7b9e2bba726fd3d502dc5022fe359d480e6d267a5
48 changes: 48 additions & 0 deletions dev-util/gcovr/gcovr-5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{7..11} )
DISTUTILS_IN_SOURCE_BUILD=1

inherit distutils-r1

DESCRIPTION="A Python script for summarizing gcov data"
HOMEPAGE="https://github.com/gcovr/gcovr"
SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/pytest-timeout[${PYTHON_USEDEP}]
)
"

# tests fail on gcc newer than 5.8
#RESTRICT="test"

distutils_enable_tests pytest

python_test() {
distutils_install_for_testing

local -x PATH="${TEST_DIR}/scripts:${PATH}" \
PYTHONPATH="${TEST_DIR}/lib"

local deselect=(
# those tests fail on gcc newer than 5.8
# https://github.com/gcovr/gcovr/issues/206
gcovr/tests/test_gcovr.py
)

epytest gcovr ${deselect[@]/#/--deselect }
}

0 comments on commit 4e4ae37

Please sign in to comment.