Skip to content

Commit

Permalink
media-sound/soundconverter: bump to 3.0.0 final
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
leio committed Jun 21, 2018
1 parent 5bd9e9a commit 4e67b62
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/soundconverter/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST soundconverter-3.0.0-beta1.tar.xz 196916 BLAKE2B 82832a151e030cbd2be129fe7f4dcd92430aadc71b163c3800cc2108f502020561e2c74291cbb25050ed42bd9d71fdfe310f107af84f612711554cf3e32fd07b SHA512 a27a2c7b4156a6d6c682424c5fa64a4dd82537b1dbfa8176fa39fbfc4d139a21b7dd042de80d088333c0aef0042a76940ab8da5d9708b6aac3399b32b7408f09
DIST soundconverter-3.0.0.tar.xz 201548 BLAKE2B bdca42d22d2e497b807149dcd5c8f911519b71dc7e836ad359831d0b7cd2241f58f8f9f60fa4580e2f038528e9c249dfa8a811d1681d0c8dead2c53e0f58f7ce SHA512 6f5518711c76e7748447805dbf16ac8622c5041c3f3cac2de6f31968aab4eff43a2fde2da48c47d12093ce1732208923d83d57b6a97ea99fbf882dfef239a62d
63 changes: 63 additions & 0 deletions media-sound/soundconverter/soundconverter-3.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )

inherit gnome2 python-single-r1

DESCRIPTION="A simple audiofile converter application for the GNOME environment"
HOMEPAGE="http://soundconverter.org/"
MY_PV="${PV/_/-}"
SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

IUSE="aac flac libnotify mp3 ogg opus vorbis"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/gobject-introspection:=
x11-libs/gtk+:3[introspection]
media-libs/gstreamer:1.0[introspection]
"

# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
# List in soundconverter/gstreamer.py
# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
RDEPEND="${COMMON_DEPEND}
x11-libs/pango[introspection]
dev-python/gst-python:1.0[${PYTHON_USEDEP}]
libnotify? ( x11-libs/libnotify[introspection] )
media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
media-plugins/gst-plugins-meta:1.0
flac? ( media-plugins/gst-plugins-flac:1.0 )
media-libs/gst-plugins-good:1.0
mp3? (
media-libs/gst-plugins-bad:1.0
media-libs/gst-plugins-ugly:1.0
media-plugins/gst-plugins-lame:1.0
)
aac? ( media-plugins/gst-plugins-faac:1.0 )
opus? ( media-plugins/gst-plugins-opus:1.0 )
"
DEPEND="${COMMON_DEPEND}
dev-util/intltool
sys-devel/gettext
"

RESTRICT="test" # broken pot files list in 3.0.0 release, making src_test fallback to "make test" which fails

src_prepare() {
python_fix_shebang .
gnome2_src_prepare
}

src_install() {
gnome2_src_install
python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
}

0 comments on commit 4e67b62

Please sign in to comment.