Skip to content

Commit

Permalink
dev-ml/camlp5: add 8.00.01
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jun 10, 2021
1 parent 9a3be82 commit 4e8107f
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/camlp5/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST camlp5-7.11.tar.gz 878224 BLAKE2B f384764da43653a2f75664681a4f202ec84497720
DIST camlp5-7.12.tar.gz 1008350 BLAKE2B 8f390f6d617a6ef029462aa74ca4d80c0e2eb267bb6957aac43fdecc425aae34dfc7f3e572c8a1f4ee6b032dd90b3b8262094f80a19ea0bb19b80a88d22d3f28 SHA512 233d973b0a968a7812b977e8a37da8e8daa0f3ef81ca7c473d83c1602380dae6c14f94daffb6bb799f8d90fab121238a46e89a233202cd6f622b0da2f728c0c0
DIST camlp5-7.13.tar.gz 1031832 BLAKE2B 2afd7e269092d9c40f263e9ce92b3b9f66b0b3f0ae01da43e2094c6a919aa9f26790030f835b630547d51e7bb4a08e74ac8522e7f308864896fa0414370f8f2f SHA512 8ab94b951e6791be895c70e32b930e498229c9ba7bccc505a3e7c2a91ca12fe038b979b9d5822b43e9c74ee2bf552efa1af7a61f1d287100803efb540d5db8b2
DIST camlp5-7.14.tar.gz 1044110 BLAKE2B c9aa5be80df8d2c376fc41c157b2cd86658dbb90e1babd346b7681afd7453649c7f3682f95f238e51b74b3b3a7a2c5b5a854be892b30a7d1e3b62c3272f5442e SHA512 1b39949c532ca622b01a8e800aa1dcad34f1c944ffe580003642bd742dedc158f3ee54602f3b05f89c0e259525d7feed101b971ebd589449b6d56046389a5bf6
DIST camlp5-8.00.01.tar.gz 1321790 BLAKE2B df4403af56cd07f8e07745bdb73f698ddba24803cde22f11cfbeda425d4360f51be45a92b3f522c52a204f867bb3403dacebf20bfe463f6fd751901102ef2213 SHA512 f40e57845ac4a14cf260ddd9df616d12df09f67efaf6735e915598aee981721e8203bf9203fb83d08e34e43021c08003de64dbf3bdcd4d12fd079542fb7649aa
DIST camlp5-8.00.tar.gz 1321320 BLAKE2B 14957ea83e40f3e2f68c7cbbec1ab84325eba1057f38905a37f9516a99a009024ee0b463cf588880d23d94e710b027b835dd51153a429c8bda22be7fe95dc911 SHA512 6a0d19ced4d94cd3afebfbc373d344229c5faf088e8910dea32ed4dfa841dd9844c72849f8a6281e2bce55295665eae90391cf29d062a44b083761a9e04bce93
58 changes: 58 additions & 0 deletions dev-ml/camlp5/camlp5-8.00.01.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit findlib vcs-clean

DESCRIPTION="A preprocessor-pretty-printer of ocaml"
HOMEPAGE="https://camlp5.github.io/"
SRC_URI="https://github.com/camlp5/camlp5/archive/rel${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-rel${PV}"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="doc +ocamlopt"

DEPEND="
>=dev-lang/ocaml-3.10:=[ocamlopt?]
"
RDEPEND="${DEPEND}"

src_prepare() {
egit_clean
default
}

src_configure() {
./configure \
--strict \
-prefix /usr \
-bindir /usr/bin \
-libdir /usr/$(get_libdir)/ocaml \
-mandir /usr/share/man || die "configure failed"
}

src_compile() {
ulimit -s 11530000
emake out
if use ocamlopt; then
emake opt
emake opt.opt
fi
}

src_test() {
emake bootstrap
}

src_install() {
emake DESTDIR="${ED}" install
# findlib support
insinto "$(ocamlfind printconf destdir)/${PN}"
doins etc/META

dodoc -r doc/*
dodoc CHANGES DEVEL ICHANGES README.md UPGRADING MODE
}

0 comments on commit 4e8107f

Please sign in to comment.