forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/fwupd: Bump to version 1.2.4
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Feb 1, 2019
1 parent
22990f0
commit 4eca51d
Showing
2 changed files
with
132 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST fwupd-1.2.2.tar.gz 1768003 BLAKE2B 83d91761b7dc71296def8a88eb356df687906278ad6e351dffce246a1473de4a141e84e959dd4a785a36a846fc6884d4c83f512e8ea96d7f1b8f9c5dd438d784 SHA512 34221c905a75f4b6d9ee66bc08a2ceb0d65debb71771b8e0eeed26593dff4f29a4080b7c3164535e862f91f370bb519ae2761dc1f62c6b6de3c6c51ef5f0af65 | ||
DIST fwupd-1.2.3.tar.gz 1768734 BLAKE2B 898f0cf3d86295840ad3f5a3736d9b0aedb61f678ca10d93bbbd9240513ae09a2d8941e3d6844024a20652eec487c7237dea5e6813d8d7c969d2998a970d23c1 SHA512 fc4fbb3778f9ed82eec4f05905d611f34344fccd78d199348b9f8ca83fedc48d1503fc77eb0b85026d77f5f83de5f609d97d0a0c008f3280b0a97e942000ba59 | ||
DIST fwupd-1.2.4.tar.gz 1808778 BLAKE2B 4dd8db0e73b148cba8ca43ec7942efa183f331a376b947421b8673d473ef868cef57e3abf4f50e031eb22f97fa8eb199b8bd7ef3b96efb598f842d0824c235a7 SHA512 7734be90459364c2e9ca35d9a9327e7becabe64cd0129d5c8f3cb4a95ef0195726c519862e843636952a3251ecea080907d1e6814c3037e9f90e8dde53b406ad |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,131 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{4,5,6,7} ) | ||
|
||
inherit meson python-single-r1 vala xdg-utils | ||
|
||
DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable" | ||
HOMEPAGE="https://fwupd.org" | ||
SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1+" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="colorhug dell doc +gpg +man nvme pkcs7 redfish systemd test thunderbolt uefi" | ||
REQUIRED_USE=" | ||
${PYTHON_REQUIRED_USE} | ||
dell? ( uefi ) | ||
" | ||
|
||
RDEPEND=" | ||
${PYTHON_DEPS} | ||
app-arch/gcab | ||
app-arch/libarchive:= | ||
dev-db/sqlite | ||
>=dev-libs/glib-2.45.8:2 | ||
dev-libs/json-glib | ||
dev-libs/libgpg-error | ||
dev-libs/libgudev:= | ||
>=dev-libs/libgusb-0.2.9[introspection] | ||
>=dev-libs/libxmlb-0.1.5 | ||
dev-python/pillow[${PYTHON_USEDEP}] | ||
dev-python/pycairo[${PYTHON_USEDEP}] | ||
dev-python/pygobject:3[cairo,${PYTHON_USEDEP}] | ||
>=net-libs/libsoup-2.51.92:2.4[introspection] | ||
>=sys-auth/polkit-0.103 | ||
virtual/libelf:0= | ||
colorhug? ( >=x11-misc/colord-1.2.12:0= ) | ||
dell? ( | ||
sys-libs/efivar | ||
>=sys-libs/libsmbios-2.4.0 | ||
) | ||
gpg? ( | ||
app-crypt/gpgme | ||
dev-libs/libgpg-error | ||
) | ||
nvme? ( sys-libs/efivar ) | ||
pkcs7? ( >=net-libs/gnutls-3.4.4.1:= ) | ||
redfish? ( | ||
sys-libs/efivar | ||
) | ||
systemd? ( >=sys-apps/systemd-211 ) | ||
!systemd? ( >=sys-auth/consolekit-1.0.0 ) | ||
thunderbolt? ( sys-apps/thunderbolt-software-user-space ) | ||
uefi? ( | ||
media-libs/fontconfig | ||
media-libs/freetype | ||
sys-boot/gnu-efi | ||
>=sys-libs/efivar-33 | ||
x11-libs/cairo | ||
) | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
$(vala_depend) | ||
x11-libs/pango[introspection] | ||
doc? ( dev-util/gtk-doc ) | ||
man? ( app-text/docbook-sgml-utils ) | ||
nvme? ( >=sys-kernel/linux-headers-4.4 ) | ||
test? ( net-libs/gnutls[tools] ) | ||
" | ||
|
||
BDEPEND=" | ||
>=dev-util/meson-0.47.0 | ||
virtual/pkgconfig | ||
" | ||
|
||
# required for fwupd daemon to run. | ||
# NOT a build time dependency. The build system does not check for dbus. | ||
PDEPEND="sys-apps/dbus" | ||
|
||
src_prepare() { | ||
default | ||
sed -e "s/'--create'/'--absolute-name', '--create'/" \ | ||
-i data/tests/builder/meson.build || die | ||
sed -e "/'-Werror',/d" \ | ||
-i plugins/uefi/efi/meson.build || die | ||
vala_src_prepare | ||
} | ||
|
||
src_configure() { | ||
xdg_environment_reset | ||
local emesonargs=( | ||
--localstatedir "${EPREFIX}"/var | ||
-Dconsolekit="$(usex systemd false true)" | ||
-Dgpg="$(usex gpg true false)" | ||
-Dgtkdoc="$(usex doc true false)" | ||
-Dman="$(usex man true false)" | ||
-Dpkcs7="$(usex pkcs7 true false)" | ||
-Dplugin_dell="$(usex dell true false)" | ||
-Dplugin_nvme="$(usex nvme true false)" | ||
-Dplugin_redfish="$(usex redfish true false)" | ||
-Dplugin_synaptics="$(usex dell true false)" | ||
-Dplugin_thunderbolt="$(usex thunderbolt true false)" | ||
-Dplugin_uefi="$(usex uefi true false)" | ||
-Dsystemd="$(usex systemd true false)" | ||
-Dtests="$(usex test true false)" | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
doinitd "${FILESDIR}"/${PN} | ||
|
||
if ! use systemd ; then | ||
# Don't timeout when fwupd is running (#673140) | ||
sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \ | ||
-i "${ED}"/etc/${PN}/daemon.conf || die | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
elog "In case you are using openrc as init system" | ||
elog "and you're upgrading from <fwupd-1.1.0, you" | ||
elog "need to start the fwupd daemon via the openrc" | ||
elog "init script that comes with this package." | ||
} |