forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.28
- Loading branch information
Showing
3 changed files
with
71 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST dvtm-0.11.tar.gz 34499 SHA256 01a29fdf6556f019f183bd517a1045bcc12d23561c1a84c4b5a8b3ba2d2feb87 SHA512 e1c76540bbddf6245f77a749146f2c3c836a8f2cf1c0e96ef198c3be9e5069458360ecf0a0a523ce9fcf22d55a424ee064420f8699875026cb399fc3f017cfa7 WHIRLPOOL 7d18be8ca4ab86d93f6d98d07a1a1843d6bb0ea796affb99864fcd31798396a4a431895f4b3b955be64de2f6661f8c87c07c6b8dc09992c1d53107ee3500f52b | ||
DIST dvtm-0.14.tar.gz 35893 SHA256 8a9bb341f8a4c578b839e22d9a707f053a27ae6df15158e16f4fee787e43747a SHA512 d47f55b4ce47582f665ac5b5d86bb9137722f65b157bdd80aaaf45a2cd8d783a3b0718886c7a7ea1d900762359316c2d76816460dac03484e122d43c64f57dd6 WHIRLPOOL 1ca474b4ad5f9d7fa7106ec0c180d32e06cd2d02be1e3a3392a7c6373ecf00d5abba26e8e4d2ed67d8784533db10951bebc408cad9c068e7270407beb339706e | ||
DIST dvtm-0.15.tar.gz 40511 SHA256 8f2015c05e2ad82f12ae4cf12b363d34f527a4bbc8c369667f239e4542e1e510 SHA512 48a0c8fd6a50fe5d43414d0223c9f4b9920a31d42fe3bfc428ce1ae7d0e41a41ebe2597eae0824c7c76bfb0e32a13e440c8d5fcdb1886d55d6791fa3fe3fd77b WHIRLPOOL 2025dfc087408108ac9fc6fc8952f760324d3ecc900b9b820b4beb6cebd31d4f2a9b9a7191981fb403a987ff2caf536a8f6103ee8d918a36ea414f41a06d69c3 | ||
DIST dvtm-0.8.tar.gz 27543 SHA256 4c84b7c32f6cd476ef92150c4c1ca211836ed00f16ca8bdd4089933912b39a78 SHA512 6b4c910aee637fe0e4eeedf7905e893ffee2476baffc08697093b2181197aaca1aafd1095fb7e140fea2f0dd9492edf608bad5ad4ad410a5a3e76610732220eb WHIRLPOOL c3505ca64e36a17b1e0de175448c6bbf09ba18732b41787c8f9d7062afb3aca1a72f0a74d890da2261db7b94bd14ac83f5998ff87c776253f0c4c0a2df4a575b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,68 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit savedconfig toolchain-funcs | ||
|
||
DESCRIPTION="Dynamic virtual terminal manager" | ||
HOMEPAGE="http://www.brain-dump.org/projects/dvtm/" | ||
|
||
if [[ ${PV} == 9999* ]]; then | ||
inherit git-2 | ||
EGIT_REPO_URI="git://repo.or.cz/dvtm.git" | ||
else | ||
SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
fi | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
IUSE="unicode" | ||
|
||
DEPEND="sys-libs/ncurses:0[unicode?]" | ||
RDEPEND=${DEPEND} | ||
|
||
src_prepare() { | ||
sed -i \ | ||
-e 's|FLAGS =|FLAGS +=|' \ | ||
-e 's|-I/usr/local/include||' \ | ||
-e 's|-L/usr/local/lib||' \ | ||
-e 's|-Os||' \ | ||
config.mk || die "sed config.mk failed" | ||
use unicode || { | ||
sed -i \ | ||
-e 's|-lncursesw|-lncurses|' \ | ||
config.mk || die "sed config.mk failed" | ||
} | ||
sed -i \ | ||
-e '/strip/d' \ | ||
-e 's:@tic :@tic -o ${DESTDIR}${PREFIX}/share/terminfo :g' \ | ||
Makefile || die "sed Makefile failed" | ||
|
||
restore_config config.h | ||
} | ||
|
||
src_compile() { | ||
local msg="" | ||
use savedconfig && msg=", please check the configfile" | ||
emake CC=$(tc-getCC) ${PN} || die "emake failed${msg}" | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" PREFIX="/usr" install | ||
|
||
insinto /usr/share/${PN} | ||
newins config.h ${PF}.config.h | ||
|
||
dodoc README.md | ||
|
||
save_config config.h | ||
} | ||
|
||
pkg_postinst() { | ||
elog "This ebuild has support for user defined configs" | ||
elog "Please read this ebuild for more details and re-emerge as needed" | ||
elog "if you want to add or remove functionality for ${PN}" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters