forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/bless: Update for monolithic gtk-sharp & mono-4
Changed the dependencies to cope with the unannounced monolithic gtk-sharp ebuild which blocks on packages such as bless that need glade-sharp. Also introduced a patch to use mcs rather than the depreacted gmcs. Package-Manager: portage-2.2.20.1 Signed-off-by: Mike Auty <[email protected]>
- Loading branch information
Mike Auty
committed
Aug 23, 2015
1 parent
400ce1c
commit 4ef6927
Showing
2 changed files
with
40 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
diff --git a/builder/ModuleBuilder.cs b/builder/ModuleBuilder.cs | ||
index 0f62e92..7edb1ab 100644 | ||
--- a/builder/ModuleBuilder.cs | ||
+++ b/builder/ModuleBuilder.cs | ||
@@ -119,7 +119,7 @@ public class ModuleBuilder | ||
//System.Console.WriteLine("gmcs {0}", sb.ToString()); | ||
System.Console.WriteLine(">> Building module {0}...", module.Name); | ||
|
||
- Process buildProcess = Process.Start("gmcs", sb.ToString()); | ||
+ Process buildProcess = Process.Start("mcs", sb.ToString()); | ||
buildProcess.WaitForExit(); | ||
|
||
if (buildProcess.ExitCode == 0) { | ||
@@ -137,4 +137,4 @@ public class ModuleBuilder | ||
} | ||
|
||
|
||
-} | ||
\ No newline at end of file | ||
+} | ||
diff --git a/configure.ac b/configure.ac | ||
index 415cc64..a8e527c 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -24,9 +24,9 @@ if test "x$PKG_CONFIG" = "xno"; then | ||
fi | ||
|
||
# C# compiler | ||
-AC_PATH_PROG(MCS, gmcs, no) | ||
+AC_PATH_PROG(MCS, mcs, no) | ||
|
||
-CS="gmcs C#" | ||
+CS="mcs C#" | ||
if test "x$MCS" = "xno" ; then | ||
AC_MSG_ERROR([No $CS compiler found]) | ||
fi |