Skip to content

Commit

Permalink
dev-util/bless: Update for monolithic gtk-sharp & mono-4
Browse files Browse the repository at this point in the history
Changed the dependencies to cope with the unannounced
monolithic gtk-sharp ebuild which blocks on packages
such as bless that need glade-sharp.

Also introduced a patch to use mcs rather than the
depreacted gmcs.

Package-Manager: portage-2.2.20.1
Signed-off-by: Mike Auty <[email protected]>
  • Loading branch information
Mike Auty committed Aug 23, 2015
1 parent 400ce1c commit 4ef6927
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 2 deletions.
6 changes: 4 additions & 2 deletions dev-util/bless/bless-0.6.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -19,7 +19,8 @@ IUSE="debug"
RDEPEND="
>=dev-lang/mono-1.1.14
>=dev-dotnet/gtk-sharp-2.12
>=dev-dotnet/glade-sharp-2.12
|| ( >=dev-dotnet/gtk-sharp-2.12.21
>=dev-dotnet/glade-sharp-2.12 )
"
DEPEND="${RDEPEND}
app-text/scrollkeeper
Expand All @@ -42,6 +43,7 @@ src_prepare() {
( "${T}/gettextize" -f --no-changelog > /dev/null ) || die "gettexize failed"
epatch "${FILESDIR}/${P}-pixmap.patch"
epatch "${FILESDIR}/${P}-docpath.patch"
epatch "${FILESDIR}/${P}-mono-4.patch"
eautoreconf
gnome2_src_prepare
}
Expand Down
36 changes: 36 additions & 0 deletions dev-util/bless/files/bless-0.6.0-mono-4.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
diff --git a/builder/ModuleBuilder.cs b/builder/ModuleBuilder.cs
index 0f62e92..7edb1ab 100644
--- a/builder/ModuleBuilder.cs
+++ b/builder/ModuleBuilder.cs
@@ -119,7 +119,7 @@ public class ModuleBuilder
//System.Console.WriteLine("gmcs {0}", sb.ToString());
System.Console.WriteLine(">> Building module {0}...", module.Name);

- Process buildProcess = Process.Start("gmcs", sb.ToString());
+ Process buildProcess = Process.Start("mcs", sb.ToString());
buildProcess.WaitForExit();

if (buildProcess.ExitCode == 0) {
@@ -137,4 +137,4 @@ public class ModuleBuilder
}


-}
\ No newline at end of file
+}
diff --git a/configure.ac b/configure.ac
index 415cc64..a8e527c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,9 +24,9 @@ if test "x$PKG_CONFIG" = "xno"; then
fi

# C# compiler
-AC_PATH_PROG(MCS, gmcs, no)
+AC_PATH_PROG(MCS, mcs, no)

-CS="gmcs C#"
+CS="mcs C#"
if test "x$MCS" = "xno" ; then
AC_MSG_ERROR([No $CS compiler found])
fi

0 comments on commit 4ef6927

Please sign in to comment.