Skip to content

Commit

Permalink
dev-db/pgxnclient: Bump to 1.3.2
Browse files Browse the repository at this point in the history
Also add py3.10 support

Closes: https://bugs.gentoo.org/845633
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Jun 18, 2022
1 parent 31c9294 commit 4f42795
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/pgxnclient/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pgxnclient-1.3.1.tar.gz 80554 BLAKE2B 0f63d3ee94de623b32d990a9504a469e5606b72df7c4f3c8a261e00c36c7284e2d7efdc1eec15b43fde69be50c1b55f65f3a2259a67894fb9022e9d39280683f SHA512 e698fa9cb56a4f66c4c4281861ee6cfef4667ca9b0643691798929c625fee9eb9534ad9c6c4b94f63a730b9dedcf9f0b6a120d179052c3519d8010bc2791dd3e
DIST pgxnclient-1.3.2.tar.gz 86146 BLAKE2B 452eb33999362b97c4f65aadcc9d19f1a24534fd7647b0ad66bbe8b87d006cee59ae5de71551be7bcd42402f40bdc551946bb38e960f217617357fb65657f161 SHA512 ce4e2b7512e4fc8f36ee9ebb7280096bdc18c5c372bb483c8cec35b7e5d5c0f19c256d1a916b5f9b2adb96c80736524df9dee90dcd7e76bf4b1af13fbf8d96bc
DIST pgxnclient-1.3.tar.gz 51976 BLAKE2B 84ae5573588e6da0b01d5b05e296adc09f28a0b21ff81e5f2f14f3035a98ad5eb834d6793acf0a48a8b19190b989562e75094341f7c01b371028a0dd6a87b0f4 SHA512 fd9326107334d473db3466f776021186a5add389a93266b000c143131a0214b9773dd4cdd4688575cd720c8357afce1473838dea4aa5ff2564dcbc2c359de2dd
39 changes: 39 additions & 0 deletions dev-db/pgxnclient/pgxnclient-1.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1

DESCRIPTION="PostgreSQL Extension Network Client"
HOMEPAGE="https://pgxn.github.io/pgxnclient/
https://pypi.org/project/pgxnclient/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"

LICENSE="BSD"
SLOT="0"

IUSE="test"

RDEPEND="dev-db/postgresql:*[server]
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-python/mock )
"

# Test data is currently missing from the distribution. Next release
# will include it.
RESTRICT="test"
distutils_enable_tests pytest

src_prepare() {
sed "s/setup_requires/#/" -i setup.py || die
sed "s/find_packages()/find_packages(exclude=['tests'])/" -i setup.py || die

default
}

0 comments on commit 4f42795

Please sign in to comment.