Skip to content

Commit

Permalink
dev-ruby/rack: add 2.0.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
graaff committed Apr 24, 2018
1 parent e929b68 commit 4f4cf65
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rack/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST rack-1.6.7.gem 229888 BLAKE2B b4ea51d9a0606c92c6cc199bcaf3f7068e6360dd972417af7fe8784a5b23a8de1288347431f08d9af1d19f1409f18035d668d6e80f0b2080d761a3e703259d0c SHA512 e1cc22d78a61998c034bbf9217cad5cc0e614697e787f58aed9cfb1c3a12f69b557c9e95a4b09fcc1509cb607332a8655a66159b2492ea6fdc2bda21f588a59e
DIST rack-2.0.3.gem 254464 BLAKE2B c7052ae0210d2c8d9aeaa6e3b5b10b272ea48d6c2601aecd524eeab141d3987b7905d9511814d0ac7a62413ef5eb01e847168a278bafb5a0e8f882c526cdfcc9 SHA512 c48e6681544c2f37797ee697f5c4f0d4de6008a3df2506665b52c248fca1ef7321a892dd28475e4d7b461a0b2d12112903a67e1bed7c7397742833fce85167e1
DIST rack-2.0.4.gem 254976 BLAKE2B e816bda9969117525d061b2de2e9172d831a1fd0654ee5f4ff0293a95c01b8451204cab034816f7b2382b77cae3c9a735184f3f1c8f5b9e8cb43963001f815da SHA512 d6624d52c456654ab4c98554d544c6cb0bd15fad5a494575ad329bd1892dca2ac612b5730f4e3f6eddf2c0496afc393f215fb7d60795c264d2251896c27f450a
DIST rack-2.0.5.gem 254464 BLAKE2B 91fdb183a7e79b853d5ff8ef0d95799fdcdcb92ae69406666a96742dfe9abf7211c0d3ee0ec21edfb01392006e30c146573acb532a83bbf807f743272fb77dd9 SHA512 ac820997ec5804816e26275630797d0c86e2dc04d43572e66e99a25067d531c8a6fcdfb7b5157ce44d039d1690bb015567d859a13a85dc7d22fa0f7454ea0aa2
42 changes: 42 additions & 0 deletions dev-ruby/rack/rack-2.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby22 ruby23 ruby24 ruby25"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.rdoc SPEC"

inherit ruby-fakegem eutils versionator

DESCRIPTION="A modular Ruby webserver interface"
HOMEPAGE="https://rack.github.com/"

LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_rdepend "virtual/ruby-ssl"

ruby_add_bdepend "test? ( dev-ruby/minitest:5 dev-ruby/concurrent-ruby )"

# The gem has automagic dependencies over mongrel, ruby-openid,
# memcache-client, thin, mongrel and camping; not sure if we should
# make them dependencies at all.

# Block against versions in older slots that also try to install a binary.
RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5 !<dev-ruby/rack-1.6.4-r2:1.6"

all_ruby_prepare() {
# The build system tries to generate the ChangeLog from git. Create
# an empty file to avoid a needless dependency on git.
touch ChangeLog || die

# Avoid development dependency
sed -i -e '/minitest-sprint/ s:^:#:' rack.gemspec || die
}

each_ruby_test() {
${RUBY} -Ilib:test:. -e "require 'test/gemloader.rb'; Dir['test/spec_*.rb'].each{|f| require f}" || die
}

0 comments on commit 4f4cf65

Please sign in to comment.