Skip to content

Commit

Permalink
app-vim/gentoo-syntax: bump to 20170225
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3_p65_p263862, Repoman-2.3.1_p58_p263862
  • Loading branch information
floppym committed Feb 26, 2017
1 parent 06025ea commit 4f73593
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-vim/gentoo-syntax/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gentoo-syntax-20160530.tar.gz 18950 SHA256 819495c10e594b2fef1fdcd80afa24ee437fe20b94ad9e7eb9e91f0a5be31919 SHA512 38881c5f16499eb053eb7a5514f6324b2a161f1392a044db0bbaf0cb71a0f17e1edebd4a685ff856a78525fbcb8c6267daa2503cfbc6f94d841cf3f6a25045bd WHIRLPOOL 41018200b7f79eec005f55e80d3f8b1eec1f33acdbf1a8bce03b282a27cf63bb08a4959e0fcd74ecc9972322bbf4b0b89755dbde35cedc87ee9a228d07519a33
DIST gentoo-syntax-20170225.tar.gz 18939 SHA256 f9305c689f8eeb492fc2a7f9e9c90b6af1663e2f16dcf0b95d22e6395a6bb8e2 SHA512 2c01577910eccd413b85c094dbd12bf8445e2f560be1fffc4a4c3130b32587f9c298d8442b5cf12bd7d2950ab8c9e5b95a72f2f41c42c6dc939ffa2c26fd71d5 WHIRLPOOL 7350ddf65ebc9c64fd83997d2e7d9ce329fa434a150ee69b35d54adfd2097319c6492508a0d1d0938453f7ae5068d422448564ad292cb43fc45afb97097efdc7
54 changes: 54 additions & 0 deletions app-vim/gentoo-syntax/gentoo-syntax-20170225.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit vim-plugin

if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://github.com/gentoo/gentoo-syntax.git"
inherit git-r3
else
SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Gentoo and portage related syntax highlighting, filetype, and indent settings"
HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
LICENSE="vim"
IUSE="ignore-glep31"

VIM_PLUGIN_HELPFILES="gentoo-syntax"
VIM_PLUGIN_MESSAGES="filetype"

src_prepare() {
default
if use ignore-glep31 ; then
for f in ftplugin/*.vim ; do
ebegin "Removing UTF-8 rules from ${f} ..."
sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
|| die "waah! bad sed voodoo. need more goats."
eend $?
done
fi
}

pkg_postinst() {
vim-plugin_pkg_postinst

if [[ -z ${REPLACING_VERSIONS} ]] ; then
if use ignore-glep31 1>/dev/null ; then
ewarn "You have chosen to disable the rules which ensure GLEP 31"
ewarn "compliance. When editing ebuilds, please make sure you get"
ewarn "the character set correct."
else
elog "Note for developers and anyone else who edits ebuilds:"
elog " This release of gentoo-syntax now contains filetype rules to set"
elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
elog " If you find this feature breaks things, please submit a bug and"
elog " assign it to [email protected]. You can use the 'ignore-glep31' USE"
elog " flag to remove these rules."
fi
fi
}

0 comments on commit 4f73593

Please sign in to comment.