forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-backup/fsarchiver: Bump to version 0.8.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Lars Wendler
committed
Feb 20, 2017
1 parent
132d10a
commit 4f784ad
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST fsarchiver-0.6.19.tar.gz 244972 SHA256 9ba4d3262059a0cb108de564340d947a4d75d34ba3b8e35a767d543afbf24dbb SHA512 28c2b7c59fcdedd47c5451867540696e1859d954259670419df01fb94b626f169a2ff97b9eb96caaba69421ff2560cebbd6c7743b2a89172591f0747716a0471 WHIRLPOOL 78200870521adb927b042e3ada778ebb552f84c0164cf628fa5214f84f42a853fe71871d2ee27a6c485fa1db3c229002e52c6f11e58ef9766b38df6723e93f24 | ||
DIST fsarchiver-0.6.24.tar.gz 261942 SHA256 535401b71b905ebf268bf45a24456d50cc5584c77119d93bf692b6a10c51cee3 SHA512 5c6338426f74625b5be3da4c0b5419e55a123dbdf2669198eeae902dff6b136f004f3279e805ec46ec283293088fb25eb1caaa202b853c9e0c254c7786bf12a4 WHIRLPOOL 0a8df7bdddb636d72036ce3a779f5fee7a9204e71471c42a03500e5a21b2b915df809e5b4bb2b94bc9402208fe5e304a21ced303d028564b12fd9696e05f8426 | ||
DIST fsarchiver-0.8.0.tar.gz 264741 SHA256 68e98e51faa44abd593342503073cbce5f8ff74f87ecd45dfa45f68ad5e0a362 SHA512 3007ffa47c6399987f06cd53e30a1bbe9784703b97dd7383c5aa0a505bb64c94c89095f5b821ddebfb1eb76361babf08f0b64ab4a39ce3cc3f2f9a6f02f71fae WHIRLPOOL ab221d38787fdb5e9e0325acc98e5a24acece718719b41465681cdc539f366dd27287fe8677163cb61cb33f8abfb59cdc210ab059ea06622358825bba79b029c | ||
DIST fsarchiver-0.8.1.tar.gz 265048 SHA256 f21dc8f66a67e949c836f3316862db0619f14cf8971ba37342c0ae6e11e625f8 SHA512 17133392b0678b88552ae356bc199a8a5a8a88d3c8878b593b36acdc0f9dc3869f87475cc1a36d0df752e3bc3df8c9c0641954f675aaf60da4f1b0862dec1bc6 WHIRLPOOL 190450d064ed509f731c0104623e237ccca1f04d4cde3cae23d14a34bfc0ae567062bd081cb1523655d82ae62a1add99afa75260db815db96a0a145962bd8154 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit autotools | ||
|
||
DESCRIPTION="Flexible filesystem archiver for backup and deployment tool" | ||
HOMEPAGE="http://www.fsarchiver.org" | ||
SRC_URI="https://github.com/fdupoux/${PN}/releases/download/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug lzma lzo static" | ||
|
||
DEPEND="dev-libs/libgcrypt:0= | ||
>=sys-fs/e2fsprogs-1.41.4 | ||
lzma? ( >=app-arch/xz-utils-4.999.9_beta ) | ||
lzo? ( >=dev-libs/lzo-2.02 ) | ||
static? ( lzma? ( app-arch/xz-utils[static-libs] ) )" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e 's/^\([a-z]*_CFLAGS.*\)-ggdb/\1/' src/Makefile.am \ | ||
|| die "seding failed" | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
myeconfargs=( | ||
$(use_enable lzma) | ||
$(use_enable lzo) | ||
$(use_enable static) | ||
$(use_enable debug devel) | ||
) | ||
econf "${myeconfargs[@]}" | ||
} |