Skip to content

Commit

Permalink
app-vim/vim-latex: add python{3_7,3_8} targets.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/721558
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Jun 21, 2020
1 parent 4e36101 commit 4f84700
Showing 1 changed file with 65 additions and 0 deletions.
65 changes: 65 additions & 0 deletions app-vim/vim-latex/vim-latex-1.10.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7,3_8} )

inherit vim-plugin python-single-r1

DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
HOMEPAGE="http://vim-latex.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

LICENSE="vim"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
|| (
app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
)
virtual/latex-base
!app-vim/vimtex"

VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"

src_compile() { :; }

src_install() {
# remove unused metadata
rm vim-latex.metainfo.xml || die

# don't mess up vim's doc dir with random files
mv doc mydoc || die
mkdir doc || die
mv mydoc/*.txt doc/ || die
rm -rf mydoc || die

# don't install buggy tags scripts, use ctags instead
rm latextags ltags || die

vim-plugin_src_install

# use executable permissions (bug #352403)
fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py

python_fix_shebang "${ED}"
}

pkg_postinst() {
vim-plugin_pkg_postinst

if [[ -z ${REPLACING_VERSIONS} ]]; then
echo
elog "To use the vim-latex plugin add:"
elog " filetype plugin on"
elog ' set grepprg=grep\ -nH\ $*'
elog " let g:tex_flavor='latex'"
elog "to your ~/.vimrc-file"
echo
fi
}

0 comments on commit 4f84700

Please sign in to comment.