Skip to content

Commit

Permalink
app-editors/qxmledit: version bump, rewritten ebuild, qt5 support
Browse files Browse the repository at this point in the history
Also fix bug 568746, migrate to EAPI 6, and update metadata.xml

Package-Manager: portage-2.2.27
  • Loading branch information
Pesa committed Feb 27, 2016
1 parent 557da3f commit 4fc96fc
Show file tree
Hide file tree
Showing 3 changed files with 77 additions and 6 deletions.
1 change: 1 addition & 0 deletions app-editors/qxmledit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qxmledit-0.8.8-1-src.tgz 8885329 SHA256 d43ccd0029b1094a970d58170a095cbe5fddfe3d93da7c52388783d321386e17 SHA512 5440d33c052507d3b5c840cdd2966c151a77e2027703f7c1d33f80ec786affab915053d2ae17ef72fd856223ca85dbb70d39d8800170449a26ea88632c0069b5 WHIRLPOOL 68f8d73c39ce490f13d88283053ad045125f007132a25d965ffb603ab1de1d42b62944659a76aa9bbb5adc884b37ad90f7eaf4487f314678d8a1923cd16f1078
DIST qxmledit-0.9.2-src.tgz 16697023 SHA256 14b8b47f00cf8ea031a0066c928cf8888a3b0d885627ed7f45c6d455be8bd531 SHA512 1cef025ded878e8ad4a33af7f22caf4b157a93e30a6fe863d80ef8c32ca6c9f080e3e4212d1db6a18e647ca111afba796b77f13c2dbc65b18d498fb977504c93 WHIRLPOOL 07fc283720a7427f352fac086770f07e921c20f66ead80fd1b0729be5afc6a01d0c437973dc6c85a61c22f3dabdc9eba2c9b9bf1721e859f0a23cc0cd60900a7
12 changes: 6 additions & 6 deletions app-editors/qxmledit/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -10,13 +10,13 @@
<name>Gentoo Qt Project</name>
</maintainer>
<longdescription lang="en">
QXmlEdit is a simple XML editor written in Qt4. Its main
features are unusual data visualization modes, it has some
nice XML manipulation and presentation features and it is
multi-platform. This is one of the few graphical Open Source
XSD viewer.
QXmlEdit is a simple XML editor based on Qt libraries. Its main features are
unusual data visualization modes, nice XML manipulation and presentation
features, and it is multi-platform. It can split very big XML files into
fragments, and compare XML files. It is one of the few graphical Open Source
XSD viewers.
</longdescription>
<upstream>
<remote-id type="google-code">qxmledit</remote-id>
<remote-id type="sourceforge">qxmledit</remote-id>
</upstream>
</pkgmetadata>
70 changes: 70 additions & 0 deletions app-editors/qxmledit/qxmledit-0.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils qmake-utils

DESCRIPTION="Qt4 XML Editor"
HOMEPAGE="http://qxmledit.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}-src.tgz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="qt5"

DEPEND="
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qtsql:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
dev-qt/qtxmlpatterns:5
)
!qt5? (
dev-qt/qtcore:4
dev-qt/qtgui:4
dev-qt/qtsql:4
dev-qt/qtsvg:4
dev-qt/qtxmlpatterns:4
)"
RDEPEND="${DEPEND}"

DOCS=(AUTHORS NEWS README)

src_prepare() {
default

# bug 568746
sed -i -e '/QMAKE_CXXFLAGS/s:-Werror::' \
src/{QXmlEdit,QXmlEditWidget,sessions/QXmlEditSessions}.pro || die
}

src_configure() {
export \
QXMLEDIT_INST_DIR="/usr/bin" \
QXMLEDIT_INST_LIB_DIR="/usr/$(get_libdir)" \
QXMLEDIT_INST_INCLUDE_DIR="/usr/include/${PN}" \
QXMLEDIT_INST_DATA_DIR="/usr/share/${PN}" \
QXMLEDIT_INST_DOC_DIR="/usr/share/doc/${PF}" \
QXMLEDIT_INST_TRANSLATIONS_DIR="/usr/share/${PN}/translations"

if use qt5; then
eqmake5
else
eqmake4
fi
}

src_install() {
emake INSTALL_ROOT="${D}" install
doicon install_scripts/environment/icon/qxmledit.png
domenu install_scripts/environment/desktop/QXmlEdit.desktop
einstalldocs
}

0 comments on commit 4fc96fc

Please sign in to comment.