forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
51 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST abduco-0.4.tar.gz 14222 SHA256 bda3729df116ce41f9a087188d71d934da2693ffb1ebcf33b803055eb478bcbb SHA512 1f6df3604f5b4b59a650ccb8b6b7f9e62591154f72163350b8c8d2ffa9c392c9ebda0f958537a203e87319e275674fec6d161f18a10d49e44d0afc512c467f88 WHIRLPOOL e232bbae99cdd0c3c5b0e06f8cce73126586f9d997a03ba03720030355d603ee488df40b04343b6bfd508d2ac05dbdd2ca3bc6a62a661b140c5bd9bfc43fde12 | ||
DIST abduco-0.5.tar.gz 15790 SHA256 bf22226a4488355a7001a5dabbd1e8e3b7e7645efd1519274b956fcb8bcff086 SHA512 e0772b8eecc1fb6f16c7516a6956825b9bda4149f00f56b34e68ec3544f74c2270ba8cc2642599de26ae34d11ed78b8bba70497bfc9a79f3008f50de02ce49d8 WHIRLPOOL ffce64702323cba434768bb4864b9f8bd0e5a6768f3fd5a821081eee77dcffea33c8ab920e39471fb644ca2ff03214d04808d55804889a278417c5d6d76d3f79 | ||
DIST abduco-0.6.tar.gz 15829 SHA256 c90909e13fa95770b5afc3b59f311b3d3d2fdfae23f9569fa4f96a3e192a35f4 SHA512 3b70a5cc10f0a2743dcbdf6eebdcfcee0e4f4ff8c6ce0bf0aa9f55c3fa85ab43aa659997735e063eab36aba69f91be7bb5519f3f632bff1b9098f5179165c1f2 WHIRLPOOL 116ac3855e25ebb406d5a6d8702eb4115ee98f783113424cad67e2fab95efdb08ea641aac5f72107955ce31759dd10760ebfd14f1b21c583eea47bce7e056a16 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit savedconfig toolchain-funcs | ||
|
||
DESCRIPTION="lightweight session manager with {de,at}tach support" | ||
HOMEPAGE="http://www.brain-dump.org/projects/abduco/" | ||
SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="ISC" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="" | ||
|
||
DEPEND="" | ||
RDEPEND="" | ||
|
||
src_prepare() { | ||
sed -e 's:^PREFIX.*:PREFIX = /usr:' \ | ||
-e 's/-Os//' \ | ||
-e '/^CC/d' \ | ||
-i config.mk || die | ||
|
||
sed -e "s/VERSION/${PV}/g" \ | ||
-i ${PN}.1 || die | ||
|
||
sed -e '/@echo CC/d' \ | ||
-e 's|@${CC}|$(CC)|g' \ | ||
-i Makefile || die | ||
|
||
restore_config config.def.h | ||
|
||
tc-export CC | ||
|
||
default | ||
} | ||
|
||
src_test() { | ||
./testsuite.sh || die | ||
} | ||
|
||
src_install() { | ||
dobin ${PN} | ||
dodoc README.md | ||
doman ${PN}.1 | ||
|
||
save_config config.def.h | ||
} |