Skip to content

Commit

Permalink
dev-go/delve: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
mrueg committed Nov 15, 2016
1 parent be4cbc0 commit 50174c7
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-go/delve/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST delve-0.11.0_alpha.tar.gz 910021 SHA256 47278abc6928161cca902b203dab9351aa27428d82c4eefae23fc457781733f5 SHA512 57af18bd8a671ab7ad67980b84e9168795c5c72724117fad85a156eba6668fd4360faf2109833d29d6f3faea3f4856fa7094b5ff7687bf199d7e2b97f107c15e WHIRLPOOL 4b3194207529c09cf222cc0166376e19e453b829abd7547a50b09d89a995839d7931194ba0c1dc77e28f20d14e16273c66aa1ba50b5e2e0fe6dff4c42a983c84
34 changes: 34 additions & 0 deletions dev-go/delve/delve-0.11.0_alpha.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
EGO_PN="github.com/derekparker/delve"

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
EGIT_COMMIT="v${PV/_/-}"
DELVE_SHA="6774a6c"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
inherit golang-vcs-snapshot
fi

DESCRIPTION="A source-level debugger for the Go programming language"
HOMEPAGE="http://github.com/derekparker/delve"

LICENSE="MIT"
SLOT="0"
IUSE=""

S=${WORKDIR}/${P}/src/${EGO_PN}

src_compile() {
GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -ldflags="-X main.Build=${DELVE_SHA}" -o "bin/dlv" ./cmd/dlv || die
}

src_install() {
dodoc README.md CHANGELOG.md
dobin bin/dlv
}
8 changes: 8 additions & 0 deletions dev-go/delve/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Manuel Rüger</name>
</maintainer>
</pkgmetadata>

0 comments on commit 50174c7

Please sign in to comment.