Skip to content

Commit

Permalink
media-video/pipewire: bump to v0.3.13
Browse files Browse the repository at this point in the history
Closes: gentoo#17528
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Oct 11, 2020
1 parent ead3dba commit 50191b9
Show file tree
Hide file tree
Showing 2 changed files with 137 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/pipewire/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pipewire-0.2.7.tar.gz 421644 BLAKE2B d2ccb56a9ea5ea7782678deb6eae0b0a70da1fa69e807398062d388733901839f15a2f0f7db982fbebd2b2759f443709e6c1950b6367f3ed4801d6c2d6109e73 SHA512 10d3e20cc3d233fbcd1fc39702ae3043a656ebcd9cd3c39c77f0cc2bf42ff4956fc03e7933c7b397bca446c63f45ddacea948d5ec7e4a3300499fa2794f14334
DIST pipewire-0.3.10.tar.gz 1148297 BLAKE2B d890b8e6697b17be9f8706a7228b9c79631120550ac51d7fbea8b5d05ca161ce6142a5666a6a61db618d4da0519676160ba1180cf9274865d879f4bb0da2a8e7 SHA512 f2f3dd7ce9b9f3a5ab55b6da97cd64419dad5115714848ce8893795c0ed2fd2fe0059240ec9fe1c92fb1442caf8d7071e415afe6712500be1c29fd001293cf0d
DIST pipewire-0.3.13.tar.gz 1176949 BLAKE2B 5a4c7f211c1ac3c823cc34cede2f42204a2a7c6d583237465e702936926fad924c37f0638c8bbdedc55ad70d59cc2796e64b2b3dea2c64f199383d4ed9c1c84a SHA512 38ce7d8808e69935db0148c077340cfbc1b85f5a016a0a57eff2c076560c42f0695cfe681c9f16ebf15796d773dd113c9a84631eb50ac44dfb09f91ed3fc61f0
136 changes: 136 additions & 0 deletions media-video/pipewire/pipewire-0.3.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,136 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/PipeWire/pipewire.git"
EGIT_BRANCH="work"
inherit git-r3
else
SRC_URI="https://github.com/PipeWire/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi

DESCRIPTION="Multimedia processing graphs"
HOMEPAGE="https://pipewire.org/"

LICENSE="LGPL-2.1+"
SLOT="0/0.3"
IUSE="bluetooth debug doc ffmpeg gstreamer jack pulseaudio systemd test vulkan X"

BDEPEND="
app-doc/xmltoman
doc? (
app-doc/doxygen
media-gfx/graphviz
)
"
RDEPEND="
>=media-libs/alsa-lib-1.1.7
media-libs/libsdl2
>=media-libs/libsndfile-1.0.20
sys-apps/dbus
virtual/libudev
bluetooth? (
media-libs/sbc
net-wireless/bluez:=
)
ffmpeg? ( media-video/ffmpeg:= )
gstreamer? (
>=dev-libs/glib-2.32.0:2
>=media-libs/gstreamer-1.10.0:1.0
media-libs/gst-plugins-base:1.0
)
jack? ( >=media-sound/jack2-1.9.10:2 )
pulseaudio? (
dev-libs/glib:2
>=media-sound/pulseaudio-11.1
)
systemd? ( sys-apps/systemd )
vulkan? ( media-libs/vulkan-loader )
X? ( x11-libs/libX11 )
"
DEPEND="${RDEPEND}
vulkan? ( dev-util/vulkan-headers )
"

DOCS=( {README,INSTALL}.md NEWS )

RESTRICT="!test? ( test )"

src_prepare() {
spa_use() {
if ! in_iuse ${1} || ! use ${1}; then
sed -e "/^add-spa-lib.*${1}/s/^/#${2-$1}-disabled-by-USE-no-${1}\:/" \
-e "/^load-module.*${1}/s/^/#${2-$1}-disabled-by-USE-no-${1}\:/" \
-i src/daemon/pipewire.conf.in || die
fi
}

default
spa_use libcamera
spa_use rtkit
spa_use bluetooth bluez5
spa_use jack
spa_use vulkan
}

src_configure() {
local emesonargs=(
-Dexamples=true # contains required pipewire-media-session
-Dman=true
-Dspa=true
-Dspa-plugins=true
--buildtype=$(usex debug debugoptimized plain)
# alsa plugin and jack/pulseaudio emulation
-Dpipewire-alsa=true
$(meson_use jack pipewire-jack)
$(meson_use pulseaudio pipewire-pulseaudio)
# spa-plugins
# we install alsa support unconditionally
$(meson_use bluetooth bluez5)
$(meson_use ffmpeg)
$(meson_use jack)
$(meson_use vulkan)
# libcamera is not packaged
# misc
$(meson_use doc docs)
$(meson_use gstreamer)
$(meson_use systemd)
$(meson_use test test)
$(meson_use test tests)
)
meson_src_configure
}

src_install() {
meson_src_install

dosym ../../../usr/share/alsa/alsa.conf.d/50-pipewire.conf /etc/alsa/conf.d/50-pipewire.conf

# # TODO: this breaks alsa users
# if use alsa; then
# dosym ../../../usr/share/alsa/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/99-pipewire-default.conf
# fi
}

pkg_postinst() {
elog "Package has optional sys-auth/rtkit RUNTIME support that may be disabled"
elog "by setting DISABLE_RTKIT env var."
elog "To enable rtkit, uncomment the load-module line in /etc/pipewire/pipewire.conf"
elog
if use jack; then
elog "Please note that even though the libraries for JACK emulation have"
elog "been installed, this ebuild is not yet wired up to replace a JACK server."
elog
fi
if use pulseaudio; then
elog "Please note that even though the libraries for PulseAudio emulation have"
elog "been installed, this ebuild is not yet wired up to replace PulseAudio."
elog
fi
elog "Read INSTALL.md for information about ALSA plugin or JACK/PulseAudio emulation."
}

0 comments on commit 50191b9

Please sign in to comment.