Skip to content

Commit

Permalink
dev-util/android-studio: bump to 3.1.2.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
perfinion committed Apr 27, 2018
1 parent fb47df7 commit 5068c6a
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/android-studio/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST android-studio-ide-171.4443003-linux.zip 773670325 BLAKE2B b8cff0b85cf20f9d181b4f5c29dc75385539ca2d8e2677211c6c42fcb115616c4208faa5df8cc8a8210c4e9e869d00ae42e7c9dd212756608ff9d4f47bdc8943 SHA512 ba91309c59e4f258222f5b5978bc9ea048476bab4d0662235c7900590f9d58716dc77e937464fab0e57752ee18353a13c163ee98615474f48d0b99e04dae1d34
DIST android-studio-ide-173.4697961-linux.zip 894046861 BLAKE2B 233fefaed2a0b9c70e6cabc61663dd15d9a2486d1df17a45fc71d9c542ffd9212fc36ef54e22032ffa709a76aae796b2f14b189e31a79e96dfb0736017cacae9 SHA512 787a1cf1ab74f84cd39f663496b7b0e1cfc77130d4a7b8b732d010cf2dd553865f368463e07220144c7e9f7d5c12e20ec149ea05f5ee2f8e291537a99d678ff0
DIST android-studio-ide-173.4720617-linux.zip 894052929 BLAKE2B cc1ff03b24febf18e8ebd9a78ae0463e9552e20ee4c28e60e5e4f52379e66d6e5c6d91af1cd641b79c72590a081770a22882539612028915cd064834c8bc0ef3 SHA512 121d5eead42743127dfccf37b0b4bc4ceddc0df706bdddbc8c0ae2ec3711b4c8308d945b92ed5e8b3209d380e202dc08fbf8475ef6ad30016ca5cc9acb264d3e
108 changes: 108 additions & 0 deletions dev-util/android-studio/android-studio-3.1.2.0.173.4720617.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils java-pkg-2 versionator

RESTRICT="strip"
QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
opt/${PN}/bin/fsnotifier*
opt/${PN}/lib/libpty/linux/x86*/libpty.so
opt/${PN}/plugins/android/lib/libwebp_jni*.so
opt/${PN}/plugins/android/resources/perfa/*/libperfa.so
opt/${PN}/plugins/android/resources/perfd/*/perfd
opt/${PN}/plugins/android/resources/simpleperf/*/simpleperf"

if [[ $(get_version_component_count) -eq 6 ]]; then
STUDIO_V=$(get_version_component_range 1-4)
BUILD_V=$(get_version_component_range 5-6)
else
STUDIO_V=$(get_version_component_range 1-3)
BUILD_V=$(get_version_component_range 4-5)
fi

DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="selinux"
KEYWORDS="~amd64 ~x86"

DEPEND="app-arch/zip
dev-java/commons-logging:0
dev-java/log4j:0"

# dev-java/guava:18
RDEPEND=">=virtual/jdk-1.7
selinux? ( sec-policy/selinux-android )
>=app-arch/bzip2-1.0.6-r4
dev-java/commons-logging:0
dev-java/log4j:0
>=dev-libs/expat-2.1.0-r3
>=dev-libs/libffi-3.0.13-r1
>=media-libs/fontconfig-2.10.92
>=media-libs/freetype-2.5.5
>=media-libs/libpng-1.2.51
>=media-libs/mesa-10.2.8
|| ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
>=sys-libs/ncurses-5.9-r3:5/5[tinfo]
>=sys-libs/zlib-1.2.8-r1
>=x11-libs/libX11-1.6.2
>=x11-libs/libXau-1.0.7-r1
>=x11-libs/libXdamage-1.1.4-r1
>=x11-libs/libXdmcp-1.1.1-r1
>=x11-libs/libXext-1.3.2
>=x11-libs/libXfixes-5.0.1
>=x11-libs/libXrender-0.9.8
>=x11-libs/libXxf86vm-1.1.3
>=x11-libs/libdrm-2.4.46
>=x11-libs/libxcb-1.9.1
>=x11-libs/libxshmfence-1.1"
S=${WORKDIR}/${PN}

src_prepare() {
eapply_user
# This is really a bundled jdk not a jre
rm -R "${S}/jre" || die "Could not remove bundled jdk"

# Replace bundled jars with system
# has problems with newer jdom:0 not updated to jdom:2
cd "${S}/lib" || die
local JARS="commons-logging log4j"
local j
for j in ${JARS}; do
rm -v ${j/:*/}*.jar || die
java-pkg_jar-from ${j}
done

cd "${S}" || die

# bug 629404
echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
}

src_compile() {
:
}

src_install() {
local dir="/opt/${PN}"

insinto "${dir}"
# Replaced bundled jre with system vm/jdk
# This is really a bundled jdk not a jre
doins -r *

rm -rf "${D}${dir}/jre" || die
dosym "/etc/java-config-2/current-system-vm" "${dir}/jre"

fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die

newicon "bin/studio.png" "${PN}.png"
make_wrapper ${PN} ${dir}/bin/studio.sh
make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
}

0 comments on commit 5068c6a

Please sign in to comment.