Skip to content

Commit

Permalink
net-analyzer/goaccess: changes in live ebuild
Browse files Browse the repository at this point in the history
In accordance to gentoo#26693

Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Vladimir Pavljuchenkov <[email protected]>
Closes: gentoo#27109
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
SpiderX authored and juippis committed Sep 27, 2022
1 parent 5c820de commit 506ad4e
Showing 1 changed file with 45 additions and 24 deletions.
69 changes: 45 additions & 24 deletions net-analyzer/goaccess/goaccess-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,51 +1,72 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
EAPI=8

inherit autotools
EGIT_REPO_URI="https://github.com/allinurl/${PN}.git"

if [[ ${PV} = *9999* ]] ; then
EGIT_REPO_URI="https://github.com/allinurl/${PN}.git"
inherit git-r3
else
SRC_URI="https://tar.goaccess.io/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
fi
inherit autotools git-r3 optfeature systemd tmpfiles

DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
DESCRIPTION="A real-time web log analyzer and interactive viewer in a terminal"
HOMEPAGE="https://goaccess.io"
SRC_URI=""

LICENSE="MIT"
SLOT="0"
KEYWORDS=""
IUSE="debug geoip geoipv2 getline ssl unicode"
REQUIRED_USE="geoipv2? ( geoip )"

BDEPEND="virtual/pkgconfig"
RDEPEND="sys-libs/ncurses:=[unicode(+)?]
RDEPEND="acct-group/goaccess
acct-user/goaccess
sys-libs/ncurses:=[unicode(+)?]
geoip? (
!geoipv2? ( dev-libs/geoip )
geoipv2? ( dev-libs/libmaxminddb:0= )
)
ssl? (
dev-libs/openssl:0=
)"
ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_prepare() {
default

# Change path to GeoIP bases in config
sed -i -e s':/usr/local:/usr:' config/goaccess.conf || die "sed failed for goaccess.conf"
# Enable log-format, define log file and db path,
# change path to GeoIP bases in config
sed -i -e '/log-format COMBINED/s/#//' \
-e '/log-file/s/#//' \
-e '/db-path/s|tmp|var/lib/goaccess|' \
-e '/geoip-database/s|local/||' config/goaccess.conf \
|| die "sed failed for goaccess.conf"

eautoreconf
}

src_configure() {
econf \
"$(use_enable debug)" \
"$(use_enable geoip geoip "$(usex geoipv2 mmdb legacy)")" \
"$(use_enable unicode utf8)" \
"$(use_with getline)" \
"$(use_with ssl openssl)"
local myeconfargs=()
readarray -t myeconfargs < <(
use_enable debug
use_enable geoip geoip "$(usex geoipv2 mmdb legacy)"
use_enable unicode utf8
use_with getline
use_with ssl openssl
)
econf "${myeconfargs[@]}"
}

src_install() {
default

newinitd "${FILESDIR}"/goaccess.initd goaccess
newconfd "${FILESDIR}"/goaccess.confd goaccess
systemd_dounit "${FILESDIR}"/goaccess.service
newtmpfiles "${FILESDIR}"/goaccess.tmpfile goaccess.conf

diropts -o goaccess -g goaccess -m 0700
keepdir /var/lib/goaccess/db /var/log/goaccess
}

pkg_postinst() {
optfeature "update GeoIP databases" net-misc/geoipupdate
tmpfiles_process goaccess.conf
}

0 comments on commit 506ad4e

Please sign in to comment.