forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-devel/gcc: Fix build of gcc-4.9.4 by gcc-6.4.0, bug 638056
Solution found by Zorry Closes: https://bugs.gentoo.org/638056 Package-Manager: Portage-2.3.14, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
70 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
From 41a4aa66eac45c8862a79351647ec06dd03bd1f5 Mon Sep 17 00:00:00 2001 | ||
From: jakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4> | ||
Date: Sat, 13 Dec 2014 11:24:37 +0000 | ||
Subject: [PATCH] PR bootstrap/64023 * Makefile.tpl | ||
(EXTRA_TARGET_FLAGS): Set STAGE1_LDFLAGS to POSTSTAGE1_LDFLAGS and | ||
STAGE1_LIBS to POSTSTAGE1_LIBS. Add -B to libstdc++-v3/src/.libs and | ||
libstdc++-v3/libsupc++/.libs to CXX. * Makefile.in: Regenerated. | ||
|
||
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@218705 138bc75d-0d04-0410-961f-82ee72b054a4 | ||
--- | ||
ChangeLog | 9 +++++++++ | ||
Makefile.in | 6 +++++- | ||
Makefile.tpl | 6 +++++- | ||
3 files changed, 19 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/Makefile.in b/Makefile.in | ||
index ba5ae4c2ecb..8ffc313f157 100644 | ||
--- a/Makefile.in | ||
+++ b/Makefile.in | ||
@@ -835,7 +835,9 @@ EXTRA_TARGET_FLAGS = \ | ||
'AS=$(COMPILER_AS_FOR_TARGET)' \ | ||
'CC=$$(CC_FOR_TARGET) $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
'CFLAGS=$$(CFLAGS_FOR_TARGET)' \ | ||
- 'CXX=$$(CXX_FOR_TARGET) $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
+ 'CXX=$$(CXX_FOR_TARGET) -B$$r/$$(TARGET_SUBDIR)/libstdc++-v3/src/.libs \ | ||
+ -B$$r/$$(TARGET_SUBDIR)/libstdc++-v3/libsupc++/.libs \ | ||
+ $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
'CXXFLAGS=$$(CXXFLAGS_FOR_TARGET)' \ | ||
'DLLTOOL=$$(DLLTOOL_FOR_TARGET)' \ | ||
'GCJ=$$(GCJ_FOR_TARGET) $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
@@ -853,6 +855,8 @@ EXTRA_TARGET_FLAGS = \ | ||
'WINDRES=$$(WINDRES_FOR_TARGET)' \ | ||
'WINDMC=$$(WINDMC_FOR_TARGET)' \ | ||
'XGCC_FLAGS_FOR_TARGET=$(XGCC_FLAGS_FOR_TARGET)' \ | ||
+ 'STAGE1_LDFLAGS=$$(POSTSTAGE1_LDFLAGS)' \ | ||
+ 'STAGE1_LIBS=$$(POSTSTAGE1_LIBS)' \ | ||
"TFLAGS=$$TFLAGS" | ||
|
||
TARGET_FLAGS_TO_PASS = $(BASE_FLAGS_TO_PASS) $(EXTRA_TARGET_FLAGS) | ||
diff --git a/Makefile.tpl b/Makefile.tpl | ||
index dcbc6b1b143..bb8227eaafa 100644 | ||
--- a/Makefile.tpl | ||
+++ b/Makefile.tpl | ||
@@ -641,7 +641,9 @@ EXTRA_TARGET_FLAGS = \ | ||
'AS=$(COMPILER_AS_FOR_TARGET)' \ | ||
'CC=$$(CC_FOR_TARGET) $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
'CFLAGS=$$(CFLAGS_FOR_TARGET)' \ | ||
- 'CXX=$$(CXX_FOR_TARGET) $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
+ 'CXX=$$(CXX_FOR_TARGET) -B$$r/$$(TARGET_SUBDIR)/libstdc++-v3/src/.libs \ | ||
+ -B$$r/$$(TARGET_SUBDIR)/libstdc++-v3/libsupc++/.libs \ | ||
+ $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
'CXXFLAGS=$$(CXXFLAGS_FOR_TARGET)' \ | ||
'DLLTOOL=$$(DLLTOOL_FOR_TARGET)' \ | ||
'GCJ=$$(GCJ_FOR_TARGET) $$(XGCC_FLAGS_FOR_TARGET) $$(TFLAGS)' \ | ||
@@ -659,6 +661,8 @@ EXTRA_TARGET_FLAGS = \ | ||
'WINDRES=$$(WINDRES_FOR_TARGET)' \ | ||
'WINDMC=$$(WINDMC_FOR_TARGET)' \ | ||
'XGCC_FLAGS_FOR_TARGET=$(XGCC_FLAGS_FOR_TARGET)' \ | ||
+ 'STAGE1_LDFLAGS=$$(POSTSTAGE1_LDFLAGS)' \ | ||
+ 'STAGE1_LIBS=$$(POSTSTAGE1_LIBS)' \ | ||
"TFLAGS=$$TFLAGS" | ||
|
||
TARGET_FLAGS_TO_PASS = $(BASE_FLAGS_TO_PASS) $(EXTRA_TARGET_FLAGS) | ||
-- | ||
2.15.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters