Skip to content

Commit

Permalink
gui-apps/wf-shell: basic desktop shell for wayfire
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/713880

a simple shell which showcases the capabilities of
the wayfire window manager

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Aisha Tammy <[email protected]>
Closes: gentoo#15050
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
epsilon-0 authored and FuzzyGophers committed May 17, 2020
1 parent 3713d3b commit 5087a09
Show file tree
Hide file tree
Showing 4 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-apps/wf-shell/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST wf-shell-0.4.0.tar.xz 8996656 BLAKE2B 609668bcf00fcc7a0b8142d84a7101f07578c2d6a88616da286a615076372e5a356387cf5e3fdee9b4aba6f027d8d081a5cce32f7f00682a756d4ee9bc46916d SHA512 1b293ce3fc2b12acbadb75e0de28217ed24f733e26d7ad12ada9a5f0673df911e75eea5af6841c466f031151f881a8e36dda229ea4dc2f91825e2e6df42d4903
18 changes: 18 additions & 0 deletions gui-apps/wf-shell/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription>
Basic desktop environment for use with wayfire
which showcases all its plugins and desktop
effects. Integrates with other wayland
applications to provide a full desktop environment
</longdescription>
<maintainer type="person">
<email>[email protected]</email>
<name>Aisha Tammy</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>
49 changes: 49 additions & 0 deletions gui-apps/wf-shell/wf-shell-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="A compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wf-shell"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+pulseaudio debug"

DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
~gui-wm/wayfire-${PV}
>=gui-libs/gtk-layer-shell-0.1
pulseaudio? ( media-sound/pulseaudio )
"

RDEPEND="${DEPEND}"

BDEPEND="
${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"

src_compile () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
)
if use debug; then
emesonargs+=(
"-Db_sanitize=address,undefined"
)
fi
meson_src_compile
}
49 changes: 49 additions & 0 deletions gui-apps/wf-shell/wf-shell-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="A compiz like 3D wayland compositor"
HOMEPAGE="https://github.com/WayfireWM/wf-shell"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
else
SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+pulseaudio debug"

DEPEND="
dev-cpp/gtkmm:3.0=[wayland]
dev-libs/gobject-introspection
~gui-wm/wayfire-${PV}
>=gui-libs/gtk-layer-shell-0.1
pulseaudio? ( media-sound/pulseaudio )
"

RDEPEND="${DEPEND}"

BDEPEND="
${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"

src_compile () {
local emesonargs=(
"$(meson_feature pulseaudio pulse)"
)
if use debug; then
emesonargs+=(
"-Db_sanitize=address,undefined"
)
fi
meson_src_compile
}

0 comments on commit 5087a09

Please sign in to comment.