Skip to content

Commit

Permalink
app-crypt/acme: brings multiple reworks (bug 881043)
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/881043

The purpose of this rework is to use parent package archive as common
base for all the modules.

Warnings: some modifications might require some reviews, tests were done
but maybe not thoroughly enough.

Reworks:
  - replaces deprecated DISTUTILS_USE_SETUPTOOLS by
    DISTUTILS_USE_PEP517, with "setuptools" (DistutilsNonPEP517Build);
  - integrates parent mechanism for base source;
  - stores archive with ".gh" in its extension (PythonGHDistfileSuffix)
    also use parent’s file;
  - common "S" path definition for live ebuild.

Signed-off-by: Thibaud CANALE <[email protected]>
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
thican authored and prometheanfire committed Feb 16, 2023
1 parent 31d7c23 commit 509cc95
Show file tree
Hide file tree
Showing 5 changed files with 207 additions and 7 deletions.
3 changes: 3 additions & 0 deletions app-crypt/acme/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,5 @@
DIST certbot-2.1.0.tar.gz 1327451 BLAKE2B c4694622648427146574aa7c056d5d76dc3c4f6b8487a506d1c4996239f979d89ca26980b2ffbaab975458d0691acaa07a46a75098b6146e6e3c51e6eaa64be0 SHA512 83c3a6abeffb135cebd0d0f4561f3814039962e3b895aaf7bef6570641fccda2da04f1a6110c5e90d6ed3346402cbb3ff543b0a096e8e18f6345edd22da643cc
DIST certbot-2.1.1.gh.tar.gz 1327548 BLAKE2B 21ce7d88bc101147be237201d472f43ea71adafe37789b0a46d7d87b0bc0f1270044386507bc516beb658633cbaebcade06e0f7f6f833848e10660a6b0a09279 SHA512 9bd5d3259954fbf09287a74532ad73a6271ed07bac0e3593edc08662d562e8939982a92daca3eb5d6e6516ab530e15e0594124465e6f6608b004594418e34042
DIST certbot-2.2.0.gh.tar.gz 1331053 BLAKE2B 4a3e6d8b0b3b7f8537bd6b24234bad7657842ee64865bcef2701e572501640b7a2d49cf4dc62db25cda1039be2d20fb77ac6415cdcb4756fce0f96b5cb7410c6 SHA512 242bfa8e5b60c28b49457403b41421ef782b9f98f325cc423b58283fef410b33691c3ce126188b191c80fcd488fe5d51acfc5ca575c8e7c5b6b08198844bffb7
DIST certbot-2.2.0.tar.gz 1331053 BLAKE2B 4a3e6d8b0b3b7f8537bd6b24234bad7657842ee64865bcef2701e572501640b7a2d49cf4dc62db25cda1039be2d20fb77ac6415cdcb4756fce0f96b5cb7410c6 SHA512 242bfa8e5b60c28b49457403b41421ef782b9f98f325cc423b58283fef410b33691c3ce126188b191c80fcd488fe5d51acfc5ca575c8e7c5b6b08198844bffb7
DIST certbot-2.3.0.gh.tar.gz 1335613 BLAKE2B af8ff393f92755e8e312f7596fe99abefa35c42cef6fa6688f7f3dd4a310205385fec81366df30d8edfe28d8abd3db447c9e1a3770fe31c3d45c69f04a038660 SHA512 5f52d9b0dd390fc696389a94ff897d803ee062feca50bb66972e197dcd79b0096b337cece2798557c3878903577171fd9afe1f18a4a2131ad7e6a62d0d945ebb
59 changes: 59 additions & 0 deletions app-crypt/acme/acme-2.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools

inherit distutils-r1

PARENT_PN="certbot"
PARENT_P="${PARENT_PN}-${PV}"

if [[ "${PV}" == *9999 ]]; then
inherit git-r3

EGIT_REPO_URI="https://github.com/certbot/certbot.git"
EGIT_SUBMODULES=()
EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
else
SRC_URI="
https://github.com/certbot/certbot/archive/v${PV}.tar.gz
-> ${PARENT_P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi

DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="
https://github.com/certbot/certbot
https://letsencrypt.org/
"

LICENSE="Apache-2.0"
SLOT="0"

S="${WORKDIR}/${PARENT_P}/${PN}"

BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"

RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"

distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
59 changes: 59 additions & 0 deletions app-crypt/acme/acme-2.2.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools

inherit distutils-r1

PARENT_PN="certbot"
PARENT_P="${PARENT_PN}-${PV}"

if [[ "${PV}" == *9999 ]]; then
inherit git-r3

EGIT_REPO_URI="https://github.com/certbot/certbot.git"
EGIT_SUBMODULES=()
EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
else
SRC_URI="
https://github.com/certbot/certbot/archive/v${PV}.tar.gz
-> ${PARENT_P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi

DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="
https://github.com/certbot/certbot
https://letsencrypt.org/
"

LICENSE="Apache-2.0"
SLOT="0"

S="${WORKDIR}/${PARENT_P}/${PN}"

BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"

RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"

distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
59 changes: 59 additions & 0 deletions app-crypt/acme/acme-2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools

inherit distutils-r1

PARENT_PN="certbot"
PARENT_P="${PARENT_PN}-${PV}"

if [[ "${PV}" == *9999 ]]; then
inherit git-r3

EGIT_REPO_URI="https://github.com/certbot/certbot.git"
EGIT_SUBMODULES=()
EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
else
SRC_URI="
https://github.com/certbot/certbot/archive/v${PV}.tar.gz
-> ${PARENT_P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi

DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="
https://github.com/certbot/certbot
https://letsencrypt.org/
"

LICENSE="Apache-2.0"
SLOT="0"

S="${WORKDIR}/${PARENT_P}/${PN}"

BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"

RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
>=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"

distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
34 changes: 27 additions & 7 deletions app-crypt/acme/acme-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,26 +4,46 @@
EAPI=8

PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_SETUPTOOLS=rdepend
DISTUTILS_USE_PEP517=setuptools

inherit distutils-r1

if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
PARENT_PN="certbot"
PARENT_P="${PARENT_PN}-${PV}"

if [[ "${PV}" == *9999 ]]; then
inherit git-r3
S=${WORKDIR}/${P}/${PN}

EGIT_REPO_URI="https://github.com/certbot/certbot.git"
EGIT_SUBMODULES=()
EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
else
SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
SRC_URI="
https://github.com/certbot/certbot/archive/v${PV}.tar.gz
-> ${PARENT_P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
S=${WORKDIR}/certbot-${PV}/acme
fi

DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
HOMEPAGE="
https://github.com/certbot/certbot
https://letsencrypt.org/
"

LICENSE="Apache-2.0"
SLOT="0"

S="${WORKDIR}/${PARENT_P}/${PN}"

BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"

RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
Expand Down

0 comments on commit 509cc95

Please sign in to comment.