Skip to content

Commit

Permalink
media-libs/clutter-gst: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
pacho2 committed Feb 20, 2016
1 parent e672385 commit 50bd97b
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/clutter-gst/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST clutter-gst-2.0.16.tar.xz 357380 SHA256 a944f84186937021aba6329c23954f6015d33bf151ba8994e13c59cefd742039 SHA512 ace0eceb8f99ad78190f6ebb9caf45ccc5597fff2e4dfda4e3bf539e87f41d3d60f66637219244bd28fe32f374460e3456c8dc5d0c60ac057cc73f2f1d60c764 WHIRLPOOL dd60f5722381f8e7678cd9e47b191a1e80c313c138d3cd5cb0acb1131d13ca565dd4f9e8117eda7ed1c81ae0b0bb9cca44530403615f3545ba44c012c12b70eb
DIST clutter-gst-3.0.14.tar.xz 391596 SHA256 f7c8a7dc479759cad5ff7483cb5a1abbe3efd0b4f83ed0e443dc602430a82de2 SHA512 6d50607e684e6c57525b9408f9b256c045fc1425d0646809fc9bdfc43536b0f8d3d2bd54b0176996e1894824c77cf9269d2c6d62adb29a5e2485f8a671126145 WHIRLPOOL bc2c289dbcd518eb4087d092cf97c0c3a0ccbe60742556b436897657cd9e9007658630d6487bbcd585923ed451e9a3cca922d72fa0ec8793ade7b04748da150a
DIST clutter-gst-3.0.16.tar.xz 406328 SHA256 803e8b7265e63e0581e21fd0c6064792dfe951512e9f515e9e7a9b452caaf9f0 SHA512 ad543156e05828a28d89d49080618fb64a010247eceee87d5930c14cd4ddc4fd276f6b30be8790d9003c988be45ead8c258157d72e60db0ea089eb068229da21 WHIRLPOOL 5ddf357183baed580fddf3b1171f30139495cfb7eb36571724b8c7ad7e758d6850aed6ef5ac3eb7452a2491bcf11c7748b9ce639a069b00c6078960d2e8e91dc
64 changes: 64 additions & 0 deletions media-libs/clutter-gst/clutter-gst-3.0.16.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 )

inherit gnome2 python-any-r1

HOMEPAGE="https://blogs.gnome.org/clutter/"
DESCRIPTION="GStreamer integration library for Clutter"

LICENSE="LGPL-2.1+"
SLOT="3.0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="X examples +introspection udev"

# >=cogl-1.18 provides cogl-2.0-experimental
COMMON_DEPEND="
>=dev-libs/glib-2.20:2
>=media-libs/clutter-1.20:1.0=[X=,introspection?]
>=media-libs/cogl-1.18:1.0=[introspection?]
>=media-libs/gstreamer-1.4:1.0[introspection?]
>=media-libs/gst-plugins-bad-1.4:1.0
>=media-libs/gst-plugins-base-1.4:1.0[introspection?]
introspection? ( >=dev-libs/gobject-introspection-0.6.8:= )
udev? ( virtual/libgudev )
"
# uses goom from gst-plugins-good
RDEPEND="${COMMON_DEPEND}
>=media-libs/gst-plugins-good-1.4:1.0
!udev? ( media-plugins/gst-plugins-v4l2 )
"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
>=dev-util/gtk-doc-am-1.11
virtual/pkgconfig
"

src_configure() {
# --enable-gl-texture-upload is experimental
gnome2_src_configure \
--disable-maintainer-flags \
$(use_enable introspection) \
$(use_enable udev)
}

src_compile() {
# Clutter tries to access dri without userpriv, upstream bug #661873
# Massive failure of a hack, see bug 360219, bug 360073, bug 363917
unset DISPLAY
gnome2_src_compile
}

src_install() {
gnome2_src_install

if use examples; then
insinto /usr/share/doc/"${PF}"/examples
doins examples/{*.c,*.png,README}
fi
}

0 comments on commit 50bd97b

Please sign in to comment.