forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.2
- Loading branch information
Showing
4 changed files
with
195 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,3 @@ | ||
DIST beets-1.3.13.tar.gz 1269748 SHA256 6d973c3484079b22b7d281f771a97c03f9bb14bdd94f45b673f9d754875b2c59 SHA512 ffee7e16a115f16c26ab07a75e614746cd5871a7311660d37978deff34245f3aeab97b1a453fc0900442f40e6ac7d102c5adfce910edfec78387fc149fbea261 WHIRLPOOL 79b345612b04965aa6d4b7cc819d7ed1942b5686bf3990612f2c243dc47a2cfc3f15550f97ee30502ce42f4c24cf2ade27e9db6393f40022ffedf6842f4dc05c | ||
DIST beets-1.3.19.tar.gz 1349402 SHA256 6b241e62764a9c4bf9bf570acacc4681d30513f0f2268faa5da494ec066c21ee SHA512 86d2bae8d047a81b7a21f3fc322bb23e383193004de02e8ba0641d564054b58c8828dd112ba437e6fb1d40d9b9521d00b7717c29f33b88b8b559cdbf0ca407ae WHIRLPOOL bb25144deff5234db04b9e18c7e4c0be15a754251671f7a5461731114023fac6b866bb0abe8275a4efa66d3eec0096081dc8ed3c3e029dc0270236c4dcb818c2 | ||
DIST beets-1.4.3.tar.gz 1428494 SHA256 b93fbe11998a29cd432b0a88741b9ced0e5ac50e80362d41e13e867d851ae464 SHA512 b95a9056abae5da3db7786342e8969b4f9c86c2c4589dd48bad244d28ef3d3da4900d3d3eaee1e45964960c62ecaa8d754a33829e0d7f497f01ecc763c0f492d WHIRLPOOL 514aef47d59db4489d0bf48e9ed3a4e8c9a9e1d7dee2a8b1ecf0568bb319511c3bedec012cfa6270e5d5ef50ecc0befd17c908951df2da1875a5c4e088abab2b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,91 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="sqlite" | ||
inherit distutils-r1 eutils | ||
|
||
MY_PV=${PV/_beta/-beta.} | ||
MY_P=${PN}-${MY_PV} | ||
|
||
DESCRIPTION="A media library management system for obsessive-compulsive music geeks" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
HOMEPAGE="http://beets.radbox.org/ https://pypi.python.org/pypi/beets" | ||
|
||
KEYWORDS="~amd64 ~x86" | ||
SLOT="0" | ||
LICENSE="MIT" | ||
IUSE="badfiles bpd chroma convert doc discogs flac gstreamer lastgenre mpdstats | ||
ogg opus replaygain test web" | ||
|
||
RDEPEND=">=dev-python/enum34-1.0.4[${PYTHON_USEDEP}] | ||
dev-python/jellyfish[${PYTHON_USEDEP}] | ||
dev-python/munkres[${PYTHON_USEDEP}] | ||
dev-python/requests[${PYTHON_USEDEP}] | ||
dev-python/requests-oauthlib[${PYTHON_USEDEP}] | ||
>=dev-python/python-musicbrainz-ngs-0.4[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/unidecode[${PYTHON_USEDEP}] | ||
>=media-libs/mutagen-1.27[${PYTHON_USEDEP}] | ||
badfiles? ( media-sound/mp3val media-libs/flac ) | ||
bpd? ( dev-python/bluelet[${PYTHON_USEDEP}] ) | ||
chroma? ( dev-python/pyacoustid[${PYTHON_USEDEP}] ) | ||
convert? ( media-video/ffmpeg:0[encode] ) | ||
discogs? ( dev-python/discogs-client[${PYTHON_USEDEP}] ) | ||
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] ) | ||
mpdstats? ( dev-python/python-mpd[${PYTHON_USEDEP}] ) | ||
lastgenre? ( dev-python/pylast[${PYTHON_USEDEP}] ) | ||
replaygain? ( | ||
gstreamer? ( media-libs/gstreamer:1.0[introspection] | ||
media-libs/gst-plugins-good:1.0 | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
ogg? ( media-plugins/gst-plugins-ogg ) | ||
flac? ( media-plugins/gst-plugins-flac:1.0 ) | ||
opus? ( media-plugins/gst-plugins-opus:1.0 ) ) | ||
!gstreamer? ( || ( media-sound/mp3gain | ||
media-sound/aacgain ) ) ) | ||
web? ( dev-python/flask[${PYTHON_USEDEP}] )" | ||
DEPEND="${RDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}]" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
# remove plugins that do not have appropriate dependencies installed | ||
for flag in badfiles bpd chroma convert discogs lastgenre mpdstats replaygain web; do | ||
if ! use ${flag}; then | ||
rm -r beetsplug/${flag}.py || \ | ||
rm -r beetsplug/${flag}/ || | ||
die "Unable to remove ${flag} plugin" | ||
fi | ||
done | ||
|
||
for flag in bpd lastgenre web; do | ||
if ! use ${flag}; then | ||
sed -e "s:'beetsplug.${flag}',::" -i setup.py || \ | ||
die "Unable to disable ${flag} plugin " | ||
fi | ||
done | ||
|
||
use bpd || rm -f test/test_player.py | ||
|
||
} | ||
|
||
python_compile_all() { | ||
use doc && emake -C docs html | ||
} | ||
|
||
python_test() { | ||
cd test | ||
if ! use web; then | ||
rm test_web.py || die "Failed to remove test_web.py" | ||
fi | ||
"${PYTHON}" testall.py || die "Testsuite failed" | ||
} | ||
|
||
python_install_all() { | ||
doman man/beet.1 man/beetsconfig.5 | ||
use doc && dohtml -r docs/_build/html/ | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,97 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="sqlite" | ||
inherit distutils-r1 eutils | ||
|
||
MY_PV=${PV/_beta/-beta.} | ||
MY_P=${PN}-${MY_PV} | ||
|
||
DESCRIPTION="A media library management system for obsessive-compulsive music geeks" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
HOMEPAGE="http://beets.io/ https://pypi.python.org/pypi/beets" | ||
|
||
KEYWORDS="~amd64 ~x86" | ||
SLOT="0" | ||
LICENSE="MIT" | ||
IUSE="badfiles bpd chroma convert doc discogs flac gstreamer lastgenre lastimport mpdstats ogg opus replaygain test thumbnails web" | ||
|
||
RDEPEND=">=dev-python/enum34-1.0.4[${PYTHON_USEDEP}] | ||
dev-python/jellyfish[${PYTHON_USEDEP}] | ||
dev-python/munkres[${PYTHON_USEDEP}] | ||
dev-python/requests[${PYTHON_USEDEP}] | ||
dev-python/requests-oauthlib[${PYTHON_USEDEP}] | ||
>=dev-python/python-musicbrainz-ngs-0.4[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/unidecode[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9[${PYTHON_USEDEP}] | ||
>=media-libs/mutagen-1.33[${PYTHON_USEDEP}] | ||
badfiles? ( media-sound/mp3val media-libs/flac ) | ||
bpd? ( dev-python/bluelet[${PYTHON_USEDEP}] ) | ||
chroma? ( dev-python/pyacoustid[${PYTHON_USEDEP}] ) | ||
convert? ( media-video/ffmpeg:0[encode] ) | ||
discogs? ( dev-python/discogs-client[${PYTHON_USEDEP}] ) | ||
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] ) | ||
mpdstats? ( dev-python/python-mpd[${PYTHON_USEDEP}] ) | ||
lastgenre? ( dev-python/pylast[${PYTHON_USEDEP}] ) | ||
lastimport? ( dev-python/pylast[${PYTHON_USEDEP}] ) | ||
replaygain? ( | ||
gstreamer? ( media-libs/gstreamer:1.0[introspection] | ||
media-libs/gst-plugins-good:1.0 | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
ogg? ( media-plugins/gst-plugins-ogg ) | ||
flac? ( media-plugins/gst-plugins-flac:1.0 ) | ||
opus? ( media-plugins/gst-plugins-opus:1.0 ) ) | ||
!gstreamer? ( || ( media-sound/mp3gain media-sound/aacgain ) ) | ||
) | ||
thumbnails? ( | ||
dev-python/pyxdg[${PYTHON_USEDEP}] | ||
dev-python/pathlib[${PYTHON_USEDEP}] | ||
|| ( dev-python/pillow[${PYTHON_USEDEP}] media-gfx/imagemagick ) | ||
) | ||
web? ( dev-python/flask[${PYTHON_USEDEP}] dev-python/flask-cors[${PYTHON_USEDEP}] )" | ||
DEPEND="${RDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}]" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
# remove plugins that do not have appropriate dependencies installed | ||
for flag in bpd chroma convert discogs lastgenre lastimport mpdstats replaygain thumbnails web; do | ||
if ! use ${flag}; then | ||
rm -r beetsplug/${flag}.py || \ | ||
rm -r beetsplug/${flag}/ || | ||
die "Unable to remove ${flag} plugin" | ||
fi | ||
done | ||
|
||
for flag in bpd lastgenre web; do | ||
if ! use ${flag}; then | ||
sed -e "s:'beetsplug.${flag}',::" -i setup.py || \ | ||
die "Unable to disable ${flag} plugin " | ||
fi | ||
done | ||
|
||
use bpd || rm -f test/test_player.py | ||
|
||
} | ||
|
||
python_compile_all() { | ||
use doc && emake -C docs html | ||
} | ||
|
||
python_test() { | ||
cd test | ||
if ! use web; then | ||
rm test_web.py || die "Failed to remove test_web.py" | ||
fi | ||
"${PYTHON}" testall.py || die "Testsuite failed" | ||
} | ||
|
||
python_install_all() { | ||
doman man/beet.1 man/beetsconfig.5 | ||
use doc && dohtml -r docs/_build/html/ | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters