forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/nvidia_video_sdk: Add version 6.0.1, renamed from nvenc t…
…o nvidia_video_sdk since NVIDIA changed the branding. Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <[email protected]>
- Loading branch information
Showing
3 changed files
with
65 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST nvidia_video_sdk_6.0.1.zip 21310785 SHA256 05227ee4015dc9bdf52b4fe8b3ba5a077d80962f35fa3b76d25288adb1dd0122 SHA512 1ab398010f5018482170bf722d84278b1920f003119143911fbb0a811e6f1237a039b4120011cc141728f3fd3d7667295ce8703717eafad82b4675bb3211df87 WHIRLPOOL 4af12758753221975dddc917fc9753b065f526b8cceacd0ab8d82ad3fd88ae7a8c53d4d49f0cce3be4073f6fd4f7ec7261a0d700d0b93f914b263c4c5403ff35 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<herd>video</herd> | ||
<maintainer> | ||
<email>[email protected]</email> | ||
</maintainer> | ||
<use> | ||
<flag name="tools">Build and install example tools.</flag> | ||
</use> | ||
</pkgmetadata> |
53 changes: 53 additions & 0 deletions
53
media-video/nvidia_video_sdk/nvidia_video_sdk-6.0.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit versionator toolchain-funcs | ||
|
||
MY_P="${PN}_${PV}" | ||
|
||
DESCRIPTION="NVIDIA Video Codec SDK" | ||
HOMEPAGE="https://developer.nvidia.com/nvidia-video-codec-sdk" | ||
SRC_URI="https://developer.nvidia.com/video-sdk-$(replace_all_version_separators '') -> ${MY_P}.zip" | ||
|
||
LICENSE="MIT tools? ( NVIDIA-CODEC-SDK )" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="tools" | ||
|
||
RDEPEND=" | ||
!media-video/nvenc | ||
>=x11-drivers/nvidia-drivers-347.09" | ||
DEPEND="${RDEPEND} | ||
app-arch/unzip" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
TOOLS="NvEncoder NvEncoderPerf NvTranscoder NvEncoderLowLatency" | ||
|
||
src_compile() { | ||
if use tools ; then | ||
export EXTRA_LDFLAGS="${LDFLAGS}" | ||
for i in ${TOOLS} ; do | ||
pushd "${S}/Samples/${i}" || die | ||
emake GCC="$(tc-getCXX)" CCFLAGS="${CXXFLAGS}" | ||
popd | ||
done | ||
fi | ||
} | ||
|
||
src_install() { | ||
if use tools ; then | ||
for i in ${TOOLS}; do | ||
dobin "${S}/Samples/${i}/${i}" | ||
done | ||
dodoc "${S}/Samples/NVIDIA_Video_Codec_SDK_Samples_Guide.pdf" | ||
fi | ||
|
||
dodoc doc/*.pdf ReadMe.txt Release_notes.txt | ||
|
||
insinto /usr/include | ||
doins Samples/common/inc/nvEncodeAPI.h | ||
} |