Skip to content

Commit

Permalink
app-benchmarks/i7z: Bump to 93_p20131012, fixes bug #487784
Browse files Browse the repository at this point in the history
Upstream's versioning has gone a bit weird and I don't really
understand it but it also seems dead so there seems little point in
asking.

Upstream probably didn't intend to support Qt5 but it does work with a
tiny patch against the project file.

The GUI segfault in bug #487784 isn't specific to hardened and only
goes away when you drop all -O* flags. This application is more
power-related than benchmark-related so this isn't a big deal.

Package-Manager: portage-2.3.2
  • Loading branch information
chewi committed Nov 5, 2016
1 parent 2ae4676 commit 5113c54
Show file tree
Hide file tree
Showing 5 changed files with 84 additions and 3 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/i7z/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST i7z-0.27.2.tar.gz 51226 SHA256 a7f72d65732c17eef0df4f284927fe744fc650075f2364c51c9497534d8f47f1 SHA512 d693fda4d12bf7b0d8e694d9f97876fcd2cad4556c950b4eab09ae21d121e63e221e1e1b27bcf23a241fd868b09165639ecfafeaa126144ad809199fcaca1cbb WHIRLPOOL aaea6bc544a554703cd85f7e2e075588114a6c807e1311421300464f1468560423e987f1582b5e58a2fd48eb1753559958ea39ed9ab97e621718e7f46e8c476e
DIST i7z-93_p20131012.tar.gz 879969 SHA256 e127bddf850e7febd39cef2d2b13dca5fe19cc2a1bb1099d72b683be5d8bd1c0 SHA512 ef2dfc36407b18a2081413d423cc3d38c38121e386d9068eee9a794b810232727b3abbd22d3b36bc32206f4dc89dd881a4550df19108c439a91f01369bf74d5a WHIRLPOOL f46d7c3ae19920315e68d6c3264d14613f457201e1107c07b6c74632fff13c1cdb75747add8f1618937c5b4430a476dfc5f5d30fc01df16579fd843e4516faab
4 changes: 2 additions & 2 deletions app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
Index: Makefile
===================================================================
--- Makefile (revision 109)
+++ Makefile (working copy)
--- a/Makefile (revision 109)
+++ b/Makefile (working copy)
@@ -19,7 +19,7 @@

CC ?= gcc
Expand Down
13 changes: 13 additions & 0 deletions app-benchmarks/i7z/files/qt5.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff -Naur a/GUI/i7z_GUI.pro b/GUI/i7z_GUI.pro
--- a/GUI/i7z_GUI.pro 2013-10-12 21:59:19.000000000 +0100
+++ b/GUI/i7z_GUI.pro 2016-11-05 13:54:30.118655672 +0000
@@ -3,7 +3,8 @@
######################################################################

TEMPLATE = app
-TARGET =
+TARGET = i7z_GUI
+QT += widgets
DEPENDPATH += .
INCLUDEPATH += .
CONFIG += debug
68 changes: 68 additions & 0 deletions app-benchmarks/i7z/i7z-93_p20131012.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit flag-o-matic qmake-utils toolchain-funcs

COMMIT="5023138d7c35c4667c938b853e5ea89737334e92"
DESCRIPTION="A better i7 (and now i3, i5) reporting tool for Linux"
HOMEPAGE="https://github.com/ajaiantilal/i7z"
SRC_URI="https://github.com/ajaiantilal/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="qt4 qt5"

RDEPEND="sys-libs/ncurses:0=
qt5? (
dev-qt/qtcore:5=
dev-qt/qtgui:5=
dev-qt/qtwidgets:5=
)
!qt5? ( qt4? (
dev-qt/qtcore:4=
dev-qt/qtgui:4=
) )"

DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/i7z-0.27.2-ncurses.patch
"${FILESDIR}"/qt5.patch
)

S="${WORKDIR}/${PN}-${COMMIT}"

src_configure() {
# The GUI segfaults with -O1. None of the documented flags make a
# difference. There may not be a specific flag for the culprit.
filter-flags "-O*"

tc-export CC
cd GUI || die

if use qt5; then
eqmake5 ${PN}_GUI.pro
elif use qt4; then
eqmake4 ${PN}_GUI.pro
fi
}

src_compile() {
default

if use qt5 || use qt4; then
emake -C GUI clean
emake -C GUI
fi
}

src_install() {
emake DESTDIR="${ED}" docdir=/usr/share/doc/${PF} install

if use qt5 || use qt4; then
dosbin GUI/i7z_GUI
fi
}
1 change: 0 additions & 1 deletion app-benchmarks/i7z/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,6 @@
<email>[email protected]</email>
</maintainer>
<upstream>
<remote-id type="google-code">i7z</remote-id>
<remote-id type="github">ajaiantilal/i7z</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 5113c54

Please sign in to comment.