Skip to content

Commit

Permalink
kde-apps/akregator: Try to fix feedlist corruption and crashes
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/629548
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
a17r committed Feb 11, 2018
1 parent da7fa96 commit 5174fc8
Show file tree
Hide file tree
Showing 3 changed files with 38 additions and 0 deletions.
5 changes: 5 additions & 0 deletions kde-apps/akregator/akregator-17.12.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -53,3 +53,8 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
!kde-apps/kdepim-l10n
"

PATCHES=(
"${FILESDIR}/${P}-crashfix.patch"
"${FILESDIR}/${P}-feedlist-corruption.patch"
)
16 changes: 16 additions & 0 deletions kde-apps/akregator/files/akregator-17.12.2-crashfix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
diff --git a/src/mainwindow.cpp b/src/mainwindow.cpp
index fd533ecd..2733b273 100644
--- a/src/mainwindow.cpp
+++ b/src/mainwindow.cpp
@@ -137,9 +137,7 @@ MainWindow::~MainWindow()
void MainWindow::saveProperties(KConfigGroup &config)
{
if (!m_part) {
- if (!loadPart()) {
- return;
- }
+ return;
}

m_part->saveProperties(config);

Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
diff --git a/src/akregator_part.cpp b/src/akregator_part.cpp
index 94a4e00..3d2d778 100644
--- a/src/akregator_part.cpp
+++ b/src/akregator_part.cpp
@@ -514,6 +514,11 @@ void Part::slotSaveFeedList()
if (!m_standardListLoaded) {
return;
}
+
+ QSharedPointer<FeedList> f_list = m_mainWidget->allFeedsList();
+ if (f_list.isNull()) {
+ return;
+ }

// the first time we overwrite the feed list, we create a backup
if (!m_backedUpList) {

0 comments on commit 5174fc8

Please sign in to comment.