forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/libressl: version bump to 2.6.2
Package-Manager: Portage-2.3.8, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
53 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils multilib-minimal | ||
|
||
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL" | ||
HOMEPAGE="http://www.libressl.org/" | ||
SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz" | ||
|
||
LICENSE="ISC openssl" | ||
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ, | ||
# we'll try to use the max of either. However, if either change between | ||
# versions, we have to change the subslot to trigger rebuild of consumers. | ||
SLOT="0/44" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86" | ||
IUSE="+asm static-libs" | ||
|
||
RDEPEND="!dev-libs/openssl:0" | ||
DEPEND="${RDEPEND}" | ||
PDEPEND="app-misc/ca-certificates" | ||
|
||
src_prepare() { | ||
touch crypto/Makefile.in | ||
|
||
sed -i \ | ||
-e '/^[ \t]*CFLAGS=/s#-g ##' \ | ||
-e '/^[ \t]*CFLAGS=/s#-g"#"#' \ | ||
-e '/^[ \t]*CFLAGS=/s#-O2 ##' \ | ||
-e '/^[ \t]*CFLAGS=/s#-O2"#"#' \ | ||
-e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \ | ||
-e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \ | ||
configure || die "fixing CFLAGS failed" | ||
|
||
eapply_user | ||
} | ||
|
||
multilib_src_configure() { | ||
ECONF_SOURCE="${S}" econf \ | ||
$(use_enable asm) \ | ||
$(use_enable static-libs static) | ||
} | ||
|
||
multilib_src_test() { | ||
emake check | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
prune_libtool_files | ||
} |