Skip to content

Commit

Permalink
dev-libs/boost: Include patch for net-analyzer/icinga2
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/704128
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Dec 29, 2019
1 parent 4204aed commit 51a79e3
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-libs/boost/boost-1.72.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -58,6 +58,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.72.0-missing-serialization-split_member-include.patch
# Bug 703036, per python-impl Boost.MPI
"${FILESDIR}"/${PN}-1.72.0-boost-mpi-python.patch
# Bug 704128, missing include on Boost.Ranges
"${FILESDIR}"/${PN}-1.72.0-revert-cease-dependence-on-range.patch
)

python_bindings_needed() {
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
From 436e1dbe6fcd31523d261d18ad011392f1d6fbbc Mon Sep 17 00:00:00 2001
From: Oliver Kowalke <[email protected]>
Date: Sun, 1 Dec 2019 20:40:28 +0100
Subject: [PATCH] Revert "Cease dependence on Range"

This reverts commit 0c556bb59241e682bbcd3f572815149c5a9b17db.

see #44 (One test fails to compile after boostorg/coroutine submodule updated)
---
boost/coroutine/asymmetric_coroutine.hpp | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

diff --git a/boost/coroutine/asymmetric_coroutine.hpp b/boost/coroutine/asymmetric_coroutine.hpp
index ea96981..640896f 100644
--- a/boost/coroutine/asymmetric_coroutine.hpp
+++ b/boost/coroutine/asymmetric_coroutine.hpp
@@ -14,6 +14,7 @@
#include <boost/assert.hpp>
#include <boost/config.hpp>
#include <boost/move/move.hpp>
+#include <boost/range.hpp>
#include <boost/throw_exception.hpp>
#include <boost/utility/explicit_operator_bool.hpp>

@@ -2354,19 +2355,12 @@ end( push_coroutine< R > & c)

}

-// forward declaration of Boost.Range traits to break dependency on it
-template<typename C, typename Enabler>
-struct range_mutable_iterator;
-
-template<typename C, typename Enabler>
-struct range_const_iterator;
-
template< typename Arg >
-struct range_mutable_iterator< coroutines::push_coroutine< Arg >, void >
+struct range_mutable_iterator< coroutines::push_coroutine< Arg > >
{ typedef typename coroutines::push_coroutine< Arg >::iterator type; };

template< typename R >
-struct range_mutable_iterator< coroutines::pull_coroutine< R >, void >
+struct range_mutable_iterator< coroutines::pull_coroutine< R > >
{ typedef typename coroutines::pull_coroutine< R >::iterator type; };

}
--
2.24.1

0 comments on commit 51a79e3

Please sign in to comment.