Skip to content

Commit

Permalink
Revert "dev-libs/libgit2: Drop old versions"
Browse files Browse the repository at this point in the history
This reverts commit 5d0f06c.

dev-util/geany-plugins depends on <dev-libs/libgit2-1.4.0.

Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed May 31, 2022
1 parent 96adb37 commit 51c4543
Show file tree
Hide file tree
Showing 5 changed files with 293 additions and 0 deletions.
3 changes: 3 additions & 0 deletions dev-libs/libgit2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,4 @@
DIST libgit2-1.3.0.tar.gz 5599575 BLAKE2B b701c105bb0a5bdcdd5ed1db180662ad4949c540944664d5d8c2f5d78998f15d15bd3669ae3e3d43bfa1b81207c0a94b7e49fc76e57f4cc8ef791ab26e62fc70 SHA512 842a648a67ff23ba9e6bf14b706ba9081164866e14000ebf3858442b7046925f05e1dbf00a7d740dc4bf32280e260730e23a9492e817094aa90736ae335ee76e
DIST libgit2-1.3.1.tar.gz 5602265 BLAKE2B ecf1fb30fbc40b09edcd3862d0831bc7d4d1da1aa8e738c78cf77bda5a0bd5d9c6a60fe7ce9827e058c04ac88d89a7d6c05c54c01bd77d1a8b0b091495bbf871 SHA512 012ffda7e8b9557923758fdbe68869875977d419bfa60b61f90adadc056600e2b1cc2db1c2a003315ea0e193c0145c1f431054f7bd960c5e6e14fa541e46cba3
DIST libgit2-1.4.2.tar.gz 5629585 BLAKE2B 61e269fd08beb9579838a13b661b4270f1e8d2d3d1e67f6b8357e92a5ee4aaccbe637644dc87cc8b04d9c181e37808352077b75fed8753a4b2d8868eaf248b62 SHA512 144bec7f8e66d97b20335d87d1eb68d522f5e59064b0c557505c088d3c486d45704f023d701f51de572efa8e2eb111e3136eb5d23c035e29d16698206b5ec277
DIST libgit2-1.4.3.tar.gz 5631981 BLAKE2B 9308100ede912eae9d1fa4011c67f88f225aa11a49adf845389559fcbc213f31b0f91e4a5b496d282d42ac7f843f03c4ef7236f2d200331c615013d1250f6c31 SHA512 3dfa16c1c705b99fbda55e5e86e67703621d6f8fb62a03cfe998c834d242f33f4200fc0b6bc5d32fe5254c8b8e845259688e4bea9c2dbfc2b7df91841c335d28
72 changes: 72 additions & 0 deletions dev-libs/libgit2/libgit2-1.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1

DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.org"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S=${WORKDIR}/${P/_/-}

LICENSE="GPL-2-with-linking-exception"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86 ~ppc-macos"
IUSE="examples gssapi +ssh test +threads trace"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/libpcre:=
net-libs/http-parser:=
sys-libs/zlib
dev-libs/openssl:0=
gssapi? ( virtual/krb5 )
ssh? ( net-libs/libssh2 )
"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
"

src_prepare() {
cmake_src_prepare
# relying on forked http-parser to support some obscure URI form
sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_CLAR=$(usex test)
-DENABLE_TRACE=$(usex trace ON OFF)
-DUSE_GSSAPI=$(usex gssapi ON OFF)
-DUSE_SSH=$(usex ssh)
-DTHREADSAFE=$(usex threads)
-DUSE_HTTP_PARSER=system
)
cmake_src_configure
}

src_test() {
if [[ ${EUID} -eq 0 ]] ; then
# repo::iterator::fs_preserves_error fails if run as root
# since root can still access dirs with 0000 perms
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
cmake_src_test -R offline
fi
}

src_install() {
cmake_src_install
dodoc docs/*.{md,txt}

if use examples ; then
find examples -name '.gitignore' -delete || die
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}
76 changes: 76 additions & 0 deletions dev-libs/libgit2/libgit2-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1

DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.org/"
SRC_URI="
https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
"
S=${WORKDIR}/${P/_/-}

LICENSE="GPL-2-with-linking-exception"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~ppc-macos"
IUSE="examples gssapi +ssh test +threads trace"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/libpcre:=
net-libs/http-parser:=
sys-libs/zlib
dev-libs/openssl:0=
gssapi? ( virtual/krb5 )
ssh? ( net-libs/libssh2 )
"
DEPEND="
${RDEPEND}
"
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
"

src_prepare() {
cmake_src_prepare
# relying on forked http-parser to support some obscure URI form
sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_CLAR=$(usex test)
-DENABLE_TRACE=$(usex trace ON OFF)
-DUSE_GSSAPI=$(usex gssapi ON OFF)
-DUSE_SSH=$(usex ssh)
-DTHREADSAFE=$(usex threads)
-DUSE_HTTP_PARSER=system
)
cmake_src_configure
}

src_test() {
if [[ ${EUID} -eq 0 ]] ; then
# repo::iterator::fs_preserves_error fails if run as root
# since root can still access dirs with 0000 perms
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
cmake_src_test -R offline
fi
}

src_install() {
cmake_src_install
dodoc docs/*.{md,txt}

if use examples ; then
find examples -name '.gitignore' -delete || die
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}
71 changes: 71 additions & 0 deletions dev-libs/libgit2/libgit2-1.4.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1

DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.org"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S=${WORKDIR}/${P/_/-}

LICENSE="GPL-2-with-linking-exception"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~ppc-macos"
IUSE="examples gssapi +ssh test +threads trace"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/libpcre2:=
net-libs/http-parser:=
sys-libs/zlib
dev-libs/openssl:0=
gssapi? ( virtual/krb5 )
ssh? ( net-libs/libssh2 )
"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
"

src_prepare() {
cmake_src_prepare
# relying on forked http-parser to support some obscure URI form
sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
-DUSE_SSH=$(usex ssh)
-DUSE_GSSAPI=$(usex gssapi ON OFF)
-DUSE_HTTP_PARSER=system
-DREGEX_BACKEND=pcre2
)
cmake_src_configure
}

src_test() {
if [[ ${EUID} -eq 0 ]] ; then
# repo::iterator::fs_preserves_error fails if run as root
# since root can still access dirs with 0000 perms
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
cmake_src_test -R offline
fi
}

src_install() {
cmake_src_install
dodoc docs/*.{md,txt}

if use examples ; then
find examples -name '.gitignore' -delete || die
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}
71 changes: 71 additions & 0 deletions dev-libs/libgit2/libgit2-1.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1

DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.org"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S=${WORKDIR}/${P/_/-}

LICENSE="GPL-2-with-linking-exception"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86 ~ppc-macos"
IUSE="examples gssapi +ssh test +threads trace"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/libpcre:=
net-libs/http-parser:=
sys-libs/zlib
dev-libs/openssl:0=
gssapi? ( virtual/krb5 )
ssh? ( net-libs/libssh2 )
"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
"

src_prepare() {
cmake_src_prepare
# relying on forked http-parser to support some obscure URI form
sed -i -e '/empty_port/s:test:_&:' tests/network/url/parse.c || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
-DUSE_SSH=$(usex ssh)
-DUSE_GSSAPI=$(usex gssapi ON OFF)
-DUSE_HTTP_PARSER=system
-DREGEX_BACKEND=pcre
)
cmake_src_configure
}

src_test() {
if [[ ${EUID} -eq 0 ]] ; then
# repo::iterator::fs_preserves_error fails if run as root
# since root can still access dirs with 0000 perms
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
cmake_src_test -R offline
fi
}

src_install() {
cmake_src_install
dodoc docs/*.{md,txt}

if use examples ; then
find examples -name '.gitignore' -delete || die
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}

0 comments on commit 51c4543

Please sign in to comment.