forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/docker-compose: Version bump to 1.10.0_rc1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
70 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST docker-compose-1.10.0_pre20161220.tar.gz 219218 SHA256 3e5e0a4dbe52979f32170e9572a6574ff0de97969fdc647f013f8ad4b383aa4f SHA512 5c6ad437228916d8ae713a553c73b9aeb10302fd4ea21b01911718f593eacd6b6a9c439a9a239f754daaafda6363a67300f60b5d9cb820679574b3a3b6a2df75 WHIRLPOOL da8b85e9275c716083b1688cbc067da26e6547bc9fe5eb90ced191f1313830fe7ffa25ad67b4f4cff9534425bbc3224ba80d6bc6d5087128b52af8fa4ad09a5f | ||
DIST docker-compose-1.10.0_rc1.tar.gz 164196 SHA256 122a8eae97e0f80ddcf82cc194b274ff46cf92ba9f6ad66b4a2080b62c366ba9 SHA512 3e93cd686f887e5fab1be4d084cbae515142aaa01a511cc8904969288cf63cc9e4959a93d9fd0d7750ec9b17b3d9dba9724c13c088be66f69d053c2ebcaab947 WHIRLPOOL 9d77c4a0c9daa3dc032aba0cdaa763c59eb0b34fb1e523fb710b61129aaf5fb3f2671c58b43b2eae31ccfad246aa4dd9a3d335b2676aa8429e227a6dac5b6645 | ||
DIST docker-compose-1.8.1.tar.gz 151478 SHA256 1c72725a0a5cd41f56021cb51c6cba86932fb5b4155378ce883500d2644efc84 SHA512 8b33bf5b1fa3eeb5c5724e7ada8c61cf054a5cc1af68c9c9ab40955958f0f6a537f5bad8d54367dddc5ae66930d0555c83da47a48fc43f623d92fd60ad01cb62 WHIRLPOOL 5dca7ff3303833a45b0e7f462a375c58f68f4a19659e66b93bfc564701df8dfba70311151eb674a84c5a3b81703ddcc8809c6c7b89574c738ac9db96a32c93e6 | ||
DIST docker-compose-1.9.0.tar.gz 156392 SHA256 98fb664c79c06a0777af2540b83eaa63c6a05ae7eb9e7417193899df2f96e27f SHA512 9d145807406ce4de3e91245bba4f774d80e0a39a81115fc111624e1a56b7e8a7505d49700df68b062efc65f8de661c8dca08067615a7504b3d7adf6c15d156d0 WHIRLPOOL ca64f1e8e9c830c3cab01193be0d809cbb80fbea2a451dd7f51ff688d76a376a047bdc781471b292de06a275f933ebf755c4b24cc60fe19fe77fb4729101b9e5 |
69 changes: 69 additions & 0 deletions
69
app-emulation/docker-compose/docker-compose-1.10.0_rc1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,69 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
PYTHON_COMPAT=( python{2_7,3_4} ) | ||
|
||
inherit bash-completion-r1 distutils-r1 vcs-snapshot | ||
|
||
MY_PV=${PV//_/} | ||
|
||
DESCRIPTION="Multi-container orchestration for Docker" | ||
HOMEPAGE="https://www.docker.com/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="test" | ||
|
||
CDEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
>=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}] | ||
<dev-python/cached-property-2[${PYTHON_USEDEP}] | ||
>=dev-python/colorama-0.3.7[${PYTHON_USEDEP}] | ||
<dev-python/colorama-0.4[${PYTHON_USEDEP}] | ||
>=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}] | ||
<dev-python/dockerpty-0.5[${PYTHON_USEDEP}] | ||
>=dev-python/docker-py-2.0.0[${PYTHON_USEDEP}] | ||
<dev-python/docker-py-3.0[${PYTHON_USEDEP}] | ||
>=dev-python/docopt-0.6.1[${PYTHON_USEDEP}] | ||
<dev-python/docopt-0.7[${PYTHON_USEDEP}] | ||
>=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}] | ||
<dev-python/jsonschema-3[${PYTHON_USEDEP}] | ||
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] | ||
<dev-python/pyyaml-4[${PYTHON_USEDEP}] | ||
!~dev-python/requests-2.11.0[${PYTHON_USEDEP}] | ||
<dev-python/requests-2.12[${PYTHON_USEDEP}] | ||
>=dev-python/requests-2.6.1[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.3.0[${PYTHON_USEDEP}] | ||
<dev-python/six-2[${PYTHON_USEDEP}] | ||
>=dev-python/texttable-0.8.1[${PYTHON_USEDEP}] | ||
<dev-python/texttable-0.9[${PYTHON_USEDEP}] | ||
>=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}] | ||
<dev-python/websocket-client-1.0[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' ) | ||
$(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' ) | ||
" | ||
DEPEND=" | ||
${CDEPEND} | ||
test? ( | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) | ||
) | ||
" | ||
RDEPEND="${CDEPEND}" | ||
|
||
python_test() { | ||
${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}" | ||
} | ||
|
||
python_install_all() { | ||
newbashcomp contrib/completion/bash/docker-compose ${PN} | ||
|
||
insinto /usr/share/zsh/site-functions | ||
doins contrib/completion/zsh/* | ||
|
||
distutils-r1_python_install_all | ||
} |