forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
142 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST evolution-3.18.5.2.tar.xz 12076700 SHA256 3331bee17fc660df9e83f0e070cc2494a9335108e400c889f3a2edf0c293a643 SHA512 1c6200874a5c7e72a6a8976aa7bf5558e5f0084f7a19227866e5d84007115b92954d1e36e83c9cb092b90c722a21222a5ed84cd94596bc853d2639bf374eff9e WHIRLPOOL 8e9d9799aa1ca6d665ca3da42827da3fb15adfa1c28615af82c09848b7dad045523fda9567490d8b3dd007923086af5876af8a270f1bdaa69b95593bb7360bbb | ||
DIST evolution-3.20.4.tar.xz 12133788 SHA256 2c29733cb49042dca093bb4b3c4a3eb7fdc5d7437d1bd048fa39822f4d5436bc SHA512 c3f256c41022b7098ca63c542af01bf1a1ecb9c6fd20991518ee383df3e9e0f62f4a527512b39d2ee994ca4fac84bfa1df110e3b46732a124d1d985659159912 WHIRLPOOL 617d88ff2227aeb64a7357594bfa02d7addc2a8e009901fe111b918db0a5ccb8ea8be9b2b75c415ac60ab29c8624f971fc327da7c896241564a36c26897f7d13 | ||
DIST evolution-3.20.5.tar.xz 12133872 SHA256 2e13551ce0996963506f0bdde5e01c3b8aa0622849a272ff12877cd595baeb6e SHA512 4b974ac5d8f3918a8012192634e8d131b1f6af0ed40a32181eb9500bc43b8bf4cf29a6fc7e49620638ada8f2456117e263e6162f21c0e1deef81861789a97906 WHIRLPOOL 1ed38bd2b9de97ad50bb832e03b76bf94131e65f0cf05c555d9e62d0e908467382b7e879d8eeb9513a6a09396da77eb2b2ac3a0dd3b97c6f2cde373dd65222ae |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,141 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit flag-o-matic readme.gentoo-r1 gnome2 | ||
|
||
DESCRIPTION="Integrated mail, addressbook and calendaring functionality" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution" | ||
|
||
# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+". | ||
LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP" | ||
SLOT="2.0" | ||
|
||
IUSE="+bogofilter crypt highlight ldap map spamassassin spell ssl +weather" | ||
|
||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd" | ||
|
||
# We need a graphical pinentry frontend to be able to ask for the GPG | ||
# password from inside evolution, bug 160302 | ||
PINENTRY_DEPEND="|| ( app-crypt/pinentry[gnome-keyring] app-crypt/pinentry[gtk] app-crypt/pinentry[qt4] app-crypt/pinentry[qt5] )" | ||
|
||
# glade-3 support is for maintainers only per configure.ac | ||
# pst is not mature enough and changes API/ABI frequently | ||
# dconf explicitely needed for backup plugin | ||
# gnome-desktop support is optional with --enable-gnome-desktop | ||
# gnome-autoar (currently disabled because no release has been made) | ||
COMMON_DEPEND=" | ||
>=app-crypt/gcr-3.4:= | ||
>=app-text/enchant-1.1.7 | ||
>=dev-libs/glib-2.40:2[dbus] | ||
>=dev-libs/libxml2-2.7.3:2 | ||
>=gnome-base/gnome-desktop-2.91.3:3= | ||
>=gnome-base/gsettings-desktop-schemas-2.91.92 | ||
>=gnome-extra/evolution-data-server-3.20.3:=[gtk,weather?] | ||
>=media-libs/libcanberra-0.25[gtk3] | ||
>=net-libs/libsoup-2.42:2.4 | ||
>=net-libs/webkit-gtk-2.2:3 | ||
>=x11-libs/cairo-1.9.15:=[glib] | ||
>=x11-libs/gdk-pixbuf-2.24:2 | ||
>=x11-libs/gtk+-3.10:3 | ||
>=x11-libs/libnotify-0.7:= | ||
>=x11-misc/shared-mime-info-0.22 | ||
>=app-text/iso-codes-0.49 | ||
dev-libs/atk | ||
gnome-base/dconf | ||
dev-libs/libical:= | ||
x11-libs/libSM | ||
x11-libs/libICE | ||
crypt? ( | ||
>=app-crypt/gnupg-1.4 | ||
${PINENTRY_DEPEND} | ||
x11-libs/libcryptui ) | ||
map? ( | ||
>=media-libs/libchamplain-0.12:0.12[gtk] | ||
>=media-libs/clutter-1.0.0:1.0 | ||
>=media-libs/clutter-gtk-0.90:1.0 | ||
>=sci-geosciences/geocode-glib-3.10.0 | ||
x11-libs/mx:1.0 ) | ||
spell? ( app-text/gtkspell:3 ) | ||
ldap? ( >=net-nds/openldap-2:= ) | ||
ssl? ( | ||
>=dev-libs/nspr-4.6.1:= | ||
>=dev-libs/nss-3.11:= ) | ||
weather? ( >=dev-libs/libgweather-3.10:2= ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
app-text/docbook-xml-dtd:4.1.2 | ||
dev-util/gtk-doc-am | ||
>=dev-util/intltool-0.40.0 | ||
dev-util/itstool | ||
virtual/pkgconfig | ||
" | ||
# eautoreconf needs: | ||
# app-text/yelp-tools | ||
# >=gnome-base/gnome-common-2.12 | ||
RDEPEND="${COMMON_DEPEND} | ||
bogofilter? ( mail-filter/bogofilter ) | ||
highlight? ( app-text/highlight ) | ||
spamassassin? ( mail-filter/spamassassin ) | ||
!gnome-extra/evolution-exchange | ||
" | ||
|
||
DISABLE_AUTOFORMATTING="yes" | ||
DOC_CONTENTS="To change the default browser if you are not using GNOME, edit | ||
~/.local/share/applications/mimeapps.list so it includes the | ||
following content: | ||
[Default Applications] | ||
x-scheme-handler/http=firefox.desktop | ||
x-scheme-handler/https=firefox.desktop | ||
(replace firefox.desktop with the name of the appropriate .desktop | ||
file from /usr/share/applications if you use a different browser)." | ||
|
||
src_configure() { | ||
# Use NSS/NSPR only if 'ssl' is enabled. | ||
gnome2_src_configure \ | ||
--without-glade-catalog \ | ||
--disable-autoar \ | ||
--disable-code-coverage \ | ||
--disable-installed-tests \ | ||
--disable-pst-import \ | ||
--enable-canberra \ | ||
$(use_enable crypt libcryptui) \ | ||
$(use_enable highlight text-highlight) \ | ||
$(use_enable map contact-maps) \ | ||
$(use_enable spell gtkspell) \ | ||
$(use_enable ssl nss) \ | ||
$(use_enable ssl smime) \ | ||
$(use_with bogofilter) \ | ||
$(use_with ldap openldap) \ | ||
$(use_with spamassassin) \ | ||
$(usex ssl --enable-nss=yes "--without-nspr-libs | ||
--without-nspr-includes | ||
--without-nss-libs | ||
--without-nss-includes") \ | ||
$(use_enable weather) | ||
} | ||
|
||
src_install() { | ||
gnome2_src_install | ||
|
||
# Problems with prelink: | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=731680 | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=732148 | ||
# https://bugzilla.redhat.com/show_bug.cgi?id=1114538 | ||
echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN} | ||
doenvd "${T}"/99${PN} | ||
|
||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
readme.gentoo_print_elog | ||
} |