Skip to content

Commit

Permalink
app-admin/calamares: Version bump 3.1.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
johu committed Jul 14, 2017
1 parent 33639dd commit 51fe378
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/calamares/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST calamares-3.1.0.tar.gz 2215820 SHA256 7b4c74fc350624a17eb8b8187ade490711bfdc608d2be07322c8a3fc0a449276 SHA512 17c15aafbc811f42246f8300f64ffe7d44b43ac24f5b6ced15c83715c5fff9644060964de82cc3e7021c710e6eebbc124785d9d7b85613c5f190ec0f8d5d5389 WHIRLPOOL 6c8e46aff3700d26e876dd6f02bf28e55ea59cebe46438e64a8d04e921df9e35d0c1c3077479767b67284805103c16cda7ef5e1a2ec50d9e735093cb9e04b886
DIST calamares-3.1.1.tar.gz 4895018 SHA256 1644f28f0ee166411dafc849d1d1c9b5bf4f7346ebaf430ee3cf1a7d330a85aa SHA512 4c45f949075a46c6b1de14b322f7d124b4346b11c112b410a216359530d055d21ae8357609d2279614da5490f72f38aebf7844942a2e8a8c2a244cf31350720c WHIRLPOOL 8be229cdcbea88c396a98f42232b0dcb30df81895f927ef45c815be618f5d094f85e2b0fdda7cdf93d6a953d785a7c45bd3f0eae70d2e8775a0bccb8d0a19b3e
80 changes: 80 additions & 0 deletions app-admin/calamares/calamares-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{3_4,3_5} )
inherit kde5 python-r1

DESCRIPTION="Distribution-independent installer framework"
HOMEPAGE="http://calamares.io"
if [[ ${KDE_BUILD_TYPE} == live ]] ; then
EGIT_REPO_URI="git://github.com/${PN}/${PN}"
else
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="GPL-3"
IUSE="+networkmanager pythonqt +upower"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="${PYTHON_DEPS}
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwebengine 'widgets')
$(add_qt_dep qtwidgets)
>=dev-cpp/yaml-cpp-0.5.1
>=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
sys-apps/dbus
sys-apps/dmidecode
sys-auth/polkit-qt[qt5]
>=sys-libs/kpmcore-3.0.3:5=
pythonqt? ( >=dev-python/PythonQt-3.1:=[${PYTHON_USEDEP}] )
"

RDEPEND="${DEPEND}
app-admin/sudo
dev-libs/libatasmart
net-misc/rsync
>=sys-block/parted-3.0
|| ( sys-boot/grub:2 sys-boot/systemd-boot )
sys-boot/os-prober
sys-fs/squashfs-tools
virtual/udev
networkmanager? ( net-misc/networkmanager )
upower? ( sys-power/upower )
"

src_prepare() {
python_setup
export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
PYTHON_CFLAGS="$(python_get_CFLAGS)"\
PYTHON_LIBS="$(python_get_LIBS)"

eapply_user
}

src_configure() {
local mycmakeargs=(
-DWEBVIEW_FORCE_WEBKIT=OFF
-DWITH_PYTHONQT=$(usex pythonqt)
)

kde5_src_configure
sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
}

src_install() {
kde5_src_install
dobin "${FILESDIR}"/calamares-pkexec
}

0 comments on commit 51fe378

Please sign in to comment.