Skip to content

Commit

Permalink
dev-util/pkgconf: bump to version 1.0.1
Browse files Browse the repository at this point in the history
- fixes test failures (bug #562220)
- migrate to EAPI6 and git-r3

Gentoo-Bug: https://bugs.gentoo.org/562220
Closes: gentoo#2410

Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
doughdemon authored and SoapGentoo committed Oct 22, 2016
1 parent 31ef004 commit 526fb15
Show file tree
Hide file tree
Showing 4 changed files with 81 additions and 13 deletions.
1 change: 1 addition & 0 deletions dev-util/pkgconf/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pkgconf-0.9.11.tar.bz2 86489 SHA256 3bdae1b2672133943dc0dda694ed57074f8b03c3fea10efb215d76d3cabe2c3b SHA512 21313ef29afcaa7c49a8cb512ecd3a821693945c22fb1a670ada74f41bca320e1b9ffb64e79adc2c33cb86822b74ddc850fadb16ddcde7eb805b81a50096992f WHIRLPOOL 7442a456af7e959c86f318ee74ec89883cc4e2ad16c9708f98d8ab30cdcf71ea7ef13f7e0f9bf945717b1dea8a317ffc5322878f88a5084c2dcbdc2aeafaf4d2
DIST pkgconf-0.9.12.tar.bz2 87109 SHA256 7ec8b516e655e247f4ba976837cee808134785819ab8f538f652fe919cc6c09f SHA512 efe13db7a46992eb44ead493fc12b3fc6a5567e0206f701b6c48d9b5eb0bc90fcc9ae7a7e08ae641bb10df869287e5b68291701d4013d6cf27bd2b1518c29192 WHIRLPOOL 9fa7336e111f29648f5c37310bdeb2266bead1b86ff18183cfb57c06054916d235da20a5723bd364497d20a1f4db399eaf77f38c0bfc1519f2b7b825ab4666d0
DIST pkgconf-1.0.1.tar.gz 362653 SHA256 45ce2f6ab032451345185b800badd77c054040879bd2e56225dafc7fbe583cf1 SHA512 b379ed366327eb4de3a7ed732be58a3757fdcd231637f0fbc2f9b762fda08173244d05fd853d683cfa6bdad90f1d8ee663b3eae9aee024456ef46e8a021e7122 WHIRLPOOL ba9a26874d14b6dfd62858da1b50397bc0aa9637bfe0824d4911f4df1e430e60a9f589242f8dc60a792b16f5201f9e0944d637e0d3a4749a211b976459152d69
1 change: 0 additions & 1 deletion dev-util/pkgconf/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,6 @@
<maintainer type="person">
<email>[email protected]</email>
<name>Elizabeth Myers</name>
<description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
Expand Down
62 changes: 62 additions & 0 deletions dev-util/pkgconf/pkgconf-1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
inherit autotools git-r3
else
SRC_URI="https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi

inherit multilib-minimal

DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"

LICENSE="BSD-1"
SLOT="0"
IUSE="+pkg-config strict"

DEPEND=""
RDEPEND="${DEPEND}
pkg-config? (
!dev-util/pkgconfig
!dev-util/pkg-config-lite
!dev-util/pkgconfig-openbsd[pkg-config]
)"

MULTILIB_CHOST_TOOLS=(
/usr/bin/pkgconf
)

src_prepare() {
default

[[ ${PV} == "9999" ]] && eautoreconf
if use pkg-config; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config
)
fi
}

multilib_src_configure() {
ECONF_SOURCE=${S} \
econf $(use_enable strict)
}

multilib_src_install() {
default

if use pkg-config; then
dosym pkgconf /usr/bin/pkg-config
else
rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
fi
}
30 changes: 18 additions & 12 deletions dev-util/pkgconf/pkgconf-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,18 +1,21 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
inherit autotools git-2 multilib-minimal
EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
inherit autotools git-r3
else
inherit autotools multilib-minimal vcs-snapshot
SRC_URI="https://github.com/pkgconf/pkgconf/tarball/${P} -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
SRC_URI="https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi

inherit multilib-minimal

DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"

Expand All @@ -33,8 +36,9 @@ MULTILIB_CHOST_TOOLS=(
)

src_prepare() {
[[ -e configure ]] || eautoreconf
default

[[ ${PV} == "9999" ]] && eautoreconf
if use pkg-config; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config
Expand All @@ -49,8 +53,10 @@ multilib_src_configure() {

multilib_src_install() {
default
use pkg-config \
&& dosym pkgconf /usr/bin/pkg-config \
|| rm "${ED}"/usr/share/aclocal/pkg.m4 \
|| die

if use pkg-config; then
dosym pkgconf /usr/bin/pkg-config
else
rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
fi
}

0 comments on commit 526fb15

Please sign in to comment.