Skip to content

Commit

Permalink
dev-python/tlslite: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Mar 1, 2016
1 parent fefc108 commit 52713b2
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/tlslite/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tlslite-0.4.3.tar.gz 562090 SHA256 6a67d8a0bec66183719c19c91f383bc1555545055aae4498af2e91fe9d79f813 SHA512 d1f451ebc2f7bd4d5436f1ca8ecfdbaa403f3dbbae9f9ac3900131e5d168e3267e22fcf23d85f87457f06468997cb01a51683d028a67fde58820b15f97689a0c WHIRLPOOL 555f2659f0bb5080519edd5f4325953e13109367ef21e1595816ab4f3956233bb541940f65f2cfa95c041b7f2cc080b8c4ee10719be79edfa11076a2c834fff6
DIST tlslite-0.4.8.tar.gz 563048 SHA256 d9b447048a322c70df800f540ab577c93ecf20de52c0a02c8621176e4733bdbb SHA512 bdb42d005b7444667badc6febd38f5b74878c09218b418844c255920f0e6272f55f62b4ea21953953935f73e02657fce9874b44f73499267cf713ddbcd3d6a44 WHIRLPOOL 0804742e528e6ce9d67afed78fe42c4f0a42cdfc221bf36d37e4f4f5fce828323da10f7bec3e68b2fdcf4d13d2fa100364e83e61fbcfc5cf86d3aeb1f51d75df
DIST tlslite-0.4.9.tar.gz 105402 SHA256 9b9a487694c239efea8cec4454a99a56ee1ae1a5f3af0858ccf8029e2ac2d42d SHA512 5473139b5730ef946efa139fbb9adb3333dc67f33f03305f4a6d3b6eaaefce950ba93bc1053362fc31b9d68ff9f6deceb9449987e29ff44035b818d7310edbea WHIRLPOOL b8fa4794d5670585c9f55673f04bfb2d2fac5457013284b810d27e4c31f0f9a9a349f1664eec338bc70adf9586910bccf3c33ef6d0b926418e1801ef23e6cd7b
45 changes: 45 additions & 0 deletions dev-python/tlslite/tlslite-0.4.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit distutils-r1 eutils

DESCRIPTION="TLS Lite is a free python library that implements SSL 3.0 and TLS 1.0/1.1"
HOMEPAGE="http://trevp.net/tlslite/ https://pypi.python.org/pypi/tlslite https://github.com/trevp/tlslite"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
#Refrain for now setting IUSE test and deps of test given test restricted.
IUSE="doc"

DEPEND="
>=dev-libs/cryptlib-3.3.3[python,${PYTHON_USEDEP}]
|| (
dev-python/m2crypto[${PYTHON_USEDEP}]
dev-python/pycrypto[${PYTHON_USEDEP}]
)"
RDEPEND="${DEPEND}"

RESTRICT="test"

# Tests still hang
python_test() {
cd tests || die
"${PYTHON}" "${S}"/tests/tlstest.py client localhost:4443 . || die
"${PYTHON}" "${S}"/tests/tlstest.py server localhost:4442 . || die
}

python_install_all(){
use doc && HTML_DOCS=( docs/. )
distutils-r1_python_install_all
}

pkg_postinst() {
optfeature "GMP support" dev-python/gmpy
}

0 comments on commit 52713b2

Please sign in to comment.