forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-firewall/fwbuilder: Fix src_configure, qtbindir
Closes: https://bugs.gentoo.org/634900 Package-Manager: Portage-2.3.16, Repoman-2.3.6
- Loading branch information
Showing
3 changed files
with
62 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
DIST fwbuilder-5.0.1.3592.tar.gz 6733502 SHA256 22120de712844b5d89a3f2924964c16cc86f96f2156ace7c3f551bd0d713c94b SHA512 aac34c97963819f0dca4a6bfa63987df45cdd6905164b49ae6f6a423f044fc52aeb09b15b2fc294e1aa3da97d3d31e75bdf9a690e383f579a2fb40ef656f4885 WHIRLPOOL 436e5f8c802e6b25c588f3296ac0cbce89aa818c53871296615980aee6b71b84a64a44808f7d2390ee73b11e83b2acc88d94c7b236df5caf83788d735276211f | ||
DIST fwbuilder-5.3.6.tar.gz 7325429 SHA256 672c2870c3a2ce1eb504a97d17ea9a8eb6dd61ec314cf79b9488b48a356cdfa6 SHA512 70f6888d09c89a624ea35f119c1e00d5a7e57d993d8658fd164e35bce073503bf66f3c9e05ffa1b49ab9371cf219825d22a41c31604c63de5290dd64845e06af WHIRLPOOL a559061861447bff1657857c5a9f551e4eb0315fdea99199025d9cdaae3b1163cb69f97c36517bbe39998b0a9a97026d9737485b5a01144cd8296c502830e9b6 | ||
DIST fwbuilder-5.3.7.tar.gz 7332419 SHA256 aba1ed8f690e9e4659c0e981120ea68da7ee327d6cf81260d51329351addf91e SHA512 d6504ddab17e80cb332f005b6bbb16c15a7b4735361733f0e0437cb94059a5c9039e563be6e0e8d328954db2416b2c0bdbb8afa36cd946f61e7c7edaee47453b WHIRLPOOL 0191f0f812b494bae9d4c00cc4a26315f32c378e5395270f56cd4e3d7d0c189d67ec154c28d9aaeecee0b0304c1bb5cf61db2a738b32b189ee53f306849fdfa9 | ||
DIST fwbuilder-5.3.7.tar.gz 7332419 BLAKE2B 130c5ab413263b61b7a78dfabe8d0db861ddfd8bfcee62eb11b9ac8c229c9a9e2b6d8a22e296a12e0e9d0fd9b503882eb06e62f7dc0f62487d760191fce8b553 SHA512 d6504ddab17e80cb332f005b6bbb16c15a7b4735361733f0e0437cb94059a5c9039e563be6e0e8d328954db2416b2c0bdbb8afa36cd946f61e7c7edaee47453b |
57 changes: 57 additions & 0 deletions
57
net-firewall/fwbuilder/files/fwbuilder-5.3.7-qtbindir.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
--- a/configure.in 2017-12-04 21:30:44.000000000 +0100 | ||
+++ b/configure.in 2017-12-04 21:56:00.277286322 +0100 | ||
@@ -45,44 +45,18 @@ | ||
#define GENERATION "$GENERATION" | ||
EOF | ||
|
||
-dnl try to find QT | ||
-dnl | ||
-AC_ARG_WITH(qtdir,[ --with-qtdir=DIR Specify directory path for QT ]) | ||
- | ||
-if test -n "$with_qtdir"; then | ||
- AC_MSG_CHECKING(Using QT in ) | ||
- QTDIR="$with_qtdir"; | ||
- export QTDIR | ||
- AC_MSG_RESULT($QTDIR) | ||
-fi | ||
- | ||
-# TODO: do we need to add $QTDIR/bin to PATH to find qmake? | ||
-EXTENDED_PATH="/usr/local/bin:$QTDIR/bin/:$PATH" | ||
+EXTENDED_PATH="/usr/local/bin:$PATH" | ||
+PKG_PROG_PKG_CONFIG | ||
|
||
-AC_ARG_WITH(qmake, [ --with-qmake=qmake Specify the qmake to be used (debian qmake-qt4) ]) | ||
-if test -n "$with_qmake"; then | ||
- AC_PATH_PROG(QMAKE, $with_qmake, ,[$EXTENDED_PATH]) | ||
- if test -z "$QMAKE"; then | ||
- AC_MSG_ERROR("Could not find qmake") | ||
- fi | ||
-else | ||
- AC_PATH_PROG(QMAKE, qmake, ,[$EXTENDED_PATH]) | ||
- if test -z "$QMAKE"; then | ||
- AC_PATH_PROG(QMAKE, qmake-qt4, ,[$EXTENDED_PATH]) | ||
- if test -z "$QMAKE"; then | ||
- AC_MSG_ERROR("Could not find qmake") | ||
- fi | ||
- fi | ||
-fi | ||
- | ||
-AC_MSG_CHECKING(checking version of QT this qmake is part of) | ||
-qmake_version=`$QMAKE -v 2>&1 | awk '/Using Qt version/ { print $4;}'` | ||
-case $qmake_version in | ||
- 4.*) AC_MSG_RESULT( $qmake_version ) ;; | ||
- 5.*) AC_MSG_RESULT( $qmake_version ) ;; | ||
- *) AC_MSG_ERROR( "$qmake_version -- v4.x or v5.x is required") ;; | ||
-esac | ||
+dnl try to find Qt5 | ||
+dnl | ||
|
||
+PKG_CHECK_MODULES([QT5], [Qt5Core >= 5.1.0], [ | ||
+ QT_PATH="$( eval $PKG_CONFIG --variable=host_bins Qt5Core )" | ||
+ AC_PATH_PROGS([QMAKE], [qmake-qt5 qmake], [qmake], [$QT_PATH]) | ||
+], [ | ||
+ AC_MSG_ERROR([Qt5 not found]) | ||
+]) | ||
|
||
|
||
AC_ARG_WITH(templatedir, [ --with-templatedir=DIR Specify directory path for fwbuilder template files ]) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters