forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
The dev-util/hip upstream has separated its test cases into a full git repository with an independent build system. To run the test cases, we have to call cmake twice in every src_* phase. I come up with a wrapper to hack CMAKE_USE_DIR and BUILD_DIR values. Ignore vulkan tests before someone could figure out how to properly run them. Reference: ROCm/HIP#3292 Closes: gentoo#33906 Signed-off-by: Benda Xu <[email protected]>
- Loading branch information
Showing
3 changed files
with
82 additions
and
9 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
15 changes: 15 additions & 0 deletions
15
dev-util/hip/files/hip-test-5.7.0-rocm_agent_enumerator-location.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
In Gentoo rocm_agent_enumerator is installed by rocminfo and is in PATH. | ||
|
||
--- catch/CMakeLists.txt~ 2023-11-18 13:56:08.000000000 +0800 | ||
+++ catch/CMakeLists.txt 2023-11-18 13:59:28.136170638 +0800 | ||
@@ -182,9 +182,8 @@ | ||
# rocm_agent_enumerator | ||
if(NOT DEFINED OFFLOAD_ARCH_STR | ||
AND NOT DEFINED ENV{HCC_AMDGPU_TARGET} | ||
- AND EXISTS "${ROCM_PATH}/bin/rocm_agent_enumerator" | ||
AND HIP_PLATFORM STREQUAL "amd" AND UNIX) | ||
- execute_process(COMMAND ${ROCM_PATH}/bin/rocm_agent_enumerator | ||
+ execute_process(COMMAND rocm_agent_enumerator | ||
OUTPUT_VARIABLE HIP_GPU_ARCH | ||
RESULT_VARIABLE ROCM_AGENT_ENUM_RESULT) | ||
# Trim out gfx000 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters