Skip to content

Commit

Permalink
dev-embedded/u-boot-tools: Version bump (v2018.11)
Browse files Browse the repository at this point in the history
Signed-off-by: Mikle Kolyada <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
Zlogene committed Dec 9, 2018
1 parent f57ea76 commit 52c5506
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/u-boot-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST u-boot-2016.03.tar.bz2 11076762 BLAKE2B c36922c8400c8cb11b02ec3f3dfa2a06fabaac143149c7b46c73e0b4c4b09aeecc792736bcc66d5cecbdd51d2ae0454f65d677b24ad698dd9e3d28374c048d1d SHA512 d3a8d5f334a1a1a33756d9ac33d14eca689cafe1ada478e61b51dcbff1781266d4f0ea121e25d0232b292475721c04be63e5a153715b91a14dfc82656a54de6f
DIST u-boot-2017.09.tar.bz2 11434323 BLAKE2B 9dbadeccb5c4432e997a5da76091aec714e2fad6922a80173e96b1ff930e69df510f6e090b073c8b2c3aeb4872f5e9b40ec879398e0c839df09f5edd1e52e951 SHA512 dff6e793f135e7d6cb9d85d6ef8e4aa7ed5c1e20eece4f434e8c0a6039eb75c3f2cb7bc550121b1f5a5709e943c7cc5d6d8590e05a47a6b0d0d8f05185fe7ec6
DIST u-boot-2018.05.tar.bz2 12469276 BLAKE2B b09189d9bf8554c21630d42024d64894270c02e3efa8046bc2bef0efd68b9e0a02c3290228ffb71a4bab524d46111e32adb492c3ce9a3ef1be32287a3bbdb36a SHA512 218f71282c9d027b0faf210ce2d4d713779e0c61ea4a23f03d5dec0ca8836a3c26b46c5e258d583834f5b5a2f4663f98729ca4b0101a60f85457eb892f8370d2
DIST u-boot-2018.11.tar.bz2 13045125 BLAKE2B d2522e1eb2fb899f1217261b6c311be35ae2fb01d187714311184e6f913d1d5b3ad953b5fa02c5c7b0e1e5981be101ce82ea4cf09a457d32d778ffa5cadc0786 SHA512 1ea0bbb5f5e6d4c60b3a6bd345d1fa6e9da025daf36f47e8392bab34cb432c2e3633d903efb260f71fff87dffd6f2bf09ac900e96b3d4247073958d83b89ceff
43 changes: 43 additions & 0 deletions dev-embedded/u-boot-tools/u-boot-tools-2018.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

MY_P="u-boot-${PV/_/-}"
DESCRIPTION="utilities for working with Das U-Boot"
HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE=""

S=${WORKDIR}/${MY_P}

src_compile() {
# Unset a few KBUILD variables. Bug #540476
unset KBUILD_OUTPUT KBUILD_SRC
emake defconfig
emake \
HOSTSTRIP=: \
STRIP=: \
HOSTCC="$(tc-getCC)" \
HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
HOSTLDFLAGS="${LDFLAGS}" \
CONFIG_ENV_OVERWRITE=y \
tools-all
}

src_install() {
cd tools || die
dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
dobin easylogo/easylogo
dobin env/fw_printenv
dosym fw_printenv /usr/bin/fw_setenv
insinto /etc
doins env/fw_env.config
doman "${S}"/doc/mkimage.1
}

0 comments on commit 52c5506

Please sign in to comment.