Skip to content

Commit

Permalink
gui-apps/wf-recorder: add 0.4.1
Browse files Browse the repository at this point in the history
Corresponding release:
  - https://github.com/ammen99/wf-recorder/releases/tag/v0.4.1

These changes also add the pulseaudio USE flag.

Closes: https://bugs.gentoo.org/871684
Signed-off-by: Aliaksei Urbanski <[email protected]>
Co-authored-by: Arthur Zamarin <[email protected]>
Signed-off-by: Arthur Zamarin <[email protected]>
Closes: gentoo#35161
Signed-off-by: Arthur Zamarin <[email protected]>
  • Loading branch information
Jamim and arthurzam committed Feb 7, 2024
1 parent ac07c51 commit 52df57a
Show file tree
Hide file tree
Showing 4 changed files with 57 additions and 3 deletions.
1 change: 1 addition & 0 deletions gui-apps/wf-recorder/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST wf-recorder-0.3.0.tar.xz 19888 BLAKE2B 52b7cbe8ad77d3756f91cad0c0642548b439f3465be8152d9cc1175f55d608df8bbd9f21e82b18099fba59d39389012e023e7dc39a0ae061eed13aece99c058a SHA512 6c8a069c923a342441ab5ebce2cf8ec727b75f474c2843d0fa49b69b3e5ef4498bc0548573409203e704a84a72ebec5523f89459a144679bf1d9d5bf6e514b60
DIST wf-recorder-0.4.1.tar.xz 26184 BLAKE2B 87110d3fb8629b5cdfc2c4b50da56d19630b97ffb7e46a555099c8fca263bd1bd87fb03a497fbb5e5ac0022b31bb5c93dc4ea29785de33dd7f2adc8db74f7db2 SHA512 c97b3a0570aa5496d93b88549db6cd682e80c1497bbd6e999ab6b35f2f13adc7af167c22517fa35eab5d3021439001d0e7cfe2ee75a2ba99b9aa6953beb56aa0
3 changes: 3 additions & 0 deletions gui-apps/wf-recorder/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,7 @@
<upstream>
<remote-id type="github">ammen99/wf-recorder</remote-id>
</upstream>
<use>
<flag name="pulseaudio">Enable support for audio capture via PulseAudio</flag>
</use>
</pkgmetadata>
41 changes: 41 additions & 0 deletions gui-apps/wf-recorder/wf-recorder-0.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson

DESCRIPTION="Screen recorder for wlroots-based compositors"
HOMEPAGE="https://github.com/ammen99/wf-recorder"

if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ammen99/wf-recorder.git"
else
SRC_URI="https://github.com/ammen99/wf-recorder/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="pulseaudio"

DEPEND="
dev-libs/wayland
media-libs/mesa[wayland]
media-video/ffmpeg[pulseaudio?,x264]
pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}"
BDEPEND="
dev-libs/wayland-protocols
dev-util/wayland-scanner
virtual/pkgconfig
"

src_configure() {
local emesonargs=(
$(meson_feature pulseaudio pulse)
)
meson_src_configure
}
15 changes: 12 additions & 3 deletions gui-apps/wf-recorder/wf-recorder-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 2020-2023 Gentoo Authors
# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -18,15 +18,24 @@ fi

LICENSE="MIT"
SLOT="0"
IUSE="pulseaudio"

DEPEND="
dev-libs/wayland
media-libs/libpulse
media-video/ffmpeg[pulseaudio,x264]
media-libs/mesa[wayland]
media-video/ffmpeg[pulseaudio?,x264]
pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}"
BDEPEND="
dev-libs/wayland-protocols
dev-util/wayland-scanner
virtual/pkgconfig
"

src_configure() {
local emesonargs=(
$(meson_feature pulseaudio pulse)
)
meson_src_configure
}

0 comments on commit 52df57a

Please sign in to comment.