Skip to content

Commit

Permalink
actually apply Debian patches (bug #561928)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
Michael Sterrett committed Oct 1, 2015
1 parent 324f31a commit 5304a68
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-arcade/netris/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST netris-0.52.tar.gz 33135 SHA256 8bc770ebb2c3ead1611ca7a1a2f3d833e169536c78d53b3fcf49381164ee9706 SHA512 842ad8602394dee929c3c4ba222f9f5ffe628e52348c3faf7c9098bbd5b0b0279fffc7927320f8ee8a5102537c995a8ed605d851f1cd32e4bd8976a7889c84e1 WHIRLPOOL 7bf0356b85107ec871c15afa9e680596e890e22cfb6ba9e72b4487af84c01b5aa4519a0d218c8736f80edaa8ba0c488d49aca07dd67c75dad91054de3a7ea7aa
DIST netris_0.52-7.diff.gz 11586 SHA256 6b4d157768d075d9fedb9318f2583add253af994bab8ed6fe25b65b5086c8cc5 SHA512 2d2fe28dbf886107fa27f631e30534aab8afe027b5a41da3761ff39a16d65d7cf6ff5bf409708d55740638df75e334b5fb1ae4c5304616731fb6498d2cc00ca9 WHIRLPOOL ff1ff01f25b12f809f72682e48f539dd55df8e370151effe1222898b12239abf972e97ff1e8cc768beedf3c085b96e6c3540a309f08205245811ae1b52b51ac2
DIST netris_0.52-9.diff.gz 14482 SHA256 7364a74dabf43e834a2dc76352191b8794094c1f5f4ab02c64950af61a40261b SHA512 4bed230091ddecf5a0dc043981ec9b0a177bee01262715b9cb9a2af0adefe2db52555416b795a70dd496e6fb0b132586bc7f32d2a480f1cfd6c4d40304076109 WHIRLPOOL 26d51d8cb7b2bbe2b7d754ad707023b796ad4f79d97c0af742b3514dde2f8bf14e165211b23d92aa8665cba324ce85d2272b966123ba56e2d83bd1f31bf40215
58 changes: 58 additions & 0 deletions games-arcade/netris/netris-0.52-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils games

DEB_VER=9
DESCRIPTION='Classic networked version of T*tris'
HOMEPAGE='http://www.netris.org/'
SRC_URI="ftp://ftp.netris.org/pub/netris/${P}.tar.gz
mirror://debian/pool/main/n/netris/netris_${PV}-${DEB_VER}.diff.gz"

LICENSE='GPL-2'
SLOT=0
KEYWORDS='~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd'
IUSE=''

DEPEND='sys-libs/ncurses:0='
RDEPEND=${DEPEND}

src_prepare() {
epatch "${WORKDIR}"/netris_${PV}-${DEB_VER}.diff
epatch netris-0.52/debian/patches/[01]*
# bug #185332
sed -i \
-e '/sys\/time/ i\
#include <sys/types.h> \
#include <time.h>
' \
-e '/netint2/ s/short/int16_t/' \
-e '/netint4/ s/long/int32_t/' \
netris.h || die
sed -i \
-e 's/volatile //g' \
-e '/Be more forgiving/d' \
-e 's/static myRandSeed/static int myRandSeed/' \
util.c || die
sed -i \
-e 's/\(long pauseTimeLeft\)/\1 = 0/' \
game.c || die
sed -i \
-e '/^CC/d' \
-e '/^COPT/d' \
-e '/^CFLAGS/d' \
-e 's/(LFLAGS)/(LDFLAGS) $(LFLAGS)/' \
Configure || die
}

src_configure() {
bash ./Configure -O || die
}

src_install() {
dogamesbin netris sr
dodoc FAQ README robot_desc
prepgamesdirs
}

0 comments on commit 5304a68

Please sign in to comment.