forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
xfce-extra/xfce4-weather-plugin: Bump to 0.8.10
- Loading branch information
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST xfce4-weather-plugin-0.8.10.tar.bz2 2991350 SHA256 ee6d43c444904631c240470e15e96215c2ce451158bfdbf234bce892bf60eab8 SHA512 e40f794e824cc48038ece0c1336eed21b2e28091b86a4b76099c092c2e45abc5041d010d286f64fc483e8ad7c496127152df86330187afbd0872506d89f37c35 WHIRLPOOL 96b7d1cfbc9ed763c7e48c914ce1a5c6f20dcf22517dc8a0303da297d0c82b7f0c8a7dc361e7a6f325002fa799378280fd5256805f150c71b58a26d44abb34ad | ||
DIST xfce4-weather-plugin-0.8.8.tar.bz2 2979971 SHA256 651b722714fdafde3f548f183958c34e1539cf563193d7e51f28bfb6933d6d3f SHA512 98e35d11bc57edf926228d7da2c5fbd4320f9dce0ff4fab232b81a98f4ff979c80575c077b9ffb161c54bf81f5da400b518838be881fbea82e5b1c37cae2c01a WHIRLPOOL 47118162fa35ab3b69018605190802ce17a2df9dcc4712bea267d262afe88c226bd0b58c9eb323957fe47e8531003fb6abe2f5dd4c05ea488874cc345966fa1d | ||
DIST xfce4-weather-plugin-0.8.9.tar.bz2 2966504 SHA256 0e15d14b3e18c3da46ad23ee3158a25220f1474a48b611de96edb56221aecee5 SHA512 bcc714bc369f8fe0dbcb2d42e4c99c0208539edf58adcecf5d0fb55ba05e763be9113a8197ed931b99f119ff4e4d54985824c612ba3b613da8b1a7ca717bacfd WHIRLPOOL b3357cefedeea36a6fcd210946e5b46b1216f7b2e98e30c6e0ae8382376d5da831570284365e8154bc1d1957e851904171072722b8231955661919cfcf24f555 |
46 changes: 46 additions & 0 deletions
46
xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit gnome2-utils | ||
|
||
DESCRIPTION="A weather plug-in for the Xfce desktop environment" | ||
HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin" | ||
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86" | ||
IUSE="upower" | ||
|
||
RDEPEND=">=dev-libs/glib-2.20:= | ||
dev-libs/libxml2:= | ||
>=net-libs/libsoup-2.32:= | ||
>=x11-libs/gtk+-2.14:2= | ||
>=xfce-base/libxfce4ui-4.10:= | ||
>=xfce-base/libxfce4util-4.10:= | ||
>=xfce-base/xfce4-panel-4.10:= | ||
upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )" | ||
DEPEND="${RDEPEND} | ||
dev-util/intltool | ||
virtual/pkgconfig" | ||
|
||
DOCS=( AUTHORS ChangeLog NEWS README TODO ) | ||
|
||
src_configure() { | ||
# For GEONAMES_USERNAME, read README file and ask ssuominen@! | ||
local myconf=( | ||
$(use_enable upower) | ||
GEONAMES_USERNAME=Gentoo | ||
) | ||
econf "${myconf[@]}" | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |