forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/gtk-builder-convert: Version bump
Package-Manager: portage-2.2.24
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST gtk+-2.24.25.tar.xz 13327832 SHA256 38af1020cb8ff3d10dda2c8807f11e92af9d2fa4045de61c62eedb7fbc7ea5b3 SHA512 e102eabbd86e9e697402b4d915172dd3838374b7b8a16b95369ed602228857a013fdba7b6b8d742f925ff8d340b63a90b56c1ddbd4405d8dc454144c705ac08d WHIRLPOOL b4bcf058bcc582627be35bb8ba45a933c3814f007599df59172e537fc99003f51edac7011cf36783caad4e191c622f6fa044a6ff6e0ae3f4de7635c3815807a3 | ||
DIST gtk+-2.24.27.tar.xz 13349252 SHA256 20cb10cae43999732a9af2e9aac4d1adebf2a9c2e1ba147050976abca5cd24f4 SHA512 ffe981a41137302713a411039238604e92d41146e25ea0643857ec40388ddfe69cbb15bdc1aa8300b87ddbb4d6fbcf0054cdb7ba39634fbe4bfd1802f5bc8ac6 WHIRLPOOL 02259afb7a410fe941b9cc20e8031d61d5dd90f2ac532e3b8525b203997cfa57999286cd59e76ef152a68de35f08e8712dc4b9cd107633f2ba2433eba633197c | ||
DIST gtk+-2.24.28.tar.xz 13354884 SHA256 b2c6441e98bc5232e5f9bba6965075dcf580a8726398f7374d39f90b88ed4656 SHA512 86d563645ca70c1e14afd4b38d925f496e596cbf6181f2e95310f58c2f4152aaecc559e3c513e6d405fcf48d8d413d59a9d72782216529c1280bd8e1947d7760 WHIRLPOOL b4943bb7792f962e0fc50a118f0dbce58a79678e1a98632717a2f3bda4ddd99b62ce9aed3b14f1c0912a4b53eb975991527843985f625c5a9e052db4889acfb0 | ||
DIST gtk+-2.24.29.tar.xz 13143648 SHA256 0741c59600d3d810a223866453dc2bbb18ce4723828681ba24aa6519c37631b8 SHA512 3cdc868b74831c35b9181edfe29fc7743118b5db6b4e742cc684cf5b7d8e87686f53c4460ee14dee635c25cfd1fd7aefb5cc472d022f0f77d83b6d3a881eff26 WHIRLPOOL 9a7bf26647ac9f10dea2d1f7a50fe36ba9d88c74784b6863e0e6572ab165a716774c84c1e067c61920e9a8bb08068bc765099d65d975b3778fee2abd8f80af37 |
38 changes: 38 additions & 0 deletions
38
dev-util/gtk-builder-convert/gtk-builder-convert-2.24.29.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GNOME_ORG_MODULE="gtk+" | ||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="xml" | ||
|
||
inherit gnome.org python-single-r1 | ||
|
||
DESCRIPTION="Converts Glade files to GtkBuilder XML format" | ||
HOMEPAGE="http://www.gtk.org/" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
|
||
IUSE="" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
# gtk-builder-convert was part of gtk+ until 2.24.10-r1 | ||
COMMON_DEPEND="${PYTHON_DEPS}" | ||
|
||
RDEPEND="${COMMON_DEPEND} | ||
!<=x11-libs/gtk+-2.24.10:2 | ||
" | ||
|
||
DEPEND="${COMMON_DEPEND}" | ||
|
||
src_configure() { :; } | ||
|
||
src_compile() { :; } | ||
|
||
src_install() { | ||
cd gtk || die | ||
python_doscript gtk-builder-convert | ||
} |