forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/portage: version bump to 2.3.13
#497596 - fix PORTAGE_RSYNC_RETRIES #635116 - is_prelinkable_elf: fix for python3 #635126 - file_copy: use sendfile return value to measure bytes copied #635474 - postinst_qa_check: initialize preinst state Package-Manager: Portage-2.3.13, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
251 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST portage-2.3.11.tar.bz2 940732 SHA256 f2596fc8e5eaaaab19be88c5c0a92d9f304eddb14ebe1230ab6f8d841ae90720 SHA512 16047fae060eb400e0fd01ca4966d69c0413e90659b33e4511b34464a24e9beb510c4c785af713921240e893c3031d3c3c3f2332eb175a21bb34b414962058fd WHIRLPOOL b0d357e626710c3574dde9228c68d604eb70843d083917d761a0c55680702da96d2157566e04d7f7c6c900d8120909d1faa00e6ff2a8fe970d53da05288ae0ad | ||
DIST portage-2.3.12.tar.bz2 944929 SHA256 4a6b6c1d038131d141b932b1ad93768a7823acd0704093c6c1e5adb9f913ba1d SHA512 39f6d938e167a96b338dc85191bfc25d6db2328014f13386dd2552b9a3c36308b9b4d444dcd3342e7f6761e26d97fc0b3e2c8a9092ef7aa863d55c26bdccfd3a WHIRLPOOL 34cc7567dfe4913129a451a8e8597c48382c6c423ec1a008db1fc489f5da99d5cf371ffa48b8449d799aa98e3f0dba98f7c8b55a4b8744fdb857f914448b6f5c | ||
DIST portage-2.3.13.tar.bz2 945477 SHA256 f3ed1445cf2bbfc6c5986873aff055e4caa3b695f37e033930ad2533bdea8d24 SHA512 71d9ea6c9a889572f60e7e501e9f8739db588cffd98a431303906eb90c1f7bb85c55f6779cbfb921630149d1b3174539fe2357fbeffbbe9857998907e3215ad3 WHIRLPOOL af9140e46d7e94994b276d93389c4953de77c77e9bf132c20b85bfdd477aaaeef2bb05293e94058158cf7800711ae7d1ff694d6ec9fd5e940849fd538b86c501 | ||
DIST portage-2.3.6.tar.bz2 943085 SHA256 2f57545fcb142a4b23c2052c523d3d858754b232be21455ee6c6cd3ff0903cc2 SHA512 5bcfb678c1ea0cd97a983ee7520c9ecabd07d5bb0fd01c70b74fd7b6ce478f4a109aac84d40b82426719ca7c9ee6aed3affb3b9754045e62b4c664ae113cf055 WHIRLPOOL d0258c579597690e8bf2cc2a3ecc36d543e67a728c302a9b16ae361086023a7e059ac1a9e2e64f026b7d975d6b619d3b981062227042098ed3afc1b86658b636 | ||
DIST portage-2.3.8.tar.bz2 938062 SHA256 19b73658dca848d215c5527d1d020c8106352007a84d7675e5efd0a7b9b48a8a SHA512 4b4b2de20323799b9b0f7a8812f939aa9a96d2744a0f65ad5287ba49744c491b55169cdb21f2885317a6a7c960d2070775ffd798f247b44eebc677c33c271eb8 WHIRLPOOL 0c576bbd8aaf8b27fa1746c863ac02b2a5f361d9011d17250ffbe4b830a8a6bf10a0aee48b5181a8aa6c55d8ad81ad411195da2a6253e9b324d3c7397053fe29 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,250 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( | ||
pypy | ||
python3_4 python3_5 python3_6 | ||
python2_7 | ||
) | ||
PYTHON_REQ_USE='bzip2(+),threads(+)' | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Portage is the package management and distribution system for Gentoo" | ||
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage" | ||
|
||
LICENSE="GPL-2" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd" | ||
SLOT="0" | ||
IUSE="build doc epydoc +ipc linguas_ru +native-extensions selinux xattr" | ||
|
||
DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') ) | ||
>=app-arch/tar-1.27 | ||
dev-lang/python-exec:2 | ||
>=sys-apps/sed-4.0.5 sys-devel/patch | ||
doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 ) | ||
epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )" | ||
# Require sandbox-2.2 for bug #288863. | ||
# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's | ||
# quite slow, so it's not considered in the dependencies as an alternative to | ||
# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so | ||
# for now, don't pull in xattr deps for other kernels. | ||
# For whirlpool hash, require python[ssl] (bug #425046). | ||
# For compgen, require bash[readline] (bug #445576). | ||
RDEPEND=" | ||
>=app-arch/tar-1.27 | ||
dev-lang/python-exec:2 | ||
!build? ( | ||
>=sys-apps/sed-4.0.5 | ||
app-shells/bash:0[readline] | ||
>=app-admin/eselect-1.2 | ||
) | ||
elibc_FreeBSD? ( sys-freebsd/freebsd-bin ) | ||
elibc_glibc? ( >=sys-apps/sandbox-2.2 ) | ||
elibc_musl? ( >=sys-apps/sandbox-2.2 ) | ||
elibc_uclibc? ( >=sys-apps/sandbox-2.2 ) | ||
>=app-misc/pax-utils-0.1.17 | ||
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] ) | ||
xattr? ( kernel_linux? ( | ||
>=sys-apps/install-xattr-0.3 | ||
$(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \ | ||
python2_7 pypy) | ||
) ) | ||
!<app-admin/logrotate-3.8.0" | ||
PDEPEND=" | ||
!build? ( | ||
>=net-misc/rsync-2.6.4 | ||
userland_GNU? ( >=sys-apps/coreutils-6.4 ) | ||
)" | ||
# coreutils-6.4 rdep is for date format in emerge-webrsync #164532 | ||
# NOTE: FEATURES=installsources requires debugedit and rsync | ||
|
||
REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )" | ||
|
||
SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives" | ||
|
||
prefix_src_archives() { | ||
local x y | ||
for x in ${@}; do | ||
for y in ${SRC_ARCHIVES}; do | ||
echo ${y}/${x} | ||
done | ||
done | ||
} | ||
|
||
TARBALL_PV=${PV} | ||
SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2 | ||
$(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)" | ||
|
||
pkg_setup() { | ||
use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 ) | ||
} | ||
|
||
python_prepare_all() { | ||
distutils-r1_python_prepare_all | ||
|
||
if use native-extensions; then | ||
printf "[build_ext]\nportage-ext-modules=true\n" >> \ | ||
setup.cfg || die | ||
fi | ||
|
||
if ! use ipc ; then | ||
einfo "Disabling ipc..." | ||
sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \ | ||
-i pym/_emerge/AbstractEbuildProcess.py || \ | ||
die "failed to patch AbstractEbuildProcess.py" | ||
fi | ||
|
||
if use xattr && use kernel_linux ; then | ||
einfo "Adding FEATURES=xattr to make.globals ..." | ||
echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \ | ||
|| die "failed to append to make.globals" | ||
fi | ||
|
||
if [[ -n ${EPREFIX} ]] ; then | ||
einfo "Setting portage.const.EPREFIX ..." | ||
sed -e "s|^\(SANDBOX_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/sandbox\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(FAKEROOT_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/bin/fakeroot\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(BASH_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/bash\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(MOVE_BINARY[[:space:]]*=[[:space:]]*\"\)\(/bin/mv\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(PRELINK_BINARY[[:space:]]*=[[:space:]]*\"\)\(/usr/sbin/prelink\"\)|\\1${EPREFIX}\\2|" \ | ||
-e "s|^\(EPREFIX[[:space:]]*=[[:space:]]*\"\).*|\\1${EPREFIX}\"|" \ | ||
-i pym/portage/const.py || \ | ||
die "Failed to patch portage.const.EPREFIX" | ||
|
||
einfo "Prefixing shebangs ..." | ||
while read -r -d $'\0' ; do | ||
local shebang=$(head -n1 "$REPLY") | ||
if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then | ||
sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \ | ||
die "sed failed" | ||
fi | ||
done < <(find . -type f -print0) | ||
|
||
einfo "Adjusting make.globals ..." | ||
sed -e "s|\(/usr/portage\)|${EPREFIX}\\1|" \ | ||
-e "s|^\(PORTAGE_TMPDIR=\"\)\(/var/tmp\"\)|\\1${EPREFIX}\\2|" \ | ||
-i cnf/make.globals || die "sed failed" | ||
|
||
einfo "Adjusting repos.conf ..." | ||
sed -e "s|^\(location = \)\(/usr/portage\)|\\1${EPREFIX}\\2|" \ | ||
-i cnf/repos.conf || die "sed failed" | ||
if prefix-guest ; then | ||
sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \ | ||
-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \ | ||
-e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \ | ||
-i cnf/repos.conf || die "sed failed" | ||
fi | ||
|
||
einfo "Adding FEATURES=force-prefix to make.globals ..." | ||
echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \ | ||
|| die "failed to append to make.globals" | ||
fi | ||
|
||
cd "${S}/cnf" || die | ||
if [ -f "make.conf.example.${ARCH}".diff ]; then | ||
patch make.conf.example "make.conf.example.${ARCH}".diff || \ | ||
die "Failed to patch make.conf.example" | ||
else | ||
eerror "" | ||
eerror "Portage does not have an arch-specific configuration for this arch." | ||
eerror "Please notify the arch maintainer about this issue. Using generic." | ||
eerror "" | ||
fi | ||
} | ||
|
||
python_compile_all() { | ||
local targets=() | ||
use doc && targets+=( docbook ) | ||
use epydoc && targets+=( epydoc ) | ||
|
||
if [[ ${targets[@]} ]]; then | ||
esetup.py "${targets[@]}" | ||
fi | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
python_install() { | ||
# Install sbin scripts to bindir for python-exec linking | ||
# they will be relocated in pkg_preinst() | ||
distutils-r1_python_install \ | ||
--system-prefix="${EPREFIX}/usr" \ | ||
--bindir="$(python_get_scriptdir)" \ | ||
--docdir="${EPREFIX}/usr/share/doc/${PF}" \ | ||
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \ | ||
--portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \ | ||
--sbindir="$(python_get_scriptdir)" \ | ||
--sysconfdir="${EPREFIX}/etc" \ | ||
"${@}" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
local targets=() | ||
use doc && targets+=( install_docbook ) | ||
use epydoc && targets+=( install_epydoc ) | ||
|
||
# install docs | ||
if [[ ${targets[@]} ]]; then | ||
esetup.py "${targets[@]}" | ||
fi | ||
|
||
# Due to distutils/python-exec limitations | ||
# these must be installed to /usr/bin. | ||
local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld' | ||
einfo "Moving admin scripts to the correct directory" | ||
dodir /usr/sbin | ||
for target in ${sbin_relocations}; do | ||
einfo "Moving /usr/bin/${target} to /usr/sbin/${target}" | ||
mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!" | ||
done | ||
} | ||
|
||
pkg_preinst() { | ||
# comment out sanity test until it is fixed to work | ||
# with the new PORTAGE_PYM_PATH | ||
#if [[ $ROOT == / ]] ; then | ||
## Run some minimal tests as a sanity check. | ||
#local test_runner=$(find "${ED}" -name runTests) | ||
#if [[ -n $test_runner && -x $test_runner ]] ; then | ||
#einfo "Running preinst sanity tests..." | ||
#"$test_runner" || die "preinst sanity tests failed" | ||
#fi | ||
#fi | ||
|
||
# elog dir must exist to avoid logrotate error for bug #415911. | ||
# This code runs in preinst in order to bypass the mapping of | ||
# portage:portage to root:root which happens after src_install. | ||
keepdir /var/log/portage/elog | ||
# This is allowed to fail if the user/group are invalid for prefix users. | ||
if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then | ||
chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog} | ||
fi | ||
|
||
if has_version ">=${CATEGORY}/${PN}-2.3.1" && \ | ||
has_version "<${CATEGORY}/${PN}-2.3.3"; then | ||
SYNC_DEPTH_UPGRADE=true | ||
else | ||
SYNC_DEPTH_UPGRADE=false | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
if ${SYNC_DEPTH_UPGRADE}; then | ||
ewarn "Please note that this release no longer respects sync-depth for" | ||
ewarn "git repositories. There have been too many problems and" | ||
ewarn "performance issues. See bugs 552814, 559008" | ||
fi | ||
einfo "" | ||
einfo "This release of portage NO LONGER contains the repoman code base." | ||
einfo "Repoman has its own ebuild and release package." | ||
einfo "For repoman functionality please emerge app-portage/repoman" | ||
einfo "Please report any bugs you may encounter." | ||
einfo "" | ||
} |