Skip to content

Commit

Permalink
kde-frameworks/kauth: revision bump to add Qt subslot operator
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0_rc1
  • Loading branch information
kensington committed Jun 19, 2016
1 parent d2e60c5 commit 53815d0
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions kde-frameworks/kauth/kauth-5.23.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="Framework to let applications perform actions as a privileged user"
LICENSE="LGPL-2.1+"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="nls +policykit"

# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
RDEPEND="
$(add_frameworks_dep kcoreaddons)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui '' '' '5=')
$(add_qt_dep qtwidgets)
policykit? ( sys-auth/polkit-qt[qt5] )
"
DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
"
PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package policykit PolkitQt5-1)
)

kde5_src_configure
}

0 comments on commit 53815d0

Please sign in to comment.