Skip to content

Commit

Permalink
net-misc/dropbox: bump to 48.3.56
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
perfinion committed Apr 18, 2018
1 parent 36b84a0 commit 539ef8e
Show file tree
Hide file tree
Showing 2 changed files with 126 additions and 0 deletions.
2 changes: 2 additions & 0 deletions net-misc/dropbox/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST dropbox-lnx.x86-45.3.88.tar.gz 108891513 BLAKE2B f72ea5663a2ea46b0c34294eb18e647f857c8769a3a341fe73b1d4d252a3c08f3add1613b0413e6909e3a5b770f32e473b3383a956c08fec78067736b5b66cbe SHA512 499249377c22452a8266402e6b4ab48f9a1cf1249c4354919a5861ccb7080e8df47d4ef7d757a1667b3511b82c9faf512de1aa1e2e35a939908f74976a728724
DIST dropbox-lnx.x86-48.3.56.tar.gz 108876564 BLAKE2B b809a220605265685026657e791aff3e716f7ff51e1fc5074d66df87eb8dc473c63c7513c94ca0715844c600fe71aaa3c42a108be4baee2e3e72baade97e3429 SHA512 3174c41e19a01cbd986c111711bc0df80b68882d595a5c869b81bfa1982b3f219da4cda852168bf7fdc9d67b91f52260017f4d25508f6372efd470536a6b96c8
DIST dropbox-lnx.x86_64-45.3.88.tar.gz 114967662 BLAKE2B 3276b3b20bc96eff3a756064c64b5a0e8ad28b27d29579dd6dc34043427bb209bc5d86be62651f6642f61af17388113ec9a1a4a211e3149ecb8679a4b8e505ca SHA512 d3a787487084237fff928afd6ec2192f27e196c589bba3c6bd8a501055d1a3d4c8dcb88b15336ea03bed38e2a02d0731bb9725cbb324bb6e00ec95e98ed671ea
DIST dropbox-lnx.x86_64-48.3.56.tar.gz 114940928 BLAKE2B 7d678344b59aa12bdbd28f3e425c0b80b15feae403911ef25a03150d1dfa47e94da1eb17d4b703feea6721d2fdfa721da54fab92e1a56b6b8f31456482bc3614 SHA512 cbd3eed71286be079aa8c898929dea305a4cefb9b5e2e41b196d07f68bfc3b5f2839f78d676a3fd7df62644fe00b9ad1930121bde88a6eea9c864d956ccb6f8e
124 changes: 124 additions & 0 deletions net-misc/dropbox/dropbox-48.3.56.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,124 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
inherit eutils gnome2-utils pax-utils systemd python-single-r1

DESCRIPTION="Dropbox daemon (pretends to be GUI-less)"
HOMEPAGE="http://dropbox.com/"
SRC_URI="
x86? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86-${PV}.tar.gz )
amd64? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz )"

LICENSE="CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-linux"
IUSE="+librsync-bundled selinux X"
RESTRICT="mirror strip"

QA_PREBUILT="opt/.*"
QA_EXECSTACK="opt/dropbox/dropbox"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="librsync-bundled? ( dev-util/patchelf )"

# Be sure to have GLIBCXX_3.4.9, #393125
# USE=X require wxGTK's dependencies. system-library cannot be used due to
# missing symbol (CtlColorEvent). #443686
RDEPEND="${PYTHON_DEPS}
X? (
dev-libs/glib:2
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5[-gles2,xcb]
dev-qt/qtopengl:5[-gles2]
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5[-gles2]
dev-qt/qtwebkit:5
dev-qt/qtwidgets:5[-gles2]
media-libs/fontconfig
media-libs/freetype
virtual/jpeg
x11-libs/libSM
x11-libs/libX11
x11-libs/libXinerama
x11-libs/libXxf86vm
x11-libs/pango[X]
x11-misc/wmctrl
x11-themes/hicolor-icon-theme
)
!librsync-bundled? ( <net-libs/librsync-2 )
selinux? ( sec-policy/selinux-dropbox )
app-arch/bzip2
dev-libs/popt
net-misc/wget
>=sys-devel/gcc-4.2.0
sys-libs/zlib
|| (
sys-libs/ncurses:5/5
sys-libs/ncurses:0/5
)"

src_unpack() {
unpack ${A}
mkdir -p "${S}" || die
mv "${WORKDIR}"/.dropbox-dist/* "${S}" || die
mv "${S}"/dropbox-lnx.*-${PV}/* "${S}" || die
rmdir "${S}"/dropbox-lnx.*-${PV}/ || die
rmdir .dropbox-dist || die
}

src_prepare() {
eapply_user

rm -vf libGL.so.1 libX11* libdrm.so.2 libffi.so.6 libpopt.so.0 wmctrl || die
# tray icon doesnt load when removing libQt5* (bug 641416)
#rm -vrf libQt5* libicu* qt.conf plugins/ || die
if use X ; then
mv images/hicolor/16x16/status "${T}" || die
else
rm -vrf PyQt5* *pyqt5* images || die
fi
if use librsync-bundled ; then
patchelf --set-rpath '$ORIGIN' librsyncffi.compiled._librsyncffi*.so || die
else
rm -vf librsync.so.1 || die
fi
pax-mark cm dropbox
mv README ACKNOWLEDGEMENTS "${T}" || die
}

src_install() {
local targetdir="/opt/dropbox"

insinto "${targetdir}"
doins -r *
fperms a+x "${targetdir}"/{dropbox,dropbox_py3,dropboxd}
dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"

use X && doicon -s 16 -c status "${T}"/status

make_desktop_entry "${PN}" "Dropbox"

newinitd "${FILESDIR}"/dropbox.initd dropbox
newconfd "${FILESDIR}"/dropbox.conf dropbox
systemd_newunit "${FILESDIR}"/dropbox_at.service-r1 "[email protected]"

dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 539ef8e

Please sign in to comment.